[soundnua]: gnome-control-center crashed with SIGSEGV in g_mutex_lock()

Bug #963457 reported by Guy Taylor on 2012-03-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Conor Curran
pulseaudio (Ubuntu)
Undecided
David Henningsson

Bug Description

When changing a audio input between two sound cards.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Fri Mar 23 20:54:51 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
ProcCmdline: gnome-control-center sound-nua
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: gnome-control-center
Title: [soundnua]: gnome-control-center crashed with SIGSEGV in g_mutex_lock()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Guy Taylor (thebiggerguy) wrote :

StacktraceTop:
 g_mutex_lock (mutex=0xb6ea52e4) at /build/buildd/glib2.0-2.31.22/./glib/gthread-posix.c:208
 g_object_notify_queue_freeze (object=0xb80bce88, conditional=0) at /build/buildd/glib2.0-2.31.22/./gobject/gobject.c:226
 g_object_freeze_notify (object=0xb80bce88) at /build/buildd/glib2.0-2.31.22/./gobject/gobject.c:1087
 apply_cell_attributes (renderer=0xb80bce88, info=0xb8150b08, data=0xbf6f114c) at /build/buildd/gtk+3.0-3.3.20/./gtk/gtkcellarea.c:1257
 g_hash_table_foreach (hash_table=0xb814ce38, func=0xb72a2e10 <apply_cell_attributes>, user_data=0xbf6f114c) at /build/buildd/glib2.0-2.31.22/./glib/ghash.c:1524

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Guy Taylor (thebiggerguy) wrote :

I would like to suggest this as a higher priority as it prevent use of any sound recording on computers with multiple sound cards.

visibility: private → public
Conor Curran (cjcurran) on 2012-03-26
Changed in gnome-control-center (Ubuntu):
status: New → In Progress
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) wrote :
Conor Curran (cjcurran) wrote :

Guy, could copy that file attached above using:

open terminal.
cd to the directory where the libsoundnua.so exists and run this command :

sudo cp libsoundnua.so /usr/lib/control-center-1/panels/

Then run the control center from terminal, reproduce the crash and copy and paste the complete terminal output here.

Thanks !

Conor Curran (cjcurran) wrote :

Guy could you at least tell me what sound cards you're changing between. I have not been able to produce this with my setup. I have been testing with HDA Intel, usb headsets, echo layla 24 rack mounts. bluetooth headsets, and network sources.

Conor Curran (cjcurran) wrote :
Guy Taylor (thebiggerguy) wrote :

Sorry but I am unable to assist with this bug until after the 4th April as I have to finish my Uni Honours dissertation. I will be more than happy to help after such time.

This bug consistently appeared when changing from the internal audio, Realtek ALC269, to an external USB sound card. The following USB products where tested:
 * http://www.roland.com/products/en/UA-1EX/ (In basic and advanced mode)
 * http://www.behringer.com/EN/Products/UFO202.aspx
 * http://www.behringer.com/EN/Products/UCA222.aspx

It was only present when changing the inputs and not outputs tab in the sound control centre. I attempted to use the original pulseaudio manager, but found it has been removed from the repositories (or I couldn't find it), in an attempt to localise if it was a pulseaudio or control-centre issue.

This issue was not present when switching outputs on these cards or between internal and Bluetooth output.

Conor Curran (cjcurran) wrote :

Thanks Guy, the fact that you have confirmed that it is specific to a USB card helps alot and pretty much confirms that it is a dupe of the bug above. Working on it presently.

Conor

Conor Curran (cjcurran) wrote :

Guy, any chance you could start control centre from terminal, recreate the crash and paste the output on terminal here. I was going to buy one of those behringer cards you list above to fix this.

Guy Taylor (thebiggerguy) wrote :

guy@Other:~$ gnome-control-center --verbose > sound.log

(gnome-control-center:3198): Gtk-WARNING **: Attempting to add a widget with type GtkBox to a container of type GtkScrolledWindow, but the widget is already inside a container of type GtkAlignment, please use gtk_widget_reparent()

(gnome-control-center:3198): Gtk-WARNING **: Attempting to add a widget with type GtkBox to a container of type GtkScrolledWindow, but the widget is already inside a container of type GtkBox, please use gtk_widget_reparent()
Segmentation fault (core dumped)
guy@Other:~$

-------------------------
gnome-control-center: 1:3.4.0-0ubuntu4

Conor Curran (cjcurran) wrote :

Hi Guy,

I have been testing today to try to reproduce this. I have number of duplicates which give roughly the same error, they are all slightly different hence why I have not marked as duplicate but I suspect that a singular fix 'should' resolve them all.

Could you please try something ?

Please modify /usr/share/pulseaudio/alsa-mixer/paths/analog-input.conf
comment out "required = volume" from the [Element Capture] section.

You can comment out with '#'.

Then restart and see if the bug is still present.

thanks,
Conor

Guy Taylor (thebiggerguy) wrote :

That has prevented the crash. I can have tested it and the input now can be selected and functions (using sound out via internal into UF0202).

The Behringer UF0202 works in both "line" and "phono" as it is internal to the device. However it is displayed as two separate input and two separate output devices. A "Digital Output (S/PDIF)" and "Analogue Output" with "Analogue Input" and "iec958-stereo-input". Both input devices work when selected, both proving the same audio. I cannot test the output at the moment. The UF0202 has no SPDIF interface (documented) however I have the suspicion that it is the same hardware as the "U-CONTROL UCA222". Can this quirk be put in ALSA to prevent confusion and can there be a standardisation on "iec958" and "S/PDIF"?

Please feel free to ask for any more testing.

Guy Taylor (thebiggerguy) wrote :

Moved the S/PDIF issue to 978360 and 978370

Guy Taylor (thebiggerguy) wrote :

Looking into the specs (http://www.ti.com/product/pcm2902) the sound card should have a input volume.

Sebastien Bacher (seb128) wrote :

David, Ronoc hinted that the issue could be due to pulseaudio, let me know if that's correct

Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
David Henningsson (diwic) wrote :

@Guy Taylor, as a workaround you can use the "pavucontrol" application, available in the repositories as the "pavucontrol" package.

@Seb128, looking from the stack trace, it does not look like PulseAudio's client API is involved in the infinite recursion. I'm marking this as invalid for PulseAudio. Conor might have meant bug 978109 - without that, maybe this infinite recursion bug would not have surfaced.

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
status: Incomplete → Invalid
Sebastien Bacher (seb128) wrote :

@David: thanks, that was probably it, I milestoned that bug for precise, we should try to address it for precise or in a SRU seeing the impact it has on the new sound capplet

Conor Curran (cjcurran) wrote :

I have not been able to reproduce this but my suspicion is that certain devices appear without ports and when the user attempts to move to them the current pattern gets itself into a muddle. This infinite recursion is one of the types of muddles we have witnessed over the past few weeks. Going by the bug reports, it usually occurs with input devices on usb cards.

The problem seems to be resolved by allowing the software centre to see ports that do not have volumes attached hence why I thought this is essentially a pulse audio bug. By allowing that visibility the devices will be treated properly and not incorrectly fall into the category of a bluetooth or network sink/source.

Conor Curran (cjcurran) wrote :

David, this is the pulsaudio bug Seb is referring to
https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/978109

Conor Curran (cjcurran) on 2012-04-16
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers