Clicking System Settings window closes "Locations" window

Bug #947315 reported by Matthew Paul Thomas on 2012-03-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Low
Charles Kerr
gnome-control-center (Ubuntu)
Low
Unassigned
indicator-datetime (Ubuntu)
Low
Unassigned

Bug Description

indicator-datetime 0.3.90-0ubuntu1, Ubuntu 12.04 beta

1. Open the Time & Date settings.
2. Click "Clock".
3. Check "Time in other locations" if necessary.
4. Click "Locations…"
5. Click anywhere in the System Settings window.

What happens:
5. The "Locations" window closes.

What should happen:
5. The "Locations" window stays open.

Related branches

Robert Roth (evfool) on 2012-03-06
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Olli Ries (ories) on 2012-03-27
Changed in indicator-datetime:
status: New → Triaged
importance: Undecided → Low
Bilal Akhtar (bilalakhtar) wrote :

This affects GNOME Control Center, since it manages that window.

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Charles Kerr (charlesk) wrote :

I know this is a low priority bug but I know what's causing this and think it's got a proverbial Quick Fix...

Changed in indicator-datetime:
assignee: nobody → Charles Kerr (charlesk)
status: Triaged → In Progress
Charles Kerr (charlesk) on 2012-04-02
Changed in indicator-datetime:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.3.94-0ubuntu1

---------------
indicator-datetime (0.3.94-0ubuntu1) precise; urgency=low

  * New upstream release.
    * Fix location timezone sorting issue.
    * Clicking the systems settings window shouldn't close the
      Locations dialog. (LP: #947315)
    * Add gcov targets to autotools build for code-coverage reporting.
 -- Charles Kerr <email address hidden> Wed, 04 Apr 2012 16:53:20 -0500

Changed in indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in indicator-datetime:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers