Installing gnome-control-center installs Unity

Bug #939882 reported by Sergey "Shnatsel" Davidoff on 2012-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Wishlist
Unassigned

Bug Description

In Ubuntu Precise, gnome-control-center package recommends gnome-session package, which depends on Unity. Despite its name, gnome-session package is not even related to GNOME - it ships configuration files for Unity session, and the actual gnome-session binary is in gnome-session-bin package. So right now gnome-control-center effectively recommends Unity, which is probably not the intended behavior. In addition, it's hard to make a derivative distro with GNOME but without Unity this way.

Related branches

tags: added: packaging ubuntu
tags: added: derivatives
Sebastien Bacher (seb128) wrote :

thank you for your bug report, not it doesn't, gnome-session has a "Recommends: unity | unity-2d | gnome-shell (>= 3.0)", i.e it lists alternative and is only a recommends

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
status: New → Invalid
Sebastien Bacher (seb128) wrote :

note that gnome-control-center is integrated in GNOME nowadays and it doesn't really make sense to want to use it under other desktop environments than the one listed in that recommends list

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers