System Settings 'User Interface' name is bad in 12.04

Bug #918580 reported by Mark East on 2012-01-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
gnome-control-center (Ubuntu)
Wishlist
Didier Roche

Bug Description

I updated my 12.04 installation and noticed that in the System Settings section that Appearance has changed its name to User Interface. That name is a term that beginner users will not be familiar with and will most likely avoid clicking. Appearance is a much better name and has more meaning for the end user. These sorts of terms need to be avoided if Ubuntu wants to target less techy users and portray itself as a user friendly environment.

Solution

Keep "Appearance" as main entry, as it was in 11.10, and call the two tabs: "Look" and "Behavior"

Robert Roth (evfool) on 2012-01-19
affects: ubuntu → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the name was suggested by designers, see https://docs.google.com/a/canonical.com/document/d/1ILTJDiDCd25Npt2AmgzF8aOnZZECxTfM0hvsbWT2BxA/edit?hl=en_GB

section "2.2": This panel should be renamed to “User Interface”.

Opening an ayatana-design component so they can review your comment, the idea seems to be that the dialog will add options out of the appaerance configuration

Changed in gnome-control-center (Ubuntu):
importance: Low → Wishlist
Mark East (feasty) wrote :

I see the comment but there doesn't appear to be any reason for it! I think they're just not thinking of the non technical user. If my girlfriend, her parents or my dad (all Ubuntu users but far from technical) saw the term "User Interface" they wouldn't know what it was and they certainly wouldn't click on it because it has the term 'Interface' in, which sounds technical and low level. They are quite happy to click on a button that is labelled "Appearence" though as it has more meaning to them. It's this sort of terminology that just puts people off Linux and keeps its reputation as a techies playground. The designrs should remember that people who aren't technical, especially those who are older, are afraid that what ever they do on a computer is going to break it and unfriendly names like that is just going to intimidate more.

Mark East (feasty) wrote :

Thanks for doing that though :)

Sebastien Bacher (seb128) wrote :

setting the Ubuntu side to incomplete waiting on design input

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
dobey (dobey) wrote :

This really should be Appearance. It's a sensible name with the theme selection added, from the upstream Background. I can only imagine it was changed to User Interface with the idea that the Unity configuration pieces would be added to it (and which are now). I think these probably don't belong in this configuration panel, and will be opening a separate bug for that.

Jeremy Bicha (jbicha) wrote :

Since System Settings sorts panels alphabetically, using the Appearance name from 11.10 will put the panel in the first position in English which is convenient since changing the wallpapers is considering to be a very common customization task.

dobey (dobey) wrote :

Jeremy, true. And that's where everyone looks for it, since that's where it used to be. I was definitely confused for a second when I went to change the background (because there was a problem with it loading), and saw no Appearance settings in the top left of the control center.

Mark East (feasty) wrote :

It's also the fact that 'User Interface' is meaningless to most people non technical. I'm not so concerned about the positioning of it as people can find it if it has a sensible name (although you're right, the beginning is better) but with a name like User Interface they're likely to avoid it. It's a poor choice of name and had no justification for it in the design.

Appearance is fine by me.

For the tabs, perhaps "Style" and "Behaviour"?

Mark

description: updated
Changed in ayatana-design:
status: New → Confirmed
importance: Undecided → High
Mark East (feasty) wrote :

Rename it to Desktop??? Everyone is happy with Appearance and that would keep it consistent with previous releases.

@Feasty we are going to stick with Appearance for the main entry. We need to find a better name for the first tab. Any suggestions besides Style and Look?

description: updated
Changed in ayatana-design:
status: Confirmed → In Progress
Mark East (feasty) wrote :

I think either style or look is a good name for the first tab. I'm more in favour of look because I think that best encompasses the background, theme and launcher icon size options.

Mark Shuttleworth (sabdfl) wrote :

Would launcher icon size not fit better on the "Behaviour" tab?

Could we see a mockup of the planned full set of exposed settings, please?

Mark

Mark East (feasty) wrote :

Should Launcher icon size not be in the Universal Access are of the Setting section in the seeing tab? If not exclusively then maybe as well as?

Mark East (feasty) wrote :

I personally think that the Launcher icon size should stay in the first tab (if it's staying in the Appearence settings and not moving to Universal Access) as it doesn't actually change any behavioral aspects of the launcher.

@sabdfl, the latest spec defining the changes on System Settings are here: https://docs.google.com/a/canonical.com/document/d/1ILTJDiDCd25Npt2AmgzF8aOnZZECxTfM0hvsbWT2BxA/edit?hl=en_US
(no fix for this bug available yet)

I agree with feasty that Launcher size is not behavior and I see why it could join font size in Universal Access.

To direct people which would like to have text or tiles a bit bigger to the Universal Access panel, we could add to the first panel a link: http://ubuntuone.com/5Y86M90lZ943dKrdifIPw0

Mark East (feasty) wrote :

That's a good idea. Would it also be a good idea to inclue the Universal Access symbol next to the button somewhere to help people identify it? I was just thinking that it might be good to keep all links to areas consistent with their symbols. What do you think? I don't know if that would look ok on a panel like that.

description: updated
Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
description: updated
description: updated
John Lea (johnlea) on 2012-02-03
Changed in ayatana-design:
status: In Progress → Fix Committed
assignee: nobody → John Lea (johnlea)
Didier Roche (didrocks) on 2012-02-06
Changed in gnome-control-center (Ubuntu):
status: New → Fix Committed
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.2.2-2ubuntu6

---------------
gnome-control-center (1:3.2.2-2ubuntu6) precise; urgency=low

  [ Aurélien Gâteau ]
  * debian/patches/58_ubuntu_icon_views_redesign.patch
    - Implement the new category headers (LP: #921061)

  [ Didier Roche ]
  * debian/patches/04_new_appearance_settings.patch, respect new
    design requests:
    - High Contrast misspelled as "HighContrast" etc (LP: #878790)
    - The scope of "Restore defaults" button in Appearance>Behavior is
      not clear enough (LP: #924253)
    - Add a new launcher reveal slider (LP: #923749)
    - The Background section in Appearance panel should have an option
      to display the dotted grid (LP: #922544)
    - Restore Defaults buttons in appearance should be replaced with in
      context hints (LP: #922543)
    - Rename tabs to look and User Interface to Background (LP: #918580)

  [ Christopher James Halse Rogers ]
  * debian/patches/59_install_gcm_components_on_demand.patch:
    - Install gnome-color-manager tools on-demand. Fixes the "calibrate"
      and "View profile" buttons without requiring us to install 33MB of
      Arygll on the CDs. (LP: #868803)
 -- Didier Roche <email address hidden> Tue, 07 Feb 2012 18:13:21 +0100

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Mark East (feasty) wrote :

Just had a look at the update and I have to say the System Settings looks a lot better now that the icons have been redone to a larger size. Impressive stuff! It reads much better with the name Appearance and look.

I take it the decision not to move the launcher icon size into the Universal Access section was on purpose?

@feasty, moving the launcher size in UA is a good idea. Unfortunately it came up a bit too late, but it will definitely be taken into consideration for 12.10. Thanks!

Mark East (feasty) wrote :

@nuthinking Ok. Out of interest, what ever happened to the launcher size bar because my latest update appears to have removed it completely from the options? Was this intentional?

@feasty, if you are referring still to the launcher size, that option is not available anymore where is not supported (ie. Unity 2D).

Mark East (feasty) wrote :

@nuthinking Ah ok, that's why then, I switched to Unity 2d. Also, the designs show the menu integration option but I don't see that in the Appearance options on my system and I know a few people were looking forward to that. What happened to that one? (last question I promise)

@feasty, John Lea is the best person to answer this. I think it should land soon.

Nick Tait (jnick-tait) on 2012-03-07
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers