gnome-control-center crashed with SIGSEGV in refresh_ui()

Bug #912948 reported by Tormod Volden on 2012-01-06
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Invalid
Medium
gnome-control-center (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

I was dealing with the Network preferences.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.2.2-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic-pae 3.2.0-rc7
Uname: Linux 3.2.0-7-generic-pae i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Jan 6 23:09:27 2012
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111225)
ProcCmdline: gnome-control-center
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xafecdf29: mov 0x18(%esi),%ecx
 PC (0xafecdf29) ok
 source "0x18(%esi)" (0xaaaaaac2) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/control-center-1/panels/libnetwork.so
 g_cclosure_marshal_VOID__VOID () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_gnome-control-center:
 deja-dup 21.2-0ubuntu2
 gnome-bluetooth 3.2.1-1ubuntu3
 indicator-datetime 0.3.1-0ubuntu2

Tormod Volden (tormodvolden) wrote :

StacktraceTop:
 refresh_ui (panel=0xb958e000) at cc-network-panel.c:2205
 g_cclosure_marshal_VOID__VOID (closure=0xb9424a98, return_value=0x0, n_param_values=1, param_values=0xb974b838, invocation_hint=0xbfb81e70, marshal_data=0x0) at /build/buildd/glib2.0-2.31.6/./gobject/gmarshal.c:85
 g_closure_invoke (closure=0xb9424a98, return_value=0x0, n_param_values=1, param_values=0xb974b838, invocation_hint=0xbfb81e70) at /build/buildd/glib2.0-2.31.6/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=0xb938d070, detail=0, instance=0xb96321b8, emission_return=0x0, instance_and_params=0xb974b838) at /build/buildd/glib2.0-2.31.6/./gobject/gsignal.c:3302
 g_signal_emit_valist (instance=0xb96321b8, signal_id=316, detail=0, var_args=0xbfb8201c "\320\207V\271'}\354\257${\355\257\030\324q\271<\201\354\257\270!c\271\b\355\\\271\240!\270\277V\177\356\266\030\324q\271\026\201\354\257\364\377\343\257\021\005\343\257\030\364=\271(") at /build/buildd/glib2.0-2.31.6/./gobject/gsignal.c:3033

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
summary: - gnome-control-center crashed with SIGSEGV in
- g_cclosure_marshal_VOID__VOID()
+ gnome-control-center crashed with SIGSEGV in refresh_ui()
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
tags: added: apport-request-retrace
tags: added: apport-require-retrace
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed

After applying my patch to bug 908670; I can't manage to crash the network panel at all. I suspect this is really just another instance of the same crash, hidden somehow since it would depend on how the crash gets triggered.

Hello Tormod, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed

If you can reproduce this bug, please see Martin Pitt's comment to enable the Proposed repositories and update to the new gnome-control-center package for testing.

Sebastien Bacher (seb128) wrote :

There issue has no specific steps to be triggered but the fix seems fine, no regression was reported and the capplet works fine here, setting as verification-done

tags: added: verification-done
removed: verification-needed

This issue occured in gnome-shell, i using unity now, and does not appear.

On Sat, May 12, 2012 at 12:38 AM, Mathieu Trudel-Lapierre <
<email address hidden>> wrote:

> If you can reproduce this bug, please see Martin Pitt's comment to
> enable the Proposed repositories and update to the new gnome-control-
> center package for testing.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (970115).
> https://bugs.launchpad.net/bugs/912948
>
> Title:
> gnome-control-center crashed with SIGSEGV in refresh_ui()
>
> Status in GNOME Control Center:
> Confirmed
> Status in “gnome-control-center” package in Ubuntu:
> Triaged
> Status in “gnome-control-center” source package in Precise:
> Fix Committed
>
> Bug description:
> I was dealing with the Network preferences.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: gnome-control-center 1:3.2.2-0ubuntu5
> ProcVersionSignature: Ubuntu 3.2.0-7.13-generic-pae 3.2.0-rc7
> Uname: Linux 3.2.0-7-generic-pae i686
> ApportVersion: 1.90-0ubuntu1
> Architecture: i386
> Date: Fri Jan 6 23:09:27 2012
> ExecutablePath: /usr/bin/gnome-control-center
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386
> (20111225)
> ProcCmdline: gnome-control-center
> ProcEnviron:
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0xafecdf29: mov 0x18(%esi),%ecx
> PC (0xafecdf29) ok
> source "0x18(%esi)" (0xaaaaaac2) not located in a known VMA region
> (needed readable region)!
> destination "%ecx" ok
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: gnome-control-center
> StacktraceTop:
> ?? () from /usr/lib/control-center-1/panels/libnetwork.so
> g_cclosure_marshal_VOID__VOID () from
> /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
> g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
> Title: gnome-control-center crashed with SIGSEGV in
> g_cclosure_marshal_VOID__VOID()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> usr_lib_gnome-control-center:
> deja-dup 21.2-0ubuntu2
> gnome-bluetooth 3.2.1-1ubuntu3
> indicator-datetime 0.3.1-0ubuntu2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/912948/+subscriptions
>

--
Regards

张京
Zhang Jing

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.1-0ubuntu2

---------------
gnome-control-center (1:3.4.1-0ubuntu2) precise-proposed; urgency=low

  * debian/patches/deal_with_null_ssid.patch: don't try to dereference ssid when
    it's NULL (i.e. for non-broadcasting APs). (LP: #908670, #912948)

  [ Conor Curran & David Henningsson ]
  * debian/patches/96_sound_nua_panel.patch:
    - updated version including fixes for
    - "moving running input stream fails" (lp: #984637)
    - "peak detection on input tab doubles up on level"(lp: #987626)
    - "SIGSEGV in gvc_mixer_ui_device_get_description()" (lp: #982495)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 27 Apr 2012 12:04:53 -0400

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.