[network]: gnome-control-center crashed with SIGSEGV in panel_get_strongest_unique_aps()

Bug #908670 reported by Vince on 2011-12-26
258
This bug affects 38 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Critical
gnome-control-center (Ubuntu)
High
Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre

Bug Description

[Impact]
High impact: this causes gnome-control-center to be likely to crash in any situation where a non-SSID-broadcasting AP is in range, when opening the Network panel in gnome-control-center (System Settings).

[Development Fix]
Obvious simple and safe fix; avoid listing non-broadcasting APs, since their SSID will be unavailable anyway. This is consistent with the behavior in nm-applet. Patch in the upstream bug was developped in collaboration with the upstream NetworkManager developers; see https://bugzilla.gnome.org/show_bug.cgi?id=672922.

[Stable Fix]
See "Development Fix".

[Test Case]
Open the Network panel; observe crash or lack of crash ;)

[Regression Potential]
Very low: non-SSID-broadcasting APs don't have an SSID name to speak of that could be listed, precisely because it's not being broadcasted. :) Other applications behave the same way and don't display an SSID for these type of APs, requiring the user to connect to such a network manually.

---

Opened network folder.Tried connect to my lan then the gnome-control-center crashed

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.2.2-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
Uname: Linux 3.2.0-6-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Sun Dec 25 23:10:20 2011
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: gnome-control-center
SegvAnalysis:
 Segfault happened at: 0x1f86d46f: mov 0x4(%edx),%eax
 PC (0x1f86d46f) ok
 source "0x4(%edx)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/control-center-1/panels/libnetwork.so
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: Upgraded to precise on 2011-12-10 (16 days ago)
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
usr_lib_gnome-control-center:
 deja-dup 21.2-0ubuntu2
 gnome-bluetooth 3.2.1-1ubuntu3
 indicator-datetime 0.3.1-0ubuntu2

Vince (thehappytrucker) wrote :

StacktraceTop:
 panel_get_strongest_unique_aps (aps=0x21db5c00) at cc-network-panel.c:1086
 device_refresh_wifi_ui (device=<optimized out>, panel=0x21e9d810) at cc-network-panel.c:1783
 nm_device_refresh_device_ui (device=<optimized out>, panel=0x21e9d810) at cc-network-panel.c:1884
 refresh_ui_idle (data=0x21e9d810) at cc-network-panel.c:2194
 g_idle_dispatch (source=0x21fc7518, callback=0x1f86bb60 <refresh_ui_idle>, user_data=0x21e9d810) at /build/buildd/glib2.0-2.31.4.tested/./glib/gmain.c:4632

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
summary: - gnome-control-center crashed with SIGSEGV in g_main_context_dispatch()
+ gnome-control-center crashed with SIGSEGV in
+ panel_get_strongest_unique_aps()
tags: removed: need-i386-retrace
visibility: private → public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Medium → High
tags: added: apport-request-retrace
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-control-center:
importance: Medium → Critical

Package: gnome-control-center 1:3.4.0-0ubuntu2
ProcCmdline: gnome-control-center

tags: removed: apport-request-retrace

That bug is getting quite some duplicates, Mathieu could you have a look?

Changed in gnome-control-center (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Confirmed → Triaged
summary: - gnome-control-center crashed with SIGSEGV in
+ [network]: gnome-control-center crashed with SIGSEGV in
panel_get_strongest_unique_aps()

I don't know if it is the same thing, but I have been having lots of issues
lately due to apparmor blocking gnome. I worked around it by disabling
apparmor in the kernel.
 On Apr 16, 2012 4:45 PM, "Sebastien Bacher" <email address hidden> wrote:

> That bug is getting quite some duplicates, Mathieu could you have a
> look?
>
> ** Also affects: gnome-control-center (Ubuntu Precise)
> Importance: High
> Status: Confirmed
>
> ** Changed in: gnome-control-center (Ubuntu Precise)
> Status: Confirmed => Triaged
>
> ** Changed in: gnome-control-center (Ubuntu Precise)
> Assignee: (unassigned) => Mathieu Trudel-Lapierre (mathieu-tl)
>
> ** Summary changed:
>
> - gnome-control-center crashed with SIGSEGV in
> panel_get_strongest_unique_aps()
> + [network]: gnome-control-center crashed with SIGSEGV in
> panel_get_strongest_unique_aps()
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (938038).
> https://bugs.launchpad.net/bugs/908670
>
> Title:
> [network]: gnome-control-center crashed with SIGSEGV in
> panel_get_strongest_unique_aps()
>
> Status in GNOME Control Center:
> Confirmed
> Status in “gnome-control-center” package in Ubuntu:
> Triaged
> Status in “gnome-control-center” source package in Precise:
> Triaged
>
> Bug description:
> Opened network folder.Tried connect to my lan then the gnome-control-
> center crashed
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: gnome-control-center 1:3.2.2-0ubuntu5
> ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
> Uname: Linux 3.2.0-6-generic i686
> ApportVersion: 1.90-0ubuntu1
> Architecture: i386
> Date: Sun Dec 25 23:10:20 2011
> ExecutablePath: /usr/bin/gnome-control-center
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
> ProcCmdline: gnome-control-center
> SegvAnalysis:
> Segfault happened at: 0x1f86d46f: mov 0x4(%edx),%eax
> PC (0x1f86d46f) ok
> source "0x4(%edx)" (0x00000004) not located in a known VMA region
> (needed readable region)!
> destination "%eax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: gnome-control-center
> StacktraceTop:
> ?? () from /usr/lib/control-center-1/panels/libnetwork.so
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
> ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
> g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
> Title: gnome-control-center crashed with SIGSEGV in
> g_main_context_dispatch()
> UpgradeStatus: Upgraded to precise on 2011-12-10 (16 days ago)
> UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
> usr_lib_gnome-control-center:
> deja-dup 21.2-0ubuntu2
> gnome-bluetooth 3.2.1-1ubuntu3
> indicator-datetime 0.3.1-0ubuntu2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/908670/+subscriptions
>

Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → In Progress

I'll go guessing wildly there, but I think this is all due to just how g-c-c is getting the AP list. The list is first populated, then re-processes to get SSIDs. At any point in time during the reprocessing, if an APs signal was low enough that it disappeared from the scan results since it was added to the AP list used by g-c-c, trying to get its SSID will return a NULL GByteArray object. We then try to get a member of that object to escape SSIDs, which will fail.

Wow - that explanation was so far over my head.

The question is - can it be fixed?

 Get a signature like this.
<http://r1.wisestamp.com/r/landing?promo=19&dest=http%3A%2F%2Fwww.wisestamp.com%2Femail-install%3Futm_source%3Dextension%26utm_medium%3Demail%26utm_campaign%3Dpromo_19>
CLICK
HERE.<http://r1.wisestamp.com/r/landing?promo=19&dest=http%3A%2F%2Fwww.wisestamp.com%2Femail-install%3Futm_source%3Dextension%26utm_medium%3Demail%26utm_campaign%3Dpromo_19>

On Fri, Apr 20, 2012 at 12:13 PM, Mathieu Trudel-Lapierre <
<email address hidden>> wrote:

> I'll go guessing wildly there, but I think this is all due to just how
> g-c-c is getting the AP list. The list is first populated, then re-
> processes to get SSIDs. At any point in time during the reprocessing, if
> an APs signal was low enough that it disappeared from the scan results
> since it was added to the AP list used by g-c-c, trying to get its SSID
> will return a NULL GByteArray object. We then try to get a member of
> that object to escape SSIDs, which will fail.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (982726).
> https://bugs.launchpad.net/bugs/908670
>
> Title:
> [network]: gnome-control-center crashed with SIGSEGV in
> panel_get_strongest_unique_aps()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/908670/+subscriptions
>

There's a patch ready, we'll upload it to precise-proposed soon and it will be fixed for the release.

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
description: updated

Bug 912948 is relevant. After applying my patch, I'm not able to reproduce either crashes. I'll mark both as fixed by the change.

Uploaded to precise-proposed, awaiting approval by the sru team.

Hello Vince, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

If you can reproduce this bug, please see Martin Pitt's comment to enable the Proposed repositories and update to the new gnome-control-center package for testing.

Tormod Volden (tormodvolden) wrote :

Martin (and Mathieu), it would be helpful if you could include the package version in question in your "accepted into ... -proposed" boiler-plate.

Anyway, I think I was never able to systematically reproduce this bug and did not see it often, so I will have difficulties to confirm any fix. Using 1:3.4.1-0ubuntu1 now (which I believe does not have your fix) but I can not make it crash by clicking around in the Network preferences. If the crash is dependent on having a hidden ESSID in the neighbourhood it is even more difficult to test it conclusively.

Tormod Volden (tormodvolden) wrote :

Sorry, the above comment was meant for bug 912948. Well, it is maybe the same bug anyway.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.1-0ubuntu2

---------------
gnome-control-center (1:3.4.1-0ubuntu2) precise-proposed; urgency=low

  * debian/patches/deal_with_null_ssid.patch: don't try to dereference ssid when
    it's NULL (i.e. for non-broadcasting APs). (LP: #908670, #912948)

  [ Conor Curran & David Henningsson ]
  * debian/patches/96_sound_nua_panel.patch:
    - updated version including fixes for
    - "moving running input stream fails" (lp: #984637)
    - "peak detection on input tab doubles up on level"(lp: #987626)
    - "SIGSEGV in gvc_mixer_ui_device_get_description()" (lp: #982495)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 27 Apr 2012 12:04:53 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
status: Confirmed → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Kevin

Kevin Crocker
Consultant/Instructor/Educational Evangelist at Pivotal, Inc.
Cleveland/Akron, Ohio Area

Confirm that you know Kevin Crocker:
https://www.linkedin.com/e/-ujawa6-hryf2jil-17/isd/20308478438/JTRLGAtp/?hs=false&tok=1K7txY_DE9hm81

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/-ujawa6-hryf2jil-17/T5RsfQLTTIL4vMOXYUyf9vCTJdHQkpZweV-UlXY/goo/908670%40bugs%2Elaunchpad%2Enet/20061/I6535621141_1/?hs=false&tok=2pULVuzMs9hm81

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

To post a comment you must log in.