Brightness adjustment gauge in gnome-control-center screen not responding to brightness hot-keys

Bug #893851 reported by Chih-Hsyuan Ho on 2011-11-23
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Chih-Hsyuan Ho
Precise
Medium
David Barth
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Low
Unassigned
Nominated for Quantal by James M. Leddy
Nominated for Raring by James M. Leddy
Precise
Low
Mathieu Trudel-Lapierre

Bug Description

[Impact]
Using brightness hotkeys currently changes brightness correctly, but such changes fail to be visible in the gnome-control-center UI; which leads to confusion and unpredictable behavior if the brightness is then adjusted using UI in the same session.

[Test Case]
1) Open gnome-control-center (power indicator -> System Settings...)
2) Switch to "Brightness and Lock"
3) Use the brightness hotkeys to adjust screen brightness
4) Observe slider behavior.

Without the patch the slider should not move.
With the patch, slider should follow brightness adjustments done via hot keys.

[Regression Potential]
Minimal risk. The slider does not currently follow key brightness adjustments. Possible regression scenarios could include the slider no longer responding or changing brightness when interacting with it; or more confusion in mixing up hot key and slider brightness adjustments.

----
For systems equipped with hot keys to adjust screen brightness, the brightness gauge in "gnome-control-center screen" is not responding to brightness hot-key actions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
importance: Medium → Undecided
Pedro Villavicencio (pedro) wrote :

Are those keys detected at all in the system? It could even be a kernel issue. Could you please look at https://wiki.ubuntu.com/Hotkeys/Troubleshooting ; and provide the info pointed there to the report? Thanks.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Anthony Wong (anthonywong) wrote :

Brightness keys are working and they can be used to change screen brightness. The problem is the UI in gnome-control-center is not reflecting the change of screen brightness.

Chris Van Hoof (vanhoof) wrote :

Hello -- Please attach logs from the machine that is impacted here, and also the intended release that should be targeted.

Cheers,
Chris

Changed in oem-priority:
status: New → Incomplete
importance: Undecided → Low
assignee: nobody → Chih-Hsyuan Ho (chih)
Chih-Hsyuan Ho (chih) wrote :

Basically, this issue is about the Brightness bar in the Screen utility (please see the attached image) not reflecting the actual screen brightness in real time.

Kent Lin (kent-jclin) wrote :

Change to confirm as Chih has provided the explanation of the bug

Changed in oem-priority:
status: Incomplete → Confirmed
Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Could somebody having the issue open a bug on the GNOME bug tracker?

Chris Van Hoof (vanhoof) on 2012-01-23
Changed in oem-priority:
status: Confirmed → Incomplete
Anthony Wong (anthonywong) wrote :
Changed in oem-priority:
status: Incomplete → Confirmed
Changed in oem-priority:
importance: Low → Medium
James M. Leddy (jm-leddy) wrote :

The issue will not block the shipment. But customer would like to see the bug is fixed and user could get the fix via future update.

The attachment "Brightness-fix-for-gnome-settings-daemon-changes.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Committed

The task for Quantal is Fix Committed since g-c-c 3.5 will be uploaded soon to quantal. As for the fix itself, it's a definite SRU candidate so I'll fix the description for SRU paperwork and sponsor the patch ;)

Changed in gnome-control-center (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → Low
status: New → In Progress
description: updated

Hello Chih-Hsyuan, or anyone else affected,

Accepted into precise-proposed. The package will build now and then be available in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Anthony Wong (anthonywong) wrote :

Tested gnome-control-center_3.4.2-0ubuntu0.3 in precise-proposed and can fix this bug.

tags: added: verification-done
removed: verification-needed
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in oem-priority:
status: Confirmed → Won't Fix
status: Won't Fix → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu0.3

---------------
gnome-control-center (1:3.4.2-0ubuntu0.3) precise-proposed; urgency=low

  * debian/patches/Brightness-fix-for-gnome-settings-daemon-changes.patch:
    ensure gnome-settings-daemon DBus interface is properly used to be able to
    reflect brightness changes in UI. (LP: #893851)
 -- <email address hidden> (James M. Leddy) Tue, 26 Jun 2012 09:54:49 -0400

Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Unsubscribing sponsors, I don't see anything to sponsor here.

Changed in oem-priority:
status: Fix Committed → Fix Released
Matt Fischer (mfisch) wrote :

This issue still occurs in Quantal, it seems like the fix never made it there.

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Triaged
Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
Matt Fischer (mfisch) wrote :

James, from some discussions today it may also be okay to land the fix in Raring and not Quantal. We are likely rolling over to R in the next few weeks.

James M. Leddy (jm-leddy) wrote :

I really wish there was a way to take back series nominations. I meant for Quantal only, not Raring.

Matt Fischer (mfisch) on 2012-11-15
Changed in gnome-control-center (Ubuntu):
milestone: none → quantal-updates
milestone: quantal-updates → none
Matt Fischer (mfisch) wrote :

This is still broken in Q as I stated before, although it appears to be fixed in Gnome 3.4 and 3.6 trunks.

Here are all my notes:

1) The signal "Changed" is coming from g-s-d when the brightness hotkeys are pressed:

$ dbus-monitor --session "type='signal',sender='org.gnome.SettingsDaemon'"
In Quantal:
signal sender=:1.6 -> dest=org.gnome.SettingsDaemon serial=397 path=/org/gnome/SettingsDaemon/Power; interface=org.gnome.SettingsDaemon.Power.Screen; member=Changed

On Precise, we see the same signal:
signal sender=:1.17 -> dest=org.gnome.SettingsDaemon serial=8416 path=/org/gnome/SettingsDaemon/Power; interface=org.gnome.SettingsDaemon.Power.Screen; member=Changed

2) I instrumented the on_signal call inside gnome-control-center/panels/sceen/cc-screen-panel.c to emit a g_warning whenever any signal was received, I never saw anything come out in Q. When the same code was used in P, the message was printed. This implies, rather obviously that g-c-c is never getting the signal.

3) I then wrote a simplified test application that attempted to synchronously (for simplicity) connect to the same signal and just print a message if one was received and again, no message was received. I modified this code slightly to listen for signals from Gnome Screensaver and I get signals, so I think my sample code is fine. The sample code is attached later. To run it with the gnome-screensaver and get results, start the code and run "gnome-screensaver-command -a" in another terminal, and you should see:

** (process:17715): WARNING **: we get signal from :1.89: ActiveChanged

If you swap the 3 screensaver related lines with the SettingsDaemon code you will get no output. (replace lines 39-41 with 46-48)

4) I see one more interesting thing that may or may not be a problem:
The signals from SettingsDaemon have a Destination field of the settings daemon itself. Those from Gnome Screensaver have a "null" destination:

signal sender=:1.6 -> dest=org.gnome.SettingsDaemon serial=397 path=/org/gnome/SettingsDaemon/Power; interface=org.gnome.SettingsDaemon.Power.Screen; member=Changed

signal sender=:1.89 -> dest=(null destination) serial=78 path=/org/gnome/ScreenSaver; interface=org.gnome.ScreenSaver; member=ActiveChanged

Perhaps this is a problem? I don't know enough about dbus to be sure.

Matt Fischer (mfisch) wrote :
Matt Fischer (mfisch) wrote :

To compile that test code I posted:

gcc dbus-test.c -o dbus-test `pkg-config --libs --cflags gio-2.0 gtk+-3.0 dbus-glib-1 dbus-1`

Then ./dbus_test to run it.

Jeremy Bicha (jbicha) wrote :

I don't know if this is directly related to this bug but I can easily crash gnome-settings-daemon by pressing the brightness up/down keys on my keyboard. I'm using gnome-control-center 3.6.3/gnome-settings-daemon 3.6.3 on raring.

tags: added: raring
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.