Not possible to reconfigure Alt-F1 and Alt-F2 shortcuts

Bug #889479 reported by Mikael Ståldal on 2011-11-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Wishlist
Unassigned

Bug Description

Alt-F1 and Alt-F2 seems to be bound to "Show the run command prompt" and "Show the activities overview", but it is not possible to reconfigure them. See attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sat Nov 12 14:47:32 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-10-27 (16 days ago)

Mikael Ståldal (mikaelstaldal) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, they can be changed in ccsm, not in the GNOME control dialog

Changed in unity (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Invalid

Sebastien, Mikael, the bug described is a lack of configurability in GNOME control center (gnome-control-center package).
I have changed the target package accordingly and marked this as Confirmed, since one would expect a Keyboard shortcuts tab to allow users full configurability and connecting all kind of tasks to hotkeys.

affects: unity (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

Not sure we do intend to let the users easily change standard keybindings...

Sebastien, that I do not know.
But then again, how many users actually change standard keybindings? And how many average, non-tech savvy users do? If safety reasons are taken into account, why only two (apparently) keyboard shortcuts are omitted, not more of them?

Sebastien Bacher (seb128) wrote :

those are not the only ones not listed in the keybindings dialog, the expose keybinding is not there, the one to display the workspace switcher is not there, the one to switch between dialog in a same software is not, etc

I see and understand that there are probably more.
What I do not understand is why allowing full configurability isn't desired, especially that it shouldn't prove to be dangerous and/or difficult for users (the new ones usually don't tamper with configuration panels at all).

Mikael Ståldal (mikaelstaldal) wrote :

If you are not supposed to be able to configure them, why are they visible at all in the control center?

I think that it is quite important for a user to be able to reconfigure key bindings like Alt-F1 and Alt-F2 since they clash with some applications, such as IntelliJ IDEA.

http://brainstorm.ubuntu.com/idea/27973/

How do you change them in CCSM?

h1bymask (h1bymask) wrote :

Confirming successful changing via CCSM Unity Plugin.
But still have problem with Alt+F1 / Alt+F2 combination. Every time the Alt button after pressing the combination (e.g. Alt+F1) is released, the Unity menu command dialog appears.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers