Display utility doesn't offer to use nvidia-settings with proprietary drivers installed?

Bug #879528 reported by Daniel Manrique on 2011-10-21
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Canonical Desktop Team
Oneiric
Wishlist
Unassigned
Precise
Medium
Unassigned

Bug Description

On this system, the proprietary nvidia drivers are required for some features (like suspend/resume) to work correctly. On previous Ubuntu versions, opening the "Monitors" control panel detected the proprietary drivers and offered to use nvidia-settings instead of Displays. This is required, for instance, to be able to properly detect screens and enable the VGA, DisplayPort and HDMI video outputs which are completely ignored by g-c-c's Displays applet.

However on 11.10, Displays doesn't have this behavior, so the user is left to figure out why DIsplays is so limited and unable to detect/enable external screens, and eventually to learn to use nvidia-settings from a command prompt. This is quite confusing for novice users.

I'll attach some files with hardware information, this machine is primarily used for testing so please don't hesitate to let me know if I can provide more detailed info or run any necessary tests.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Fri Oct 21 12:17:11 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 deja-dup 20.0-0ubuntu3
 gnome-bluetooth 3.2.0-0ubuntu1
 indicator-datetime 0.3.0-0ubuntu3

Daniel Manrique (roadmr) wrote :
Daniel Manrique (roadmr) wrote :
Daniel Manrique (roadmr) wrote :
Daniel Manrique (roadmr) wrote :
Daniel Manrique (roadmr) wrote :
Ara Pulido (ara) on 2011-11-05
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: regression-release
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, not sure that's a bug though, the changelog has

"gnome-control-center (1:2.32.0-0ubuntu3) natty; urgency=low

  [ Martin Pitt ]
  * Drop 109_screen_resolution_extra.patch,
    110_screen_resolution_package.patch,
    111_screen_resolution_vendor_fallback.patch, and drop
    screen-resolution-extra recommends. This isn't necessary any more with
    XRandR 1.2 capable drivers, and the proprietary fglrx/nvidia ones have
    their own control panels."

Seems the binary drivers support xrandr nowadays

Changed in gnome-control-center (Ubuntu Oneiric):
importance: Undecided → Wishlist
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Note that the bug describes several issues, like suspend should be working with nouveau, you should open a bug against the nouveau driver about this issue

summary: - [Dell Studio XPS 1340] Displays utility doesn't offer to use nvidia-
- settings with proprietary drivers installed
+ Displays utility doesn't offer to use nvidia-settings with proprietary
+ drivers installed?

One other question would be know why the nvidia settings dialog is required to enable output, could be a bug in the nvidia drivers

Daniel Manrique (roadmr) wrote :

Hi Sebastien,

Thanks for looking at this bug report.

A separate bug was filed on the suspend/resume behavior a while ago, see bug 754711. This one is specifically about the control panel behavior; it's just an usability thing, making life easier for users who may not be aware changing resolutions or using external monitors with these drivers requires the proprietary panel.

Sebastien Bacher (seb128) wrote :

> users who may not be aware changing resolutions or using external monitors with these drivers requires the proprietary panel.

oh, is the proprietary panel "required"? (i.e don't those driver support xrandr)? if the normal panel doesn't work it's indeed a bug rather than a wishlist but my understanding was that we dropped the hacks to run the binary panel because the GNOME version though that simpler should be working with binary drivers nowadays

Changed in gnome-control-center (Ubuntu Oneiric):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) wrote :

Hi Sebastien,

With the normal panel I can switch resolutions (only 4 choices - not all available resolutions are shown here). I can't rotate the screen or use an external monitor. Also, the screen shows up as "unknown".

With the proprietary panel I can switch between about 20 resolution choices, and use external monitors. I still can't rotate the screen. This panel correctly identifies connected monitors by name/make/model (DDC information I think).

Of note, if I add an external display using the proprietary panel, the normal panel shows a "giant" desktop, i.e. if I have two 1024x768 screens configured on the proprietary panel, the normal panel will show one giant "unknown" screen of resolution 2048x768.

Thanks!

Changed in gnome-control-center (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in gnome-control-center (Ubuntu Precise):
status: Confirmed → Triaged
Chris Halse Rogers (raof) wrote :

The fglrx proprietary driver supports XRandR 1.2, so the Displays capplet will (should) work for it.

The nvidia binary driver does *not* support XRandR 1.2, so (as Daniel notes) the Displays capplet will not work properly (specifically, it won't do any multihead or external display setup) with the nvidia binary driver.

Changed in gnome-control-center (Ubuntu Precise):
importance: Wishlist → Medium
Bryce Harrington (bryce) on 2011-12-16
summary: - Displays utility doesn't offer to use nvidia-settings with proprietary
+ Display utility doesn't offer to use nvidia-settings with proprietary
drivers installed?
Hélio Nunes (dedalu-dedalu) wrote :

This bug may be unimportant for desktop systems, but is important for laptops. The first time user must google to solve such easy task.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/879528

tags: added: laptop-testing
Bryce Harrington (bryce) wrote :

Now that -nvidia supports xrandr 1.2, it's probably not worth the effort to fix this. For quantal, presumably the stock config dialog should "just work" with nvidia, so no need for special hacks there. And for precise, unfortunately I think even if we did come up with a special hack it wouldn't be SRUable anyway.

I think this bug can be closed as WONTFIX.

Changed in gnome-control-center (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints