gnome-control-center crashed with SIGSEGV in um_user_set_automatic_login()

Bug #873679 reported by Brandon Taylor on 2011-10-13
112
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Expired
Medium
gnome-control-center (Ubuntu)
High
Michael Terry
Precise
High
Michael Terry

Bug Description

Just closed control panel and this popped up

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CasperVersion: 1.287
Date: Thu Oct 13 15:45:57 2011
ExecutablePath: /usr/bin/gnome-control-center
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: gnome-control-center --overview
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fb05f5b0594: mov 0x20(%rdi),%rdi
 PC (0x7fb05f5b0594) ok
 source "0x20(%rdi)" (0x00000020) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/control-center-1/panels/libuser-accounts.so
 ?? () from /usr/lib/control-center-1/panels/libuser-accounts.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
usr_lib_gnome-control-center:
 deja-dup 20.0-0ubuntu3
 gnome-bluetooth 3.2.0-0ubuntu1
 indicator-datetime 0.3.0-0ubuntu3

Brandon Taylor (iammrbt) wrote :

StacktraceTop:
 um_user_set_automatic_login (user=0x0, enabled=1) at um-user.c:1075
 autologin_changed (object=<optimized out>, pspec=<optimized out>, d=0x7fb07d40d280) at um-user-panel.c:532
 g_closure_invoke (closure=0x7fb07d514600, return_value=0x0, n_param_values=2, param_values=0x7fb07d492f90, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=916, instance=0x7fb07d231200, emission_return=0x0, instance_and_params=0x7fb07d492f90) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3003

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Medium → High
summary: - gnome-control-center crashed with SIGSEGV in g_closure_invoke()
+ gnome-control-center crashed with SIGSEGV in
+ um_user_set_automatic_login()
visibility: private → public
tags: added: mgr-rls-p-tracking
tags: added: rls-mgr-p-tracking
removed: mgr-rls-p-tracking
Michael Terry (mterry) on 2012-03-23
Changed in gnome-control-center (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

I pushed in a patch for this. I'm not sure why it's happening (the crash happens if the autologin switch changes but there is no selected user. I couldn't make the dialog have no selected user, but maybe that's something that happens during close).

But I did see how to guard against a crash in that case, so I made that patch. I also submitted it upstream.

Changed in gnome-control-center (Ubuntu Precise):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.3.92-0ubuntu4

---------------
gnome-control-center (1:3.3.92-0ubuntu4) precise; urgency=low

  * debian/patches/fix-crash-on-user-panel.patch:
    - Fix occasional crash when closing user panel (LP: #873679)
 -- Michael Terry <email address hidden> Fri, 23 Mar 2012 15:26:12 -0400

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center:
status: New → Incomplete
Changed in gnome-control-center:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.