Ubuntu

The printing panel shouldn't display errors about firewalld not running

Reported by Leon on 2011-10-10
214
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Linux Mint
Undecided
Unassigned
elementary OS
High
Unassigned
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

WORKAROUND: As an alternative to the printer configuration tool from the new Gnome Shell control center, you can still use system-config-printer. To open it, just press Alt+F2, type system-config-printer and press Enter.

It appears a patch was added to Gnome back in July that requires FirewallD to be running in order to add a network printer.
see: http://mail.gnome.org/archives/commits-list/2011-July/msg09761.html

This only appears to affect those using the Gnome 3 desktop environment, and this problem is not present in Unity, so you can still add the pinter in Unity's control panel, but users wanting to use Gnome will encounter this. The specific error message is:
 "FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall."

The documentation in the mentioned patch suggests this behavior is actually intentional. However, FirewallD is, as far as I know, specific to Fedora.

1) release: Ubuntu Oneiric Beta 2 (64 bit, but others likely to be affected)

2) issue is more specific to the Gnome 3 desktop environment as a whole, although there may be individual packages that can be patched to circumvent this behavior

3) I expected the previous behavior of being able to add a network printer without having a package that does not even exist for Ubuntu

4) I got this nice error message that tells me "FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall."

As far as a solution goes, a documented work-around may be a good idea (such as an FAQ entry that says simply to install the network printer in Unity), at least until a more permanent solution can be found.

This is bug was originally asked as a question here: https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/173836 but it was suggested that a bug report be submitted instead.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Mon Oct 10 14:49:32 2011
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 deja-dup 20.0-0ubuntu3
 gnome-bluetooth 3.2.0-0ubuntu1
 indicator-datetime 0.3.0-0ubuntu3

Leon (lehjr) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed

Thank you for your bug report, that's indeed an upstream issue

summary: - Using Gnome control panel to add a network printer now requires
- FirewallD
+ The printing panel shouldn't display errors about firewalld
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
summary: - The printing panel shouldn't display errors about firewalld
+ The printing panel shouldn't display errors about firewalld not running
Sebastien Bacher (seb128) wrote :

Ok, I've forward it to

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel Stoyanov (dankh) wrote :

How this bug can be flagged as importance:Medium ? Many of us can't work without a printer. At work I have access to only network printers. Just upgraded to 11.10 and have to revert ... . Is there any tutorial or workaround to fix this before official fix released ?

Leon (lehjr) wrote :

To add the printer log into another desktop environment, even Unity works. Once the printer is added it will work in Gnome 3. But as far as I know you can't do it in Gnome 3 itself.

As far as a fix goes, my own interpretation doesn't leave me feeling confident that it will get fixed by Gnome devs any time soon but rather will have to wait until some future release, so maybe someone can create a replacement applet, or the Ubuntu devs can create a patched package that removes this .

Sebastien Bacher (seb128) wrote :

> How this bug can be flagged as importance:Medium ? Many of us can't work without a printer.

the tools which has the bug is neither the default one nor the one used under the default desktop, nothing blocks you to use system-config-printer under gnome-shell if that's what you want to use, system-config-printer is the default printer configuration utility and doesn't have those issues

Daniel Stoyanov (dankh) wrote :

@Leon : thank you it works. I logged in Unity 2D session and added the printer, then its available in the fallback session and I'm able to print.

@Seb : I agree with you if I use defaults it works. But my hope was that 11.10 will be user friendly with or without the use of Unity. In this case if I don't use a "Unity" session I can't add a printer the user friendly way.

Sebastien Bacher (seb128) wrote :

> In this case if I don't use a "Unity" session I can't add a printer the user friendly way.

well, complain to the GNOME guys if the configuration tools they ship are buggy and you really want to use the GNOME tools but nothing prevents you to run system-config-printer under gnome-shell, it's user friendly as well

Leon (lehjr) wrote :

Considering how this patch made it into Gnome without noticing the distro specific requirements, especially noting these lines that should have raised a red flag or at least an eyebrow:

+#define FIREWALLD_BUS "org.fedoraproject.FirewallD"
+#define FIREWALLD_PATH "/org/fedoraproject/FirewallD"
+#define FIREWALLD_IFACE "org.fedoraproject.FirewallD"

I'd say complaining to GNOME devs probably won't make much difference. I know no one's perfect, but I wold have thought that their patches underwent a little more scrutiny and required some level of review before inclusion.

Anyway, am I correct in assuming the easiest fix would be a to point the printer configuration launcher (correct terminology?) in gnome control center to point to system-config-printer?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)

For your interest, system-config-printer can be used from Gnome Shell too, without the need of Unity. Just open a terminal (or press Alt+F2), write "system-config-printer" and press Enter.

I'm going to add this easy workaround to the bug description.

description: updated

Does not work in 12.04, system-config-printer.py crashes.

Sebastien Bacher (seb128) wrote :

mike: could you open a new bug using apport?

Changed in gnome-control-center (Ubuntu):
assignee: Rodrigo Moya (rodrigo-moya) → nobody
Albert Pool (albertpool) wrote :

Bug affects me as well, on Linux Mint 12. system-config-printer however doesn't have any problem adding my printer.

No crashes at me, just the message about FirewallD when using gnome's system settings app.

Guy Stone (stoneguy3) wrote :

Same bug in QuantalA3 guest in Precise Vbox host. Possibly related to using Gnome Classic No Effects desktop. And installed OK with workaround in #12. While it's unlikeky that a newbie will hit this, those of us who know just enough to be dangerous might get stumped.

mike (motla68) wrote :

FIREWALLD PROBLEM

SOLVED ! FIXED! 3 days of endless searches through forums on and off and changing configurations and it finally paid off, I figured this out on my own and everything came to life, automatically detected all my printers.

Ubuntu 12.04 LTS OS install has an incorrect file name for network management.

Old : /etc/NetworkManager/NetworkManager.conf

New: /etc/NetworkManager/nm-system-settings.conf

The only way I found this is because I have a older computer that will only run Ubuntu 10, just happened to see that they were different. I hope this will go up to the developers so they can make changes for the next updates. So glad this was found, because I would hate to lose Ubuntu 12, other then this problem it has been one of the best OSs I have used.

mike (motla68) wrote :

oh yeah, forgot to add on my post just added, network manager will need restarted or restart computer.

Jeremy Bicha (jbicha) wrote :

Mike, why do you think we have to have a file named /etc/NetworkManager/nm-system-settings.conf ?

Reading the attached GNOME report, it sounds like this may be fixed in gnome-control-center 3.6 (System Settings), but we'll still be using 3.4 for Ubuntu 12.10.

Jeremy, mike: it doesn't. NetworkManager.conf is the new, correct name for the file. If some application is expecting a different value (and one would wonder why they go out to look for that file in the first place); then it's that application that needs fixing.

If a part of the control center in Gnome (not unity?) requires firewalld, then I'm sure there's a way to disable that check, which is something that should be considered anyway since we're at the very least not going to have firewalld for Quantal. (We have ufw instead)

aaron thomas (athomas-1) wrote :

Using Cinnamon desktop, so I get this error. Didn't realize I was using fedora now. Since cinnamon was made for linux mint. On ubuntu.

VidJa (vidja-hunter) wrote :

C'mmon guys, fix this annoying bug that has plagued us since 11.10. Despite all the rants that 'you can work around it'
I personnaly think printing should be tested at least under the most commonly used desktops.

Sebastien Bacher (seb128) wrote :

@VidJa: try talking to the GNOME guys. Note that Ubuntu default's desktop uses system-config-printer which doesn't have that issue

rpaco (rpa-rpaco) wrote :

Has this been solved yet or moved elsewhere?

Using "system-config-printer" does not work in Ubuntu 11.10 Gnome 3.2.1 It gives the error "command not found"

I am not using Unity.

Sebastien Bacher (seb128) wrote :

> Using "system-config-printer" does not work in Ubuntu 11.10 Gnome 3.2.1 It gives the error "command not found"

sudo apt-get install system-config-printer-gnome

Changed in gnome-control-center:
status: Confirmed → Fix Released
Changed in elementaryos:
status: New → Triaged
milestone: none → luna-beta2
Daniel Fore (danrabbit) on 2012-12-23
Changed in elementaryos:
milestone: luna-beta2 → luna-beta3
Leon (lehjr) wrote :

Bug is present in Linux Mint 14 Cinnamon Edition.

Leon (lehjr) wrote :

see also

Changed in elementaryos:
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

I believe this is fixed in Ubuntu 13.04 even if you are using GNOME according to the linked GNOME bug. I personally haven't seen this error in a long time.

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Cody Garver (codygarver) on 2013-05-13
Changed in elementaryos:
milestone: luna-beta3 → 0.3-beta1
Changed in elementaryos:
status: Triaged → Fix Released
Changed in elementaryos:
milestone: 0.3-beta1 → luna-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.