Setting screen resolution fails with error message "null"

Bug #863547 reported by Philipp Wendler on 2011-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

After upgrading from Natty to Oneiric, my second monitor was disabled on first login. I opened the resolution dialogue via the system menu and enabled it (both monitors and their resolutions were correctly shown in this dialogue). After clicking "apply", nothing changed but a popup box appeared saying "The chosen screen configuration could not be applied (null)".

Obviously, changing the resolution should work (it did in Natty), and if it fails, the message should be more helpful than "null".

I have a Radeon HD 4870 and use the usual radeon driver.

Manually enabling the second monitor with xrandr led to a Compiz crash, but I'll file a separate bug about that if I can reproduce it.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu2
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,place,session,gnomecompat,resize,vpswitch,mousepoll,grid,snap,regex,imgpng,wall,move,unitymtgrabhandles,animation,fade,scale,expo,workarounds,ezoom,unityshell]
CompositorRunning: compiz
CurrentDmesg:
 [ 29.109352] EXT4-fs (dm-2): re-mounted. Opts: commit=0
 [ 30.979254] init: plymouth-stop pre-start process (1856) terminated with status 1
Date: Fri Sep 30 20:16:35 2011
DistUpgraded: Log time: 2011-09-30 18:47:44.708272
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 ATI Technologies Inc RV770 [Radeon HD 4870] [1002:9440] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:0851]
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-12-generic-pae root=/dev/mapper/linux-root ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (0 days ago)
dmi.bios.date: 11/25/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0704
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A79XTD EVO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0X
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0704:bd11/25/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A79XTDEVO:rvrRevX.0X:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Philipp Wendler (philw85) wrote :
affects: ubuntu → gnome-control-center (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

summary: - [Oneiric] Setting screen resolution fails with error message "null"
+ Setting screen resolution fails with error message "null"
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

It would be interesting if you could give details on the resolution you configure for each screen if you get the issue? Could you also create a file gsd-debug-randr in your user directory, restart your session, trigger the bug and add the gsd-debug-randr.log you should get in your user directory?

Philipp Wendler (philw85) wrote :

Hi,

currently only a part of this bug is reproducible. The error message does not appear anymore, but changing resolutions, enabling/disabling monitors etc. does not work. Whatever I do in this dialogue, absolutely nothing happens when I click "apply".

Changing resolutions etc. on the command line works well.

My monitor setup is as follows:

Screen 0: minimum 320 x 200, current 3200 x 1200, maximum 8192 x 8192
DVI-0 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 546mm x 352mm
   1920x1200 60.0*+
   1600x1200 60.0
   1680x1050 60.0
   1600x1000 60.0
   1280x1024 75.0
   1280x960 60.0
   1152x864 75.0
   1024x768 75.1 60.0
   832x624 74.6
   800x600 75.0 60.3
   640x480 75.0 60.0
   720x400 70.1
DIN disconnected (normal left inverted right x axis y axis)
DVI-1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024 75.0*+ 60.0
   1152x864 75.0
   1024x768 75.1 70.1 60.0
   800x600 72.2 75.0 60.3
   640x480 72.8 75.0 60.0
   720x400 70.1

I tried to produce the gsd-debug-randr.log, but didn't succeed (although I did a logout/login):

philipp@pc-philipp:~$ ls -l gsd*
-rw-r--r-- 1 philipp philipp 0 2011-10-22 16:43 gsd-debug-randr
philipp@pc-philipp:~$

Bryce Harrington (bryce) wrote :

Hi Philipp,

Good to hear the error message is corrected now. Of course, the remaining problem sounds worse. But it's hard to guess what might be going wrong. Having some sort of logs or other details might help.

I'm not sure why your gsd-debug-randr.log is not getting produced; that would be very informative if it existed.

You could also try turning on randr debugging from the X side. Run 'sudo xdiagnose' and tick the first checkbox. Then reboot and reproduce the issue, and then collect 'sudo dmesg > dmesg.txt' and attach that file, which should have some details about the resolution change.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Since the error message was fixed I'll close out the bug at this time.

If you would still like the other issue investigated please file a new bug with the log.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints