System Settings Keyboard icon indistinct with Ambiance

Bug #862027 reported by Jeremy Bicha on 2011-09-29
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
ubuntu-themes (Ubuntu)
Medium
Unassigned

Bug Description

With ubuntu-mono 0.0.36, the keyboard icon was changed and now is difficult to make out in System Settings with Ambiance. It looks a bit better with Radiance (ubuntu-mono-light).

Ideas for solutions
1. Revert the keyboard icon change
2. Create a new symbolic keyboard icon and update the indicator to use it
3. Patch System Settings to use a non-symbolic keyboard icon
4. Force System Settings to use the ubuntu-mono-light icon (doesn't sound like a good idea because it could break some themes)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubuntu-mono 0.0.36
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Thu Sep 29 00:36:35 2011
PackageArchitecture: all
SourcePackage: ubuntu-mono
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Martin Pitt (pitti) wrote :

Paul, at this point I think it's easiest to just revert the change. It was made way after UIF anyway. Do you see another quick and safe solution?

Changed in ubuntu-mono (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-mono (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
assignee: nobody → Paul Sladen (sladen)
Paul Sladen (sladen) wrote :

Jeremy: where are you seeing this indistinct example? Is it with:

  1. <Super>
  2. typing "keyboard" in the dash?

Really, Dash or Launcher shouldn't be using the "status" keyboard icons; but if needed I can restore/replace the previous keyboard at sizes != 22 pixels. Note that the "preferences-desktop-keyboard" icon was not changed by the upload.

  dpkg -L ubuntu-mono | grep keyboard | grep -v [gf]pm

  diff -Nru debian/changelog debian/changelog
  diff -Nru debian/control debian/control
  diff -Nru debian/rules debian/rules
  diff -Nru ubuntu-mono-dark/status/16/ibus-keyboard.svg ubuntu-mono-dark/status/16/ibus-keyboard.svg
  diff -Nru ubuntu-mono-dark/status/22/ibus-keyboard.svg ubuntu-mono-dark/status/22/ibus-keyboard.svg
  diff -Nru ubuntu-mono-dark/status/22/input-keyboard.svg ubuntu-mono-dark/status/22/input-keyboard.svg
  diff -Nru ubuntu-mono-dark/status/22/keyboard.svg ubuntu-mono-dark/status/22/keyboard.svg
  diff -Nru ubuntu-mono-dark/status/24/ibus-keyboard.svg ubuntu-mono-dark/status/24/ibus-keyboard.svg
  diff -Nru ubuntu-mono-light/status/16/ibus-keyboard.svg ubuntu-mono-light/status/16/ibus-keyboard.svg
  diff -Nru ubuntu-mono-light/status/22/ibus-keyboard.svg ubuntu-mono-light/status/22/ibus-keyboard.svg
  diff -Nru ubuntu-mono-light/status/22/input-keyboard.svg ubuntu-mono-light/status/22/input-keyboard.svg
  diff -Nru ubuntu-mono-light/status/22/keyboard.svg ubuntu-mono-light/status/22/keyboard.svg
  diff -Nru ubuntu-mono-light/status/24/ibus-keyboard.svg ubuntu-mono-light/status/24/ibus-keyboard.svg

  http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/ubuntu-mono/oneiric/revision/30?remember=31

Paul Sladen (sladen) wrote :

(Diff above from:

  debdiff ubuntu-mono_0.0.34.dsc ubuntu-mono_0.0.36.dsc | grep diff | sed -e 's/ubuntu-mono-0.0.3..//g' )

Martin Pitt (pitti) wrote :

Paul, I think he means the control-center shell. Session indicator -> system settings (or "gnome-control-center" in shell)

Martin Pitt (pitti) wrote :

It's light gray on white, and thus has a poor contrast, but still visible, so not a release blocker. Can be fixed in an SRU as well, if really necessary.

Changed in ubuntu-mono (Ubuntu Oneiric):
importance: High → Medium
Paul Sladen (sladen) wrote :

Gnome Control Center; showing the symbolic icon; The icon has an intentional black underlay to ensure that it remains visible even when misused like this, but it's not ideal.

Otto/Xi: ideas. While sub-optimal, it's not that much worse that the mouse. I can restore the previous icon for resizes != 22 to avoid patching gnome-control-centre or gnome-settings-daemon (both of which are using plain Icon('keyboard') it appears.

Otto Greenslade (otto-chaotic) wrote :

The previous keyboard icon in panel really stood out as requiring improvement and I think this new one is a big improvement, so I would like to keep it.

Looking at Paul's sshot (settings-keyboard.png), the icon is not ideal - the contrast isn't great but I'm inclined to agree that it's passable and that it shouldn't even be being used in that context. Ideally we will move to using full symbolic icons that can be treated with different effects based on where they are used - 'one shape fits all' as it were.

It seems that g-c-c uses an icon name different from
"preferences-desktop-keyboard", is it easy to fix it?

Paul Sladen (sladen) wrote :

Screenshot of GNOME Control Centre and previous ubuntu-mono=0.0.34 installed.

Otto Greenslade (otto-chaotic) wrote :

So it's just a naming issue then? Ideally we'd revert to (Paul's last sshot as example for g-c-c) while maintaing our latest keyboard panel icon.

Martin Pitt (pitti) on 2011-09-29
Changed in ubuntu-mono (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
Jeremy Bicha (jbicha) wrote :

Ok, I used solution #3 as suggested in comment #10 and pushed the patch to our gnome-control-center desktop branch. Is this what we're going to do for Oneiric?

Changed in ubuntu-mono (Ubuntu Oneiric):
status: Triaged → Fix Committed
Paul Sladen (sladen) wrote :

Jeremy: At a cursory glance of:

   http://bazaar.launchpad.net/~ubuntu-desktop/gnome-control-center/ubuntu/revision/295

it looks reasonable, but I haven't built it yet.

Paul Sladen (sladen) wrote :

Builds and works for me(tm).

Martin Pitt (pitti) wrote :

Accepting because it fixes a regression introduced in a rather late UIFE.

affects: ubuntu-mono (Ubuntu Oneiric) → gnome-control-center (Ubuntu Oneiric)
Changed in gnome-control-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

I'm going to re-open this as I don't believe this was fixed correctly. For the Ubuntu GNOME Remix, we want to get as pure of a GNOME experience as possible. The fix that was applied in Oneiric changes the icon used for the Keyboard panel.

From the original bug report, I believe we basically went with #3 but I think #2 is what we want for raring. Specifically, upstream uses "input-keyboard" for the icon but we patched it to use "preferences-desktop-keyboard" instead.

Changed in gnome-control-center (Ubuntu):
status: Fix Released → Confirmed
assignee: Paul Sladen (sladen) → nobody
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Paul Sladen (sladen) → nobody
Jeremy Bicha (jbicha) wrote :

Because we're using the wrong icon name, the Keyboard panel doesn't have an icon when using the High Contrast theme. See the attached screenshots.

The icon renaming also goes against the Icon Naming Specification: http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html

Jeremy Bicha (jbicha) wrote :
no longer affects: ubuntu-mono (Ubuntu Oneiric)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-mono (Ubuntu):
importance: Undecided → Medium
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2012-11-26
tags: added: a11y quantal raring
Adolfo Jayme (fitojb) on 2013-06-12
affects: ubuntu-mono (Ubuntu) → ubuntu-themes (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu33

---------------
gnome-control-center (1:3.6.3-0ubuntu33) saucy; urgency=low

  [ Jeremy Bicha ]
  * Restore 57_use_nonsymbolic_keyboard_icon.patch, the ubuntu-themes
    merge proposal wasn't accepted yet

  [ Tim Lunn ]
  * debian/patches/git_shell_use_view_style_class.patch: git patch to
    fix mismatched backgrounds (LP: #1218102)
 -- Tim Lunn <email address hidden> Thu, 29 Aug 2013 19:23:56 +1000

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 13.04+13.10.20130919.2-0ubuntu1

---------------
ubuntu-themes (13.04+13.10.20130919.2-0ubuntu1) saucy; urgency=low

  [ William Hua ]
  * Add spacing between a GtkModelMenuItem's icon and its label.

  [ Jeremy Bicha ]
  * Drop input-keyboard icons, now that we have a proper
    indicator-keyboard. (LP: #862027)

  [ James Schriver ]
  * Fix light toolbar separators in Ambiance (LP: #1181661)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 315
 -- Ubuntu daily release <email address hidden> Thu, 19 Sep 2013 14:05:04 +0000

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2013-09-19
no longer affects: gnome-settings-daemon (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers