Gnome Control Center crashes if light-themes are not installed

Bug #856824 reported by Jan Hoffmann on 2011-09-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Rodrigo Moya

Bug Description

If the package light-themes is not installed, gnome-control-center crashes after selecting the Appearance/Background panel.

Terminal output:

$ gnome-control-center

(gnome-control-center:18694): background-cc-panel-WARNING **: Could not load /usr/share/themes/Ambiance/index.theme: Datei oder Verzeichnis nicht gefunden
Speicherzugriffsfehler (Speicherabzug geschrieben)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 22 23:24:57 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
ProcEnviron:
 LANGUAGE=de:en
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 deja-dup 19.92-0ubuntu1
 gnome-bluetooth 3.1.92-0ubuntu1

Jan Hoffmann (jan-hoffmann) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Rodrigo, seems due to the theme selector?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
importance: High → Undecided
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.92-0ubuntu6

---------------
gnome-control-center (1:3.1.92-0ubuntu6) oneiric; urgency=low

  * debian/patches/90_force_fallback.patch:
    - Debian patch, disable the “forced fallback mode” switch, since
      we already provide a xsession file for it in gnome-session-fallback.
      The option is also incompatible with how sessions rare started in
      Debian or Ubuntu (using gnome-session --session) (lp: #825250)

  [ Jeremy Bicha ]
  * debian/patches/10_keyboard_layout_on_unity.patch: Fix capitalization
  [ Rodrigo Moya ]
  * debian/patches/10_keyboard_layout_on_unity.patch:
    - Use a different icon for region panel, since it was the same than
      language-selector
  * debian/patches/04_add_theme_selection.patch:
    - Ignore not-installed themes (LP: #856824)
    - Add Adwaita to the list of available themes (only shown if installed)
 -- Sebastien Bacher <email address hidden> Fri, 23 Sep 2011 18:07:49 +0200

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers