Hidden controls due missing hardware showed on system settings relaunch

Bug #854544 reported by Luca Ferretti on 2011-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Undecided
Rodrigo Moya
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

It seems here is a way to add a battery or a touchpad to your non-laptop system :)
Basically System Settings window adds hidden controls (for instance touchpad or battery or just the Search entry in toolbar) if you relaunch it when it's already running. The proper behavior should be raise the window, instead. Here is a video showing the issue: http://ubuntuone.com/6tERKDklQhZo0xvSlklW08

## Steps to Reproduce ##
Let assume you are on a system without a touchpad
 - launch System Settings and open Mouse and Touchpad
 - give focus to another window, keeping system setting running and showing mouse settings
 - relaunch System Settings

## Current result ##
hidden Touchpad tab appears, as well as the search entry (this one should be available only in overview mode)

## Expected Result ##
raise system settings window

## Additional Notes ##
It seems the combobox available in Appearance > Background to change the background style (fill, tile, stretch...) is now hidden. Is it a bug, isn't it?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Tue Sep 20 10:48:38 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (6 days ago)
usr_lib_gnome-control-center:
 deja-dup 19.92-0ubuntu1
 gnome-bluetooth 3.1.4-0ubuntu2
 indicator-datetime 0.2.95-0ubuntu1

Luca Ferretti (elle.uca) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Luca Ferretti (elle.uca) wrote :

I can't reproduce this issue in my jhbuild sandbox (updated yesterdat to "release 3.2.92" git commit), so I think it's not an upstream issue, I can't file or search a non existing bug :(

Sebastien Bacher (seb128) wrote :

I can't reproduce that bug on Oneiric either on a box which doesn't have a supported pad, I don't think we have any patch that should create that behaviour either, let's see if Rodrigo or somebody else has a clue about the issue.

Changed in gnome-control-center:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
status: New → Fix Committed
Changed in gnome-control-center:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.92-0ubuntu2

---------------
gnome-control-center (1:3.1.92-0ubuntu2) oneiric; urgency=low

  [ Rodrigo Moya ]
  * debian/patches/00git_use_gtk_widget_show.patch:
    - Use gtk_widget_show instead of _show_all in gnome_control_center_show
      (LP: #854544)
  * debian/patches/00git_show_section_labels.patch:
    - Show the label for the category sections, which was being shown because
      of the gtk_widget_show_all replaced in previous commit

  [ Jeremy Bicha ]
  * debian/patches/04_add_theme_selection.patch: Use correct High Contrast
    theme names
  * debian/patches/53_use_ubuntu_help.patch: Replaced

  [ Michael Terry ]
  * debian/patches/55_user_accounts_hide_controls.patch:
    - When not using GDM, hide certain controls in the User Accounts
      panel that only apply to it. (LP: #821766, LP: #821771)
    - When a user is using an ecryptfs home directory, do not allow
      the user to log in without a password
 -- Michael Terry <email address hidden> Thu, 22 Sep 2011 11:25:29 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers