gnome-control-center crashed with SIGSEGV in on_screen_changed()

Bug #843274 reported by lulo on 2011-09-06
158
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Critical
gnome-control-center (Ubuntu)
High
Michael Terry
Precise
High
Michael Terry

Bug Description

To reproduce:
1) Enter System Settings
2) Enter the Displays panel
3) Click on All Settings button to go back
4) Plug in an external monitor

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.91-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CrashCounter: 1
Date: Tue Sep 6 23:16:59 2011
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
ProcCmdline: gnome-control-center display
SegvAnalysis:
 Segfault happened at: 0x7f68667776cc: mov (%rax),%rdi
 PC (0x7f68667776cc) ok
 source "(%rax)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/control-center-1/panels/libdisplay.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout fuse lpadmin netdev plugdev sambashare scanner video

lulo (lulojs11) wrote :

StacktraceTop:
 on_screen_changed (scr=0x7f6844002f20, data=0x7f687988d100) at cc-display-panel.c:247
 g_closure_invoke (closure=0x7f68796eddd0, return_value=0x0, n_param_values=1, param_values=0x7f68799e8f60, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.29.18/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x7f6844002f20, emission_return=0x0, instance_and_params=0x7f68799e8f60) at /build/buildd/glib2.0-2.29.18/./gobject/gsignal.c:3272
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=0x7fffb5d92698) at /build/buildd/glib2.0-2.29.18/./gobject/gsignal.c:3003
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.29.18/./gobject/gsignal.c:3060

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
summary: - gnome-control-center crashed with SIGSEGV in g_closure_invoke()
+ gnome-control-center crashed with SIGSEGV in on_screen_changed()
visibility: private → public
Pedro Villavicencio (pedro) wrote :

Is this still an issue with 3.1.92 ? There's no reports with same backtrace on that particular version. May you please test and comment back or even add a test case so we can test it? Thanks in advance.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Incomplete
Chris Johnston (cjohnston) wrote :

Pedro, I just got the issue today. Bug #859247

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

any chance to get a backtrace with the new package? apport doesnt seems to be picking those and its just marking it as dup instead.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

any news about this?

tags: added: bugpattern-needed
Changed in gnome-control-center (Ubuntu):
importance: Medium → High
status: Incomplete → Confirmed
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-control-center:
importance: Medium → Critical
Michael Terry (mterry) wrote :

I think I see why this is happening. A callback is being used after the object that registered it dies.

Changed in gnome-control-center (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
status: Confirmed → In Progress
Michael Terry (mterry) on 2012-02-25
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.3.90-0ubuntu4

---------------
gnome-control-center (1:3.3.90-0ubuntu4) precise; urgency=low

  * debian/patches/99_fix_display_crash.patch:
    - Disconnect signal when display panel is closed so we don't crash
      later. LP: #843274
 -- Michael Terry <email address hidden> Sat, 25 Feb 2012 09:36:05 -0500

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Released
Changed in gnome-control-center:
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/843274

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.