configuration of external monitor on laptop with DisplayPort causes lvds to remain black

Bug #840974 reported by Carla Sella on 2011-09-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

During test of Oneiric Beta 1 on my HP-G62 laptop testcase: http://testcases.qa.ubuntu.com/Hardware/GFX/ExternalPrimary I have this problem on configuration of external attached monitor:

After powering on my laptop with an external monitor attached, when I unclick the duplicate check box and work only with the external monitor, when you try to turn the laptop monitor on again it just remains black and only the external one works, can't get it back working, it works only if you check the duplicate check box again, but you can't switch off the external monitor and work with the laptop one if the external one is attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.5-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Sun Sep 4 14:40:31 2011
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Carla Sella (carla-sella) wrote :
Bryce Harrington (bryce) wrote :

Turn on display debug information by running sudo xdiagnose, clicking the first checkbox, apply, then reboot.

Now collect dmesg output, then reproduce the problem and collect a second dmesg. You want the data that's in the second dmesg but not the first.

Possibly this bug is related to bug #737891

Carla Sella (carla-sella) wrote :

Hello, I've just reproduced the problem with xdiagnose.
I'm attaching the second dmesg.
Let me know if everything is ok.
Thanks.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Is that still an issue? Could you create "gsd-debug-randr" file in your user directory, restart your session, change the screen settings and copy the "gsd-debug-randr.log" which got create in your user directory to the bug?

Sebastien Bacher (seb128) wrote :

Could you also give details about what screen you try to configure, their resolution, placement, etc? Does it work using the xrandr command line tools?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Carla Sella (carla-sella) wrote :

I attached the "gsd-debug-randr.log" file as asked in #4.

Carla Sella (carla-sella) wrote :

The problem occurs both using an external monitor (Acer AL1715) attached to my laptop and using only the laptop monitor.
When I try to change resolution from 1366x768 to 800x600 or 1024x768, the screen goes black, after about 20 seconds the screen goes back to the original 1366x768 resolution.
Tha log file attached in #6 was made using my laptops monitor (my laptop is a HP G-62).
Must I send you the same log with the external monitor attached ?

Carla Sella (carla-sella) wrote :

As asked on #5 I tried to use this command:
xrandr --output LVDS1 --mode 1024x768
and this one
xrandr --output LVDS1 --mode 800x600

But when I launch these commands from a terminal, the screen goes black, I tried to wait for about 2 miniutes, but seeing nothing happen, I typed in CTRL+ALT+F1 and then CTRL+ALT+F7, doing this I get the resolution I typed in the command line ( 1024x768 in the first command an 800x600 in the second).

But if I go back to 1366x768 using the monitor settings in system settings and try again to change to 1024x768 or 800x600 I get the same problem, the screen goes black for about 20 seconds and comes back to 1366x768.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

if the xrandr command line calls trigger the issue it seems part of the bug is due to xorg itself or the driver

Bryce Harrington (bryce) wrote :

Thanks for attaching the dmesg output with debugging turned on. Looking through it I do notice this bit which looks possibly complicit in this issue:

[ 515.630872] [drm:intel_prepare_page_flip], preparing flip with no unpin work?
[ 515.683339] [drm:intel_wait_for_vblank], vblank wait timed out
[ 515.683439] [drm:drm_crtc_helper_set_config],
[ 515.683445] [drm:drm_crtc_helper_set_config], [CRTC:4] [NOFB]
[ 515.683457] [drm:drm_crtc_helper_set_config], [CONNECTOR:5:LVDS-1] to [CRTC:3]
[ 515.683463] [drm:drm_crtc_helper_set_config], crtc changed, full mode switch
[ 515.683468] [drm:drm_crtc_helper_set_config], [CONNECTOR:11:VGA-1] to [NOCRTC]
[ 515.692792] [drm:intel_crtc_cursor_set],
[ 515.699776] [drm:i915_get_vblank_timestamp], crtc 1 is disabled
[ 515.716486] [drm:i915_get_vblank_timestamp], crtc 1 is disabled
[ 515.733167] [drm:i915_get_vblank_timestamp], crtc 1 is disabled
...

Those crtc 1 disabled messages go on for almost 20 seconds, so I presume this sequence corresponds to when your screen was blanked. Looks like at that point the LVDS was mapped to crtc 3; perhaps X was expecting it on crtc 1 instead and started issuing the warnings when it didn't find it there.

Would you be willing to do a quick check that this same behavior occurs in Ubuntu Precise? It should be sufficient to boot a Live USB session, configure the monitors, and see if it is working properly now. You can get the current Live USB desktop image at http://cdimage.ubuntu.com/daily-live/current/ and create a USB boot drive using usb-creator.

Changed in xorg-server (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2011-12-20
summary: - configuration of external monitor on laptop does not work properly
+ configuration of external monitor on laptop causes lvds to remain black
Bryce Harrington (bryce) wrote :

I think this *might* be a duplicate (or at least variant) of bug #828623.

summary: - configuration of external monitor on laptop causes lvds to remain black
+ configuration of external monitor on laptop with DisplayPort causes lvds
+ to remain black
Carla Sella (carla-sella) wrote :

Hello Bryce,
I downloaded today's (20/12/2011) live USB image of Precise Pangolin and created a live USB key.
Changing resolution on my laptop form the live USB key works fine, I tried all the resolutions without having any problem.
Thank you.

Sebastien Bacher (seb128) wrote :

thank you for the update Carla, I'm setting the bug as fixed then

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/840974

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints