gnome-control-center is missing font & icon-theme settings

Bug #840678 reported by Rocko on 2011-09-03
104
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Invalid
Medium
gnome-control-center (Ubuntu)
Wishlist
Unassigned

Bug Description

The Appearance setting used to have the ability to set icon sets, fonts, dpi, and font hinting. These are all missing from oneiric's gnome-control-center.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.90-0ubuntu2
Uname: Linux 3.1.0-rc4-git-20110831.1150 x86_64
Architecture: amd64
Date: Sun Sep 4 07:27:56 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (1 days ago)

Rocko (rockorequin) wrote :
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
seanyseansean (seany) wrote :

As an FYI the options are missing both on an upgrade and a fresh install of 11.10.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
Rocko (rockorequin) wrote :

... and they aren't going to fix it. They removed the configuration options on purpose.

Gnome-tweak-tool provides this functionality, though (that's an Ubuntu-developed app, isn't it?) It shows up as 'Advanced Settings' and it would be a nice workaround for this bug if Advanced Settings appeared in System Settings.

seanyseansean (seany) wrote :

You can also use gconf editor to do this, but it's not exactly user-friendly is it?

Thank you for reporting this upstream, Rocko.

Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Invalid
Sebastien Bacher (seb128) wrote :

Jason, do you think that's the sort of option we should aim to get back by default?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Jason Warner (jasoncwarner)
Sam_ (and-sam) wrote :

Possibly dupe Bug #833553

Rocko (rockorequin) wrote :

Yes, I'd say that that bug and this are dupes.

Rocko (rockorequin) wrote :

Actually, gnome-tweak-tool doesn't quite work properly with the unity bar. If, for example, I set font hinting to slight and anti-aliasing to grayscale instead of rgba, the unity bar (and menus) are drawn with what looks like medium font hinting. Other apps look fine, though, eg gnome-tweak-tool renders itself using the selected settings correctly.

Otus (jan-varho) on 2011-10-14
tags: added: a11y
summary: - gnome-control center is missing font & icon settings
+ gnome-control center is missing font & icon-theme settings

These functionalities should be split into separate bugs (one per function).

tags: added: regression-release
summary: - gnome-control center is missing font & icon-theme settings
+ gnome-control-center is missing font & icon-theme settings

"wishlist"? This is not a pony, it is a regression.

Changed in gnome-control-center (Ubuntu):
assignee: Jason Warner (jasoncwarner) → nobody
status: Triaged → Invalid
Changed in gnome-control-center (Ubuntu):
status: Invalid → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.