Set password at next login / Login without a password does not work

Bug #821771 reported by Dylan McCall on 2011-08-06
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Michael Terry
Oneiric
Low
Michael Terry
lightdm (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

When adding a new user in the User Accounts panel, one can choose to have the password set at next login or to log in withotu a password. However, with LightDM neither of these work. When I click the user's name, LightDM demands a password and no obvious input will satisfy it.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Changed in lightdm (Ubuntu):
importance: Undecided → Low
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in lightdm (Ubuntu):
status: New → Confirmed
ChrisLees (christopher-lees) wrote :

This also occurs when the only user account on the computer decides to change their password on next login, which results in them being locked out of their own computer.

This bug should be critical. Just hiding the option in Gnome Control Center would be sufficient to workaround the bug for now.

Michael Terry (mterry) on 2011-09-19
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Michael Terry (mterry)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.92-0ubuntu2

---------------
gnome-control-center (1:3.1.92-0ubuntu2) oneiric; urgency=low

  [ Rodrigo Moya ]
  * debian/patches/00git_use_gtk_widget_show.patch:
    - Use gtk_widget_show instead of _show_all in gnome_control_center_show
      (LP: #854544)
  * debian/patches/00git_show_section_labels.patch:
    - Show the label for the category sections, which was being shown because
      of the gtk_widget_show_all replaced in previous commit

  [ Jeremy Bicha ]
  * debian/patches/04_add_theme_selection.patch: Use correct High Contrast
    theme names
  * debian/patches/53_use_ubuntu_help.patch: Replaced

  [ Michael Terry ]
  * debian/patches/55_user_accounts_hide_controls.patch:
    - When not using GDM, hide certain controls in the User Accounts
      panel that only apply to it. (LP: #821766, LP: #821771)
    - When a user is using an ecryptfs home directory, do not allow
      the user to log in without a password
 -- Michael Terry <email address hidden> Thu, 22 Sep 2011 11:25:29 -0400

Changed in gnome-control-center (Ubuntu Oneiric):
status: Confirmed → Fix Released
Luca Ferretti (elle.uca) wrote :

Curiosity: is this just workaround for 11.10 or ... ?

Michael Terry (mterry) wrote :

I don't know. It's a workaround until the functionality is in LightDM. Rob would know where this is in its roadmap.

Robert Ancell (robert-ancell) wrote :

There were some fixes in LightDM to PAM behaviour and this may work now (haven't tested it).

Changed in lightdm (Ubuntu Oneiric):
assignee: Robert Ancell (robert-ancell) → nobody
Sebastien Bacher (seb128) wrote :

Robert says that it's probably fixed in the current version so we should revert the g-c-c change in precise and try again if that's still an issue

Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Triaged
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers