Password Hint field is not respected in LightDM greeter

Bug #821766 reported by Dylan McCall on 2011-08-06
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Michael Terry
Oneiric
Low
Michael Terry
lightdm (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

The User Accounts panel allows you to set a hint for a new password. This hint is not displayed in LightDM. Either LightDM should display password hints, or the field should not be there when LightDM is enabled in Ubuntu.

Changed in lightdm (Ubuntu):
importance: Undecided → Low
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in lightdm (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2011-09-19
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

I have a fix for this and bug 821771, where I hide the controls not supported by LightDM when using it (and show them when using GDM). But I'm going to hold off uploading until after Beta 2, as these are marked Low priority and not milestoned for the beta.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.92-0ubuntu2

---------------
gnome-control-center (1:3.1.92-0ubuntu2) oneiric; urgency=low

  [ Rodrigo Moya ]
  * debian/patches/00git_use_gtk_widget_show.patch:
    - Use gtk_widget_show instead of _show_all in gnome_control_center_show
      (LP: #854544)
  * debian/patches/00git_show_section_labels.patch:
    - Show the label for the category sections, which was being shown because
      of the gtk_widget_show_all replaced in previous commit

  [ Jeremy Bicha ]
  * debian/patches/04_add_theme_selection.patch: Use correct High Contrast
    theme names
  * debian/patches/53_use_ubuntu_help.patch: Replaced

  [ Michael Terry ]
  * debian/patches/55_user_accounts_hide_controls.patch:
    - When not using GDM, hide certain controls in the User Accounts
      panel that only apply to it. (LP: #821766, LP: #821771)
    - When a user is using an ecryptfs home directory, do not allow
      the user to log in without a password
 -- Michael Terry <email address hidden> Thu, 22 Sep 2011 11:25:29 -0400

Changed in gnome-control-center (Ubuntu Oneiric):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Robert says that it's probably fixed in the current version so we should revert the g-c-c change in precise and try again if that's still an issue

Changed in lightdm (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers