info capplet: launch update-manager instead of packagekit

Bug #801335 reported by Jean-Baptiste Lallement on 2011-06-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Rodrigo Moya
Oneiric
Medium
Rodrigo Moya

Bug Description

When there are updates available on the system, the 'Overview' section of the info capplet shows an 'Updates Available' button, this button requires gnome-packagekit but it should launch update-manager instead or be removed.

TEST CASE:
1. Ensure that the system is _not_ up to date and there are updates to install
2. Launch gnome-control-center info capplet
 $ gnome-control-center info
3. Select the section 'Overview'
  -> A button 'Updates Available' is displayed at the bottom right
4. Click on this button

Result:
* If gnome-packagekit is not installed, nothing happens and the following message is displayed on the terminal:
(gnome-control-center:11905): info-cc-panel-WARNING **: unable to launch Software Updates: Failed to execute child process "gpk-update-viewer" (No such file or directory)

* If gnome-packagekit is installed it launch 'gpk-update-viewer'

Expected:
update-manager is launched instead (unless the plan is to replace update-manager by gpk but there is a redundancy there)

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.0.2-1ubuntu4
ProcVersionSignature: Ubuntu 3.0-1.2-generic 3.0.0-rc3
Uname: Linux 3.0-1-generic i686
Architecture: i386
Date: Thu Jun 23 22:25:45 2011
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-05-16 (38 days ago)

Jean-Baptiste Lallement (jibel) wrote :
summary: - info capplet: missing dependency on gnome-packagekit and should use
+ info capplet: missing dependency on gnome-packagekit or should use
update-manager instead
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)

I think we should use update-notifier for this for the time being, and disable the upstream PackageKit part. We don't want to use packagekit as a general package manager/upgrader.

Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Rodrigo Moya (rodrigo-moya)
status: New → Triaged
summary: - info capplet: missing dependency on gnome-packagekit or should use
- update-manager instead
+ disable packagekit parts of info capplet; we are using update-manager
summary: - disable packagekit parts of info capplet; we are using update-manager
+ info capplet: launch update-manager instead of packagekit
Changed in gnome-control-center (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in gnome-control-center (Ubuntu Oneiric):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.3-0ubuntu3

---------------
gnome-control-center (1:3.1.3-0ubuntu3) oneiric; urgency=low

  * debian/patches/05_run_update_manager.patch:
    - Run update-manager instead of PackageKit updater (LP: #801335)
 -- Rodrigo Moya <email address hidden> Tue, 05 Jul 2011 18:08:07 +0200

Changed in gnome-control-center (Ubuntu Oneiric):
status: In Progress → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers