[FFE] [UIFE] [Regression] Power section no longer allows configuration of "when the lid is closed" action in Oneiric

Bug #792636 reported by Tom Adams on 2011-06-04
164
This bug affects 30 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Won't Fix
Medium
gnome-control-center (Ubuntu)
High
Martin Pitt
Oneiric
High
Martin Pitt
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: gnome-control-center

In Natty I was able to configure what happens when the laptop lid was closed. Now that option doesn't exist in the power settings.

I tried to set the following gconf options to "nothing", but they had no immediate effect:
/apps/gnome-power-manager/buttons/lid_battery
/apps/gnome-power-manager/buttons/lid_ac

It would be helpful to know a temporary workaround as I close my laptop all the time but I never suspend/hibernate it.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.0.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
Date: Fri Jun 3 20:06:37 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcEnviron:
 LANGUAGE=en_US:en
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-06-03 (0 days ago)

Tom Adams (holizz) wrote :
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → Triaged
Tom Adams (holizz) wrote :

I've found a workaround for those who might need it:

Edit /etc/UPower/UPower.conf and change the line at the bottom "IgnoreLid=false" to "IgnoreLid=true".

Alessio L. (scionescire) wrote :

I confirm Tom Adams' workaround.

Daniel Holm (danielholm) wrote :

Does the screen just go blank after that workaround, or what?

Dave Russell (drussell) wrote :

Yup, just goes blank.

If you prefer a gui, you could install "gnome-tweak"

Shell > Laptop lid close ....

You can change the setting for when running on battery and when connected to AC.

Jeff Lane (bladernr) wrote :

Why should a user have to install gnome-tweak (assuming they knew what gnome-tweak was to begin with)?

This was easily configurable previously, someone just decided that users wouldn't want to actually prevent their system from suspending when the lid is closed.

But expecting the majority of users to start editing config files manually, or intuiting that there's something called "gnome-tweak" that will allow them to actually configure the power settings on their system isn't a proper solution for an OS geared towards the masses.

To be honest, I'm NOT a typical user, and this is really the first time I've ever heard of gnome-tweak myself.

Is there any benefit to NOT allowing users to configure this behaviour in the system configuration tools that ship with Ubuntu?

Dave Russell (drussell) wrote :

Don't get me wrong, I absolutely agree with you that the functionality should be in the default system config tools.

I'm just assisting in providing another workaround until this problem gets solved properly.

Tom Adams (holizz) wrote :

> Is there any benefit to NOT allowing users to configure this behaviour in the system configuration tools that ship with Ubuntu?

Here's a blog post about the issue from the point of view of a GNOME 3 developer: http://afaikblog.wordpress.com/2011/02/03/on-laptop-lids-and-power-settings/

Their reasoning for this change is: "The vast majority of people do not like lots of settings"

While I can understand that philosophy, the fact is that there ARE lots of settings available and GNOME 3 is just making them harder to get to.

Jeff Lane (bladernr) wrote :

Dave: No worries :) I actually appreciate your workaround, and learning about gnome-tweak, something I've never needed before. Like I said, it is fine for you and I, but not Mom and Dad (for most samples of Mom and Dad). I am just more frustrated that, as Tom points out, this seems to be a philosophical change, rather than one of any technical merit.

And I'm firmly on the other side of the debate here, as I am strongly against too much "dumbing down" of Linux. Make it easier to use for the average person, sure, but don't make it brain-dead. One of the BIGGEST draws to Linux aside from stability is that you can configure SO MUCH so easily, and limiting this, IMHO, takes away from Linux instead of adding any real value.

Jeff Lane (bladernr) wrote :

Tom: Thanks for the link... that's an interesting read, and unfortunately, they lost me completely at the statement :"The other reason not to include this setting is, of course, that it is another setting and, as we all know, settings kill kittens."

This is NOT "Another" setting, it's an "existing" setting. It did not ADD to the pool of existing settings, it was already there to begin with.

And from reading the comments I can see that I am not in the minority in having issue with removing this functionality.

I too am keenly interested in getting this back in the UI, as my bug # 840089 was determined invalid.

In my opinion gnome-tweak, gsettings hacking, etc is not relevant, as this is an easy to understand (and desired) setting for many people -- and it existed in Natty :)

u-foka (ufooka) wrote :

Hy!

I can understand the opinion of the gnome developers (even if I can't agree with them) but as they removed the gconf keys too, that's insane :(

The best way maybe would be to provide a simple gui for simple users with an advenced button in the corner (only one more item, that will never be pushed by someone who hates options) what is usefull for the users who love options..

u-foka (ufooka) wrote :

Hey, actually I found the config key moved from gconf to gsettings (can be edited trough dconf-editor) under /org/gnome/settings-daemon/power/lid-close-*-action

Colin Law (colin-law) wrote :

I would like to add myself to the list of those who think that there should be a setting for what happens when laptop lid is closed, in the hope that if enough users make the point then some action may be taken.

Tom Adams (holizz) wrote :

Colin: The best way to do that is to scroll to the top of this page and click "Does this bug affect you?" and "Yes, this bug affects me".

Having attended two conferences recently (LinuxCon and LinuxPlumbers), I heard this complaint over and over and over again about both Unity and Gnome3.

I'm raising this bug to "Critical" (though I suspect it'll be lowered to "High"), nominating for Oneiric, and targeting at the 11.10 release. I've also noted in the bug description that this is a regression from previous versions of Ubuntu. Hopefully this bug will get some attention and get fixed!

Cheers,
Dustin

Changed in gnome-control-center (Ubuntu):
importance: Medium → Critical
summary: - Power section no longer allows configuration of "when the lid is closed"
- action in Oneiric
+ [Regression] Power section no longer allows configuration of "when the
+ lid is closed" action in Oneiric
Changed in gnome-control-center (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Steve Langasek (vorlon) wrote :

Here is a commandline workaround for the current lack of reasonable GUI configuration (and lack of sensible defaults):

  gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing'

Per the "lack of sensible defaults" remark above, I'm also marking this bug as affecting gnome-settings-daemon; having the machine suspend on lid close when connected to power is an infuriating regression.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: New → Triaged
Martin Pitt (pitti) wrote :

I think it's just a control-center GUI issue, closing settings-daemon task for now. I'll reopen it if we actually need a change in g-s-d.

Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Triaged → Invalid
Changed in gnome-control-center (Ubuntu Oneiric):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Ah, the g-s-d task was opened for changing the default for lid closing. We have defaulted to suspending on lid close for a while now, and it makes sense as well (you are about to put it into a bag, etc.). There are sure people who liked to configure it otherwise, so for this we desperately need the option back in the control center.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Invalid → Won't Fix
Martin Pitt (pitti) wrote :

I have the patch half-done now, so this is doable. However, this means both an UIF (new widgets) as well as new strings, so subscribing doc team and translators for their input.

summary: - [Regression] Power section no longer allows configuration of "when the
- lid is closed" action in Oneiric
+ [FFE] [UIFE] [Regression] Power section no longer allows configuration
+ of "when the lid is closed" action in Oneiric
TLE (k-nielsen81) wrote :

Forgive me I haven't read the entire thread. What roughly is the string change count for this patch?

Martin Pitt (pitti) wrote :

I added the patch to the upstream bug: https://bugzilla.gnome.org/attachment.cgi?id=196492

We have one new string:

+ <property name="label" translatable="yes">When the lid is closed:</property>

Martin Pitt (pitti) wrote :

Patch done and sent to upstream bug, awaiting FFE/UIFE ack for uploading.

Luca Ferretti (elle.uca) wrote :

A little note: all power related settings in GNOME weren't "removed" from GConf, but "moved" from GConf to GSettins/Dconf.
This means you have to install and run dconf-editor instead gconf-editor in order to have a direct and full control.

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Martin Pitt (pitti) on 2011-09-15
Changed in gnome-control-center (Ubuntu Oneiric):
milestone: ubuntu-11.10 → ubuntu-11.10-beta-2
importance: Critical → High
David Planella (dpm) wrote :

I think it's important to provide this functionality again, and the fact that we need a new string is secondary on this particular case, so translations shouldn't be blocking the update.

+1 from the translations side

Martin Pitt (pitti) on 2011-09-15
Changed in gnome-control-center (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.91-0ubuntu8

---------------
gnome-control-center (1:3.1.91-0ubuntu8) oneiric; urgency=low

  * Add 11_power-configure_lid_action.patch: Add back configuration for lid
    action. (LP: #792636, GNOME#659045)
 -- Martin Pitt <email address hidden> Thu, 15 Sep 2011 10:49:49 +0200

Changed in gnome-control-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
status: New → Won't Fix
futurefx (force) wrote :

blank screen is still missing so please can someone add option to blank screen...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.