Ubuntu

[Natty-Beta2] Turning off laptop monitor turn off both monitors (laptop and external) on Vostro 3500

Reported by Joaquín Ignacio Aramendía on 2011-04-19
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: gnome-control-center

Following instructions for testing external monitor on a laptop in http://testcases.qa.ubuntu.com/Hardware/GFX/ExternalPrimary
the resolutions of the external monitor are not detected properly. When I try to change them, also the Laptop Screen flickers and changes sizes (with "same image" option disabled, of course).
Worse is when I try to set the external monitor to be primary (by turning off the laptop screen), both screens turn off.
My steps:
# Plugged external monitor
# Go to Monitor in the Unity launcher.
# Both screens are detected.
# Tried different resolutions and more or less some of them worked (there where some resolutions external monitor isn't capable of).
# Selected Laptop monitor and switched off, click apply.
# Both monitors turned off and had to wait for the 30 second dialog to restore the last configuration. I was hoping the laptop screen to turn off and the external monitor be the primary.

Then tried the switch screen har-button in this laptop (Fn + F8) but it triggers a "super" key instead (like the win logo).
Afterwards Compiz crashed (Bug #766496).

[Next Actions]
* Reproduce under Oneiric to verify the issue is still relevant
* Reproduce under Precise to verify it still occurs in development
* Collect gsd logs as per comment #10

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-control-center 1:2.32.1-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Tue Apr 19 16:38:56 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
ProcEnviron:
 LANGUAGE=es_AR:en
 LANG=es_AR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated

This is a regression.
Both turning off of any monitor and the hard-key works in Maverick with kernel 2.6.35.28

I can confirm that this problem exists also in 11.04 final. Switching off a laptop screnn will switch off ALL monitors. Unti 10.10 the external Monitor remained working ...

Michael

This is tested with a Thinkpad L512 a 22" ext. Monitor. It seems that the handling of Fn F7 is different to the prev. versions.

Michael

PascalCavy (p92) wrote :

Same problems with thinkpad X40 since Natty and KDE :

This PC have an integrated video Intel i855GM

1- i am now unable to switch screen between internal and external with Fn+F7
2- At boot the external screen is detected but becomes a clone of the internal screen, including taking its size, so I have only a portion of my big external screen that is used
3- if I try to switch with Fn-F7 during Xorg initialisation, before the mouse of Xorg appears, then both screen goes black and are not usable again
4- If I let both screen initialize and kde start, then I am in situation 2, but switch screen hard button is inoperative, and kde monitor settings reports only one screen

It is more probably a kernel problem.

Patrick Eugenis (peugenis) wrote :

I also have this problem on a Thinkpad T410 with the i5 processor with Intel integrated video. I am running the 64-bit OS. This worked without an issue on Maverick.
-T410:~$ sudo dmidecode -t 11
# dmidecode 2.9
SMBIOS 2.6 present.
Handle 0x0027, DMI type 11, 5 bytes
OEM Strings
 String 1: IBM ThinkPad Embedded Controller -[6IHT39WW-1.14 ]-

-T410:~$ sudo lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Dean Jansen (list) wrote :

I'm experiencing the same thing on a T410s Thinkpad (intel graphics only, no AMD or NVIDIA). I think I'm actually running the 32-bit OS (accidentally... oops)

T410s:~$ sudo dmidecode -t 11
# dmidecode 2.9
SMBIOS 2.6 present.

Handle 0x0027, DMI type 11, 5 bytes
OEM Strings
 String 1: IBM ThinkPad Embedded Controller -[6UHT29WW-1.10 ]-

T410s:~$ sudo lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Carlos Contardo (ccontardo) wrote :

I have the same problem, and i think some other people have it as well...
I'm using Ubuntu 11.04 on an Alienware M11x R2.
At the time, I can only use both monitors (laptop's and external) if both are displaying the same thing. On alienware m11x, the external monitor can go up to 1920px resolution, but laptop monitor only to 1366px... At the time, the system only allows me to go up to 1024px when both monitors are up...

Todd Kennedy (toddkenn) wrote :

Just adding to the list of affected ubuntu-ers

Natty 11.04
IBM T410 with Intel Integrated GPU

Secondary monitor is via DVI->Acer 22" Monitor

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Could somebody create "gsd-debug-randr" file in you user directory, restart the session, change the screen settings and copy the "gsd-debug-randr.log" which got created in the user directory to the bug?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

[The Design Team has identified this as a blocker issue for precise, so setting the Importance to Critical. This may be adjusted down once the bug has received further design and engineering analysis, if appropriate.]

Changed in gnome-control-center (Ubuntu):
importance: Low → Critical
Bryce Harrington (bryce) on 2011-11-18
description: updated
Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) wrote :

The design team flagged this as a possible critical issue for us to solve in the development release (and SRU to natty and/or oneiric, if the fixes are suitable and appropriate to backport).

However, I notice this report only has comments from natty users, so I am wondering if this issue might have gotten solved in oneiric? (I haven't seen it on oneiric, but then I don't recall ever seeing it on natty either.) So if someone has oneiric installed and still sees this same bug, please indicate your verification (and post a gsd log as seb128 requested).

To get this resolved, we need someone running the precise development version who can test fixes for us. If anyone is on precise, still reproducing the bug, and willing to do some test work, please raise your hand.

(I've listed these tasks in the Next Actions section of the bug description)

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Closing as expired since it has been several months waiting for information.

It's likely the newer kernel in precise does not have this bug.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Invalid
Karolis (karolis) wrote :

I had this issue on 11.10, but it got resolved by upgrading to 3.2 kernel.

Karolis (karolis) wrote :

Another workaround is to switch your primary display from laptop screen to external monitor/TV by moving laptop to the right in display settings, since left screen is always default in Unity. When you do that, you can turn off the laptop screen http://i.imgur.com/ZD8YE.png

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints