cannot cope with incorrect current password under LDAP backend

Bug #607357 reported by Ryan Tandy
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Fix Released
Low
Unassigned
Lucid
Fix Released
Low
Unassigned

Bug Description

Binary package hint: gnome-control-center

When changing a UNIX password, if you enter an incorrect current password passwd will print an error and exit. However when using LDAP, unless the password has length 0 passwd offers another chance.

Enter login(LDAP) password:
LDAP Password incorrect: try again
Enter login(LDAP) password:

gnome-about-me mistakes the second prompt for the prompt to enter a new password and assumes the initial password was correct. Proceeding through the dialog eventually results in gnome-about-me hanging since passwd exits either at an unexpected time or not at all.

The interaction completes as expected when the correct initial password is given.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-control-center 1:2.30.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Jul 19 10:27:09 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: gnome-control-center

Revision history for this message
Ryan Tandy (rtandy) wrote :
Revision history for this message
raerek (raerek) wrote :

This is an issue on x86 too.
Some more symptoms (sorry for not being able to reproduce the correct dialogs, I do not have this app in English)
1) Clicking on Change Password the 'Present password' line accepts ANY passwords, after clicking on the Check button (the one to the right form the 'Presnet password' input box).
2) Then you give your new password (twice). You do this happily as you have been NOT warned that you made a typo at the present password. You click on the Change Password button and you get: 'The old and new passwords are the same.' (of course they are not.)

tags: added: x86
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Ryan Tandy (rtandy) wrote :

Thanks for the response. I fixed the problem locally a long time ago and mostly forgot about this bug. Looking at my bugs in bugzilla.gnome.org I don't think I ever filed it upstream either.

I installed a fresh VM of Natty and checked the behaviour. I use libpam-ldapd these days and when that is active the behaviour is correct. I also checked libpam-ldap and when that is active the bug is still present as reported.

I am attaching the patch I have in production that fixes this problem. It's against gnome-control-center 2.30.1-0ubuntu1 from Lucid. Should I regenerate the patch against upstream's git master and send it to them?

tags: added: patch
Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your work, gnome-about-me got deprecated in GNOME3 though so that patch doesn't apply to upstream or oneiric

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-control-center (Ubuntu Lucid):
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Sebastien Bacher (seb128) wrote :

the patch could still be useful for lucid so I'm opening a bug against that serie and subscribing ubuntu-sponsors

Changed in gnome-control-center (Ubuntu):
status: Invalid → Triaged
Revision history for this message
Sebastien Bacher (seb128) wrote :

in fact it might still apply to the new user-accounts dialog which has similar looking code

" switch (passwd_handler->backend_state) {
                case PASSWD_STATE_AUTH:
                        /* Passwd is asking for our current password */

                        if (is_string_complete (str->str, "assword: ", "failure", "wrong", "error", NULL))
 {

                                if (strstr (str->str, "assword: ") != NULL) {"

so to check and maybe to adapt for that version as well

summary: - gnome-about-me: cannot cope with incorrect current password under LDAP
- backend
+ cannot cope with incorrect current password under LDAP backend
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.3-0ubuntu5

---------------
gnome-control-center (1:3.1.3-0ubuntu5) oneiric; urgency=low

  * Fix LP: #607357 - cannot cope with incorrect current password under
    LDAP backend. Add patch based on original patch to gnome-about-me from
    Ryan Tandy
    - add debian/patches/06_handle_passwd_with_ldap.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 11 Jul 2011 23:13:29 +0100

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Chris Halse Rogers (raof) wrote :

SRU team ack: please accept into lucid-proposed.

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Ryan, or anyone else affected,

Accepted gnome-control-center into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-control-center (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Ryan Tandy (rtandy) wrote :

I installed gnome-control-center 1:2.30.1-0ubuntu2 from lucid-proposed and verified that it fixes the reported issue. Thanks for accepting my patch!

tags: added: verification-done
removed: verification-needed
Changed in gnome-control-center (Ubuntu):
assignee: nobody → MARIO MARTINEZ (www-martinez-13)
Changed in gnome-control-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

setting back to "fix committed" because 1:2.30.1-0ubuntu2 is not published to -updates.

Changed in gnome-control-center (Ubuntu):
assignee: MARIO MARTINEZ (www-martinez-13) → nobody
Changed in gnome-control-center (Ubuntu Lucid):
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.30.1-0ubuntu2

---------------
gnome-control-center (1:2.30.1-0ubuntu2) lucid-proposed; urgency=low

  * Fix LP: #607357 - cannot cope with incorrect current password under
    LDAP backend. Patch from Ryan Tandy
    - add debian/patches/98_handle_passwd_with_ldap.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Mon, 11 Jul 2011 23:23:04 +0100

Changed in gnome-control-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
brendan.r (b-enmark) wrote : The Nature gives opportunities to live confidently healthy and hot!

The Nat vvg ure gives oppor zat tunities to live confi jpn dently hea mkh lthy and h bqy ot!
New her mb bal form cwz ula of pills what fixes ere wg ction!
Try someting bet ou ter than usual arse bv nals.
www.berettax-bige.ru

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers