Ubuntu

Ubuntu does not remember selected backgrounds after rebooting

Reported by Najmudin on 2010-05-22
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Expired
Medium
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-control-center

Ubuntu 10.04 dose not remember the selected backgrounds after rebooting except the active one.
When adding a couple of images using "Appearance Preferences > Add" and keep one of them as my wallpaper ,after that i reboot the computer to XP then i reboot again to Ubuntu the active wallpaper is still there in use but the other wallpapers which i selected previously are all disappeared.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-control-center 1:2.30.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat May 22 05:26:17 2010
ExecutablePath: /usr/bin/gnome-appearance-properties
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-control-center

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of GNOME Control Center is available on Maverick and we are wondering if this bug is still an issue for you with that version? Could you please test and comment back? Thanks in advance.

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete

The problem is solved in Maverick Meerkat i did a test and the wallpaper's did not disappear .
Regards

They disappeared again after two day's :(
I'm not sure what happened exactly but i think It might be that i added a wallpaper by right clicking on a picture and selecting "Set as desktop background" which cause's previously selected wallpapers using Add button to disappear.

tsg1zzn (tsg1zzn) wrote :

II also have this problem. The list of background images resets semi-regularly for no apparent reason.

Ubuntu 10.10.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Alan Hill (hundredsand100s) wrote :

This is a persistent problem for me, too. Added wallpaper only remains in the list between reboots if it's the current wallpaper.

Kimiko Koopman (kimiko) wrote :

Confirmed. This bug is still present in Natty, gnome-control-center version 1:2.32.1-0ubuntu2. It's quite annoying that I have to re-add all my backgrounds almost every time I want to switch to a new one.

summary: - Ubuntu dose not remember selected Backgrounds after rebooting
+ Ubuntu does not remember selected backgrounds after rebooting
Kimiko Koopman (kimiko) wrote :

I just checked Gnome Bugzilla. This bug is known there under [[https://bugzilla.gnome.org/show_bug.cgi?id=636548|#636548]].
Gnome bug [[https://bugzilla.gnome.org/show_bug.cgi?id=634156|#634156]] also looks promising though, as it offers an explanation (and patch) for the apparent random disappearance of backgrounds.

Kimiko Koopman (kimiko) wrote :

Patch copied from upstream bugzilla. Confirmed there to solve this problem.

tags: added: patch
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.32.1-0ubuntu8

---------------
gnome-control-center (1:2.32.1-0ubuntu8) natty; urgency=low

  * debian/patches/00_git_dont_erase_background_xml.patch:
    - from upstream, prevent removing background.xml which removes
      manually added backgrounds. (LP: #584054)
      Thanks to Kimiko Koopman for backporting it.
 -- Didier Roche <email address hidden> Fri, 11 Mar 2011 11:40:00 +0100

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.