Gnome Appearance Properties dialog hangs when changing desktop effects

Bug #554106 reported by Andreas Modinos
360
This bug affects 69 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Fix Released
Medium
Chris Coulson
Lucid
Fix Released
Medium
Chris Coulson

Bug Description

Binary package hint: gnome-control-center

When enabling or disabling desktop effects the settings will change successfully but the Gnome Appearance Properties window and it's sub-windows will become completely unresponsive.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-control-center 1:2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Fri Apr 2 19:55:43 2010
ExecutablePath: /usr/bin/gnome-appearance-properties
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
ProcEnviron:
 LANG=fi_FI.utf8
 SHELL=/bin/bash
SourcePackage: gnome-control-center

Revision history for this message
Andreas Modinos (blueturtl) wrote :
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Hmmm, I can recreate this one too

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: needs-reassignment
tags: removed: needs-reassignment
summary: - [Lucid]Gnome Appearance Properties dialog hangs
+ Gnome Appearance Properties dialog hangs
Revision history for this message
Peter Funk (pf-artcom-gmbh) wrote : Re: Gnome Appearance Properties dialog hangs

Today I installed the 10.4-beta1 64 bit on a test machine.
Steps to repoduce: install on computer with NVidia graphics card. Install nvidia driver.
Select Preferences->Appearance->Visual Effects. Switch from None to Normal. Compiz
gets started but the gnome-appearance-properties process freezes and no longer
responds after it has displayed the dialogue asking whether one wants to keep the
settings.

Revision history for this message
Daniel Gnoutcheff (gnoutchd) wrote :

Also reproducible here with intel graphics.

summary: - Gnome Appearance Properties dialog hangs
+ Gnome Appearance Properties dialog hangs when changing desktop effects
Revision history for this message
Christoph Korn (c-korn) wrote :

I created a backtrace in my bug report.

In case it is of any use:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/552608/comments/4

Didier Roche (didrocks)
Changed in gnome-control-center (Ubuntu Lucid):
assignee: nobody → Didier Roche (didrocks)
Revision history for this message
Rune K. Svendsen (runeks) wrote :

I'm affected by this as well. Using the open source "radeon" driver.

Is there a way to enable visual effects without using gnome-appearance-properties, that can be used as a workaround for this bug?

Revision history for this message
Henrik S. (henrik-hw0) wrote :

I have this bug as well. Intel graphics. Recently upgraded to Lucid Lynx from 9.10.

Revision history for this message
captinkid (captinkid) wrote :

Reproducible on Nvidia 9500GT using binary driver

Revision history for this message
xteejx (xteejx-deactivatedaccount) wrote :

Affects me too with nvidia current drivers. Full backtrace and strace (if needed) in my duplicate for any dev that needs it bug 558589.

Revision history for this message
Daniel Gnoutcheff (gnoutchd) wrote :

Yep, it seems pretty clear that this bug is not dependent on the graphics driver in use. ;)

Revision history for this message
Rune K. Svendsen (runeks) wrote :

I had to reinstall Lucid because of this (I'm pretty sure).
I initially turned off the desktop effects to test a bug in compiz. Metacity was enabled, but the appearance dialog hung when I pressed the button to keep the settings. After trying to switch back to using desktop effects (compiz), the hanging still happens, but the settings aren't saved it seems. So apparantly it's possible to disable the desktop effects, even though the dialog hangs when pressing "Keep Settings", but it isn't possible to enable the desktop effects again.
This seemed to work OK in the beginning with metacity, without me being able to switch back to using compiz. But then all of the sudden, after a reboot, the window borders disappeared and gnome-panel as well.
I had noticed that before this happening, alongside metacity, compiz-decorator was running. But after this reboot, when the window border and gnome-panel were gone, compiz-decorator wasn't running in the background any longer.

Revision history for this message
Jean-Sebastien Gosselin (jsgosselin) wrote :

@rune Svendsen

Same thing happened to me...as a temporary workaround, I added metacity in my Startup app. pref. This behavior began just after an update I did yesterday I think.

John Doe (jdoe001)
Changed in gnome-control-center (Ubuntu Lucid):
status: Triaged → Confirmed
Revision history for this message
Jacopo Moronato (jmoronat) wrote :

Same thing as Rune Svendsen reported.
Maybe a metacity bug ?

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thanks, but we don't need any more "me too" type comments. We know there is a bug, and we know that this bug affects everybody and is not hardware specific at all. We're currently working hard to investigate the issue, and it will be fixed once we've figured it out.

In the meantime, you can register that this bug affects you at the top of the page without having to leave a comment. However, please provide information if you think it will help fix the bug

Changed in gnome-control-center (Ubuntu Lucid):
status: Confirmed → Triaged
Revision history for this message
xteejx (xteejx-deactivatedaccount) wrote :

Also, please do not change the status from Triaged to Confirmed. This lowers the importance of the bug's status and means it will be less likely to be fixed. Thanks guys.

Changed in gnome-control-center (Ubuntu Lucid):
assignee: Didier Roche (didrocks) → Chris Coulson (chrisccoulson)
status: Triaged → In Progress
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Fixed in bzr now:

bzr commit -m '* debian/patches/95_desktop-effects-integration.patch:
  - Updated to ensure that we don't call GTK functions outside of the
    GDK global lock. This fixes a deadlock caused by trying to
    recursively lock the GDK global lock (LP: #554106)' --fixes 'lp:554106'
Committing to: /home/chr1s/src/gnome-control-center/ubuntu-desktop/ubuntu/
modified debian/changelog
modified debian/patches/95_desktop-effects-integration.patch
Committed revision 169.

Changed in gnome-control-center (Ubuntu Lucid):
status: In Progress → Fix Committed
Revision history for this message
Z37A (juanzele) wrote :

Add my output, if needed:

$ gnome-appearance-properties

(gnome-appearance-properties:2496): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

(gnome-appearance-properties:2496): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed
No hay ningún controlador gráfico disponible para su sistema que soporte la extensión de composición, o bien el actual ya lo soporta.

(gnome-appearance-properties:2496): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed
Couldn't find a perfect decorator match; trying all decorators
Found no decorator to start

Revision history for this message
xteejx (xteejx-deactivatedaccount) wrote :

No need, Chris has committed a fix in bzr so just wait for it to be uploaded to the repos - an update for this should be available soon.

Revision history for this message
The Recorder (arthurbm) wrote :

Enabling effects, when in dual screen mode (2048x768) "Doesn't" change successfully. Please see my thread, especially comment #4 http://ubuntuforums.org/showpost.php?p=9106550&postcount=4

Jiří Pagáč (j-pagac)
Changed in gnome-control-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.30.0-0ubuntu4

---------------
gnome-control-center (1:2.30.0-0ubuntu4) lucid; urgency=low

  * debian/patches/95_desktop-effects-integration.patch:
    - Updated to ensure that we don't call GTK functions outside of the
      GDK global lock. This fixes a deadlock caused by trying to
      recursively lock the GDK global lock (LP: #554106)
 -- Chris Coulson <email address hidden> Sat, 10 Apr 2010 00:21:28 +0100

Changed in gnome-control-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Catalin David (c.david) wrote :

I don't know if I should open another ticket or just keep on talking on this one.

I have Lucid 64bit, updated 10 minutes ago from the main repositories (the bugfix was included) working on a Dell laptop with an Intel 945gm video card, 2GB RAM, Intel Dual Core processor.

I was experiencing same issue as before, but after the update, whenever I try to enable desktop effects (setting to normal), I get a small screen which says looking for drivers and after about 1 minute, it says that "Desktop effects cannot be enabled". Looking at the console, it reads:

$ gnome-appearance-properties
(gnome-appearance-properties:2398): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed
(gnome-appearance-properties:2398): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed
There is no available graphics driver for your system which supports the composite extension, or the current one already supports it.
compiz (core) - Warn: Exceeded max texture size
Launching fallback window manager
(gnome-appearance-properties:2398): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

I remember desktop effects used to work until now, even on my rusty, old, integrated 945gm. One more thing I should mention is that I am running a dual screen setup, the laptop monitor and a 23" external monitor (if that might help).

Thanks

Revision history for this message
Catalin David (c.david) wrote :

Update: Effects work (great) if only one of the two monitors is online, while the other one is disabled. If both of them are enabled, effects do not work. I tend to blame the graphics card and the graphics card driver for this, but, if I can help tracking down this issue, let me know.

Thanks again

Revision history for this message
The Recorder (arthurbm) wrote :
Download full text (17.1 KiB)

THIS BUG HAS NOT BEEN FIXED - SAME THING AS PREVIOUS COMMENT - DATA FOLLOWS
AS YOU CAN SEE BY THE LAST COMMAND (LAST SEVERAL LINES OF DATA), EVEN WHEN CHECKS ARE SKIPPED, COMPIZ WILL NOT START - THIS IS NOT A COMPIZ BUG - THIS IS A LUCID BUG

arthur@arthur-desktop:~$ ./compiz-check

Gathering information about your system...

 Distribution: Ubuntu 10.04
 Desktop environment: GNOME
 Graphics chip: ATI Technologies Inc RV410 [Radeon X700 (PCIE)]
 Driver in use: radeon
 Rendering method: AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap... [ OK ]
 Checking for non power of two support... [ OK ]
 Checking for composite extension... [ OK ]
 Checking for FBConfig... [ OK ]
 Checking for hardware/setup problems... [ OK ]

*************

arthur@arthur-desktop:~$ xrandr | grep '*'
   1024x768 75.1* 75.0 70.1 60.0
   1024x768 75.1* 70.1 60.0

*************

arthur@arthur-desktop:~$ xdpyinfo | grep 'dimensions:'
  dimensions: 2048x768 pixels (542x203 millimeters)

*************

arthur@arthur-desktop:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.4
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
    GLX_EXT_texture_from_pixmap
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 (RV410 5E4D) 20090101 x86/MMX/SSE2 TCL DRI2
OpenGL version string: 1.5 Mesa 7.7.1
OpenGL extensions:
    GL_EXT_compiled_vertex_array, GL_EXT_texture_env_add,
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_provoking_vertex,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clam...

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This bug has been fixed, and your problem is completely unrelated

Revision history for this message
Andreas Modinos (blueturtl) wrote :

I concur. This bug isn't about Compiz or desktop effects at all, it's about the preferences window hanging when trying to change the settings. After installing the update, I no longer suffer the problem.

Revision history for this message
The Recorder (arthurbm) wrote :
Revision history for this message
Vítor E. Silva Souza (vitorsouza) wrote :

I don't know if I'm doing something wrong, but I've just updated the system and I still suffer the problem: the Appearance Preferences and its "Keep Settings" dialog still hang, I have to kill it and if I open it again visual effects are not enabled. I don't have two monitors or anything, just my laptop (HP 6730b).

Let me know if you need me to run any commands and attach the outputs. Thank you.

Revision history for this message
Joshua Lückers (joshualuckers) wrote :

Make sure compiz is installed: sudo aptitude install compiz

Revision history for this message
radjan (daniel-novais) wrote :

Joshua, reinstalling compiz worked like a charm to me. Don't know exactly why or when, my system installed a whole lot of KDE-based programs. Once I reinstalled compiz, they were all deleted and I finally had the chance to use the effects.

I recommend everyone to check if compiz is correctly installed before taking other steps.

My thanks to both Ubuntu team and the community as a whole.

Revision history for this message
Vítor E. Silva Souza (vitorsouza) wrote :

@Joshua Lückers: thanks for the tip. It's weird that you can have CompizConfig Settings Manager installed without Compiz. I would have never imagined that Compiz wasn't installed.

Now I have visual effects. However, the "Appearance Preferences" window and "Keep Settings" dialog are still hanging and I have to kill it to go away. At least now I got Visual Effects back. So I don't care too much if those windows hang because I'm not going to use them on a regular basis. But, again, if you want me to attach some outputs here at this report or create a new bug report using System Monitor let me know.

Vítor

Revision history for this message
Kristian Cleworth (kristian-cleworth) wrote :

The visual effect window no longer hangs for me... and I get the visual effects. But they just seem to be reset on every startup!

Revision history for this message
radjan (daniel-novais) wrote :

@Vitor/Kristian,

I installed the Unstable package, and it no longer hangs. You may want to try that.

Revision history for this message
Kristian Cleworth (kristian-cleworth) wrote :

@radjan

This is what I installed, and it works fine... I can change my visual effects and it looks brilliant. It no longer hangs.

But when I restart my laptop it reverts to the old settings....

Acer 5810t

Revision history for this message
radjan (daniel-novais) wrote :

@Kristian

Got it. I'm sorry, that's all I had to do to make it work. Beside that, I only installed the Compiz basic configuration editor, so I could custom the visual effects. But I don't think this is the reason that it works around here.

I wish I could help, but my knowledge around Linux/Ubuntu is not that big. Sorry.

Revision history for this message
Doooh_Head (doooh-head) wrote :

I got the latest code last night via Update Manager and this problem still occurred. I took the advice of another post here and I ran sudo apt-get install compiz.

Of course compiz was already installed BUT according to apt-get there was a few files that did need to be updated. Once that was complete, and I logged out and back in, everything worked just fine.

Revision history for this message
Omer Akram (om26er) wrote : Re: [Bug 554106] Re: Gnome Appearance Properties dialog hangs when changing desktop effects

Works fine for me after update to gnome-control-center

Revision history for this message
VSN (vsn-inbox) wrote :

Works great.

Thanks for fixing it!

Revision history for this message
Novid (novid) wrote :

yet, i have this problem (after latest update)

Revision history for this message
Marco Lackovic (marco-lackovic) wrote :

I had the same problem and fixed it by running "sudo apt-get install compiz".

Extra packages installed:
  compiz-gnome
Suggested packages:
  gnome-themes
NEW packages installed:
  compiz compiz-gnome

Revision history for this message
Novid (novid) wrote :

"sudo apt-get install compiz" work for me too . thx Marco

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers