gnome-appearance-properties crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()

Bug #552132 reported by James Gregory-Monk
206
This bug affects 43 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Fix Released
High
Didier Roche

Bug Description

Binary package hint: gnome-control-center

I was attempting to load the 'Appearance' utility after selecting 'Change background picture' from the right-click menu on the desktop. The Appearance utility didn't load at all and I was presented with this crash report.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: gnome-control-center 1:2.30.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
Architecture: i386
CheckboxSubmission: 6cd5399a31534a3f5a71ddaa49ea22b7
CheckboxSystem: 669b662da410063cc918e0f60cf6cddf
Date: Tue Mar 30 23:59:44 2010
ExecutablePath: /usr/bin/gnome-appearance-properties
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcCmdline: gnome-appearance-properties --show-page=background
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x805ed94: mov 0x58(%edx),%eax
 PC (0x0805ed94) ok
 source "0x58(%edx)" (0x00000058) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? ()
 g_cclosure_marshal_VOID__VOID ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
Title: gnome-appearance-properties crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
James Gregory-Monk (jamgregory) wrote :
visibility: private → public
Revision history for this message
kikl (kilian-klaiber) wrote :

crashes when starting up Appearance in control center.

dinamic (dinamic6661)
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Revision history for this message
Akoley Marc (ekomak) wrote :

crashes when starting up Appearance in control center.

Revision history for this message
Dan DeSloover (d-ubuntuone-zifferent-net) wrote :

When I run it from a terminal:

(gnome-appearance-properties:2572): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

(gnome-appearance-properties:2572): Gdk-CRITICAL **: gdk_display_sync: assertion `GDK_IS_DISPLAY (display)' failed

About the third or fourth time running it, it worked.

Revision history for this message
Jesse Wilkerson (jesse-wilkerson) wrote :

I have this same problem, and it started when I updated gnome-control-center. For some reason, you can make gnome-appearance-properties work if you it in the terminal with sudo or as root (su). But that's probably not a good idea.

Revision history for this message
Doug McMahon (mc3man) wrote :

Exact same crash report on a fully updated 03/30 install, though..

On another machine, (fairly similar hardware), also fully updated there is no problem, gnome-appearance-properties opens as expected

Reverting to these on install with issue allows gnome-appearance-properties to open
capplets-data_2.29.92-0ubuntu3
gnome-control-center_2.29.92-0ubuntu3
libgnome-window-settings1_2.29.92-0ubuntu3

Updating back to the current 2.30 versions again causes the crash.

Revision history for this message
Doug McMahon (mc3man) wrote :

Maybe not related - but
On the machine that works correctly I have 2 parallel installs of lucid, exactly the same except one's on nouveau, the other nvidia-current.

Both were a couple of days behind updates, inc. the 18 kernel ect.

On the one that's currently working fine all the available updates where done in one session, took 2 runs thru the update manager, then a reboot and all is well.

On the other I just brought it forward, but held back gnome-control-center, ect., did a restart, finished the gnome and python, ect. updates, still holding back gnome-control-center. After a restart updated gnome-control-center and the 2 dep. packages - gnome-appearance-properties won't open and segfaults as described in this bug.

Revision history for this message
Alaric (jroose) wrote :

Confirmed that using the appearance manager as root does not crash. Will not allow us to change settings for the primary user account though and therefore most settings are not changeable for the average user.

Revision history for this message
Didier Roche (didrocks) wrote :

ok, confirmed. This happens when you changed the button layout to not match the default app one and start gnome-appearance-properties (it works well then in g-a-p).

Working on it

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.30.0-0ubuntu3

---------------
gnome-control-center (1:2.30.0-0ubuntu3) lucid; urgency=low

  * debian/patches/52_button_layout_from_theme.patch:
    - fix crash at startup when the button layout isn't the selected
      theme one (LP: #552132)
 -- Didier Roche <email address hidden> Wed, 31 Mar 2010 10:12:48 +0200

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Didier Roche (didrocks) wrote :

Can you please when you change the status give some feedback? Did you install 1:2.30.0-0ubuntu3 and check it works?

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Mark K (mark-kempster) wrote :

Ran into this bug, updated packages, and can now launch Appearance Preferences.
Thanks for the quick fix!

Revision history for this message
Alaric (jroose) wrote : Re: [Bug 552132] Re: gnome-appearance-properties crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()

Confirmed. Fix is in the repositories. Thanks for your quick work guys :)

On Wed, Mar 31, 2010 at 6:17 AM, Mark <email address hidden> wrote:

> Ran into this bug, updated packages, and can now launch Appearance
> Preferences.
> Thanks for the quick fix!
>
> --
> gnome-appearance-properties crashed with SIGSEGV in
> g_cclosure_marshal_VOID__VOID()
> https://bugs.launchpad.net/bugs/552132
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Micah Gersten (micahg)
tags: removed: need-i386-retrace
Revision history for this message
A.K.Karthikeyan (mindaslab) wrote :

Having this problem now in Ubuntu 14.10

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers