WinKey <SUPER_L> should be mapped to Applications menu

Bug #54024 reported by Duncan Lithgow on 2006-07-25
150
This bug affects 20 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
gnome-control-center
Won't Fix
Low
gnome-control-center (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Intrepid by Bryce Harrington

Bug Description

Binary package hint: xkeyboard-config

Please reassign package if it's wrong

The current default is that the WIN key is not mapped to anything, that makes it an ideal candidate for doing something helpful _and_ helping those migrating from windows (The WIN key in windows open the start menu, used for opening applications).

So, let's map it to the Applications menu (currently mapped to <ALT+F1>)

Onkar Shinde (onkarshinde) wrote :

It will really be helpful for users migrating from Windows.

At the same time existing users should also be able to use Alt+F1.
I am not sure if it is possible to assign two kwyboard shortcuts for one action.

Onkar Shinde (onkarshinde) wrote :

Please make it as wishlist.

Changed in xkeyboard-config:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Changed in xkeyboard-config:
importance: Untriaged → Wishlist
Phantom (lord-phantom) wrote :

I'm against that idea. Button without default action is a good button to assign somewhere. It doesn't conflict with anything (ex: compiz functions).

Duncan Lithgow (duncan-lithgow) wrote :

Wow this is old. I'd forgotten I'd posted this...

@Phanton: You're right, but anyone who wants to use it must know how to change keyboard shortcuts - so the fact that it's already assigned to something won't be a problem for them. So it's a plus for switchers from windows without being a minus for current users. Please correct me if I'm wrong.

I agree with Duncan (and this bug/wishlist item).

It would be really useful to have Windows buttons assigned to the menu. It seems to be a common annoyance that it isn't.

Surely the user could always map it to something else Phantom? I can't see how a default mapping would be worse for the user. The minority that doesn't like the Windows key mapped to menu (gamers with big fingers, e.g. ;)) could always go unmap it in the key bindings dialog (unlike Windows where it is a mess to do).

JP Vossen (jp-jpsdomain) wrote :

Agree.

Changed in xkeyboard-config:
assignee: desktop-bugs → nobody
Bryce Harrington (bryce) wrote :

SUPER_L is mappable already, but the choices of what to map it to (Applications menu or whatever) is rather a GNOME thing. Reassigning to gnome-control-center.

Sebastien Bacher (seb128) wrote :

upstream stated on http://bugzilla.gnome.org/show_bug.cgi?id=325736 that they will not change it by default since the key is used for other things too and it's easy enough to configure if you really want to use it this way

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Invalid
Changed in gnome-control-center:
status: Unknown → Won't Fix

Isn't this supposed to be for fixing annoyances. Yes it's relatively easy to reconfigure this, in fact it's one of the first things I change after an install. The fact remains that the "expected behaviour" for the vast majority of new users is that that key open the main menu. I don't care that it's been co-opted for some other purpose; it should not have been!

Travis Watkins (amaranth) wrote :

Making this change would break more than it would 'fix' as you either have to choose to use the Super key to open the applications menu or choose it to be a modifier for a large number of other actions. Currently the code does not support both and it would not be a trivial change to fix this so this bug does not quality as a paper cut.

Changed in hundredpapercuts:
status: New → Invalid
Changed in hundredpapercuts:
status: Invalid → Confirmed
Stefan Nuxoll (snuxoll) wrote :

First, this isn't a bug. Second, the SUPER key not being mapped to anything allows it to be used as a modifier key without worring if something else is already using it. Linux is not Windows, as well, and I don't see any benefit to changing this.

Changed in hundredpapercuts:
status: Confirmed → Invalid
tags: added: feature-request
tags: removed: feature-request
Lightbreeze (nedhoy-gmail) wrote :

Reopening this bug as a 'paper cut' because a duplicate was marked Confirmed.
Please take the time to read the comments in Bug #161960 before taking any more action with the status of this 'paper cut'.

Changed in hundredpapercuts:
status: Invalid → New
Paul Hoell (hoellp) wrote :

You'd really rather use the key as a single key then a modifier? I don't get that... Please leave it be and map the menu to somthing like Super+x.

mati (mati-wroc) wrote :

Paul, please read comments in bug 161960, the key would still function properly as a modifier (and used for the menu only when released alone). It's a severe thing, as many many of Ubuntu users come from the platform where Super_L is used that way, and Alt-F1 is really not easily discoverable.

The Fiddler (stapostol) wrote :

Right now, is there a way to map Super_L to open the application menu *and* be usable in two-key shortcuts (e.g. Super_L+D to minimize windows), *without* modifying source code?

If so, it would make sense to make this default in Ubuntu.

Travis Watkins (amaranth) wrote :

It isn't possible, no.

Sam Stenvall (negge) wrote :

Currently I have it set up so that when I press the Super key, all windows are minimized. This is ONLY because it is not possible to create a keyboard shortcut like Super+D (which would be the Windows equivalent to minimizing all windows and focusing on the desktop). Thus, I think this is just a wishlist item and not a real papercut bug.

What I, and probably many others too, would like is the ability to create keyboard shortcuts that use the Super key as a combo key (like Super+D to minimize all windows, Super+L to lock the screen etc.). Why couldn't we just make all the standard Windows shortcuts the same on Ubuntu?

I don't know about you guys, but after using Windows for many many years you grow used to hitting Windows+D to minimize your open windows, and when that same command doesn't work in Ubuntu, you get frustrated. On top of that, the fact that you CANNOT mimic the same behaviour is even more frustrating.

[/rant]

On Thu, 2009-06-25 at 21:27 +0000, Sam Stenvall wrote:
> Currently I have it set up so that when I press the Super key, all
> windows are minimized. This is ONLY because it is not possible to create
> a keyboard shortcut like Super+D (which would be the Windows equivalent
> to minimizing all windows and focusing on the desktop).

You can do this by mapping Super_L to Meta in your keyboard layout
options. This is the very first thing I do when I install any Linux
distro.

Personally, I think this is the right thing to do. It won't break the *default* behavior, and if anyone has mapped it to anything else, it should remain that way.
I'm cautious to confirm it though, since upstream has marked it as invalid/won't fix.

Adrian (adrianhesketh-yahoo) wrote :

I'd agree that this should be changed. I use Windows every day at work and when I get home and start using Ubuntu find myself pressing:

Windows R - to run an application (which ends up zooming in the screen for some reason)
Windows D - to minimise windows
Windows L - to lock applications
Windows - Ideally to open the applications menu

I'd really like for this to be possible in Ubuntu.

Samuel Coleman (sjcoleman) wrote :

Also extremely useful would be Super+E, which, on Windows, opens Windows Explorer to My Documents under XP and the user's C:\Users directory under Vista (IIRC; don't quote me on that). Presumably, the appropriate action under Gnome/Linux would be to open to the user's home directory.

Here's another idea: Super be mapped to the Applications menu, and the other expected shortcuts (Super+R, Super+D, etc.) be mapped to Ctrl+Alt+R, Ctrl+Alt+D, etc. Might that fit better, seeing as it's already been done for a few things? (Ctrl+Alt+L for lock comes to mind.)

   --- Samuel

Elliot Hughes (elliot-hughes) wrote :

I feel that a change like this is one that is likely to aggravate as many people as the existing problem does.As has been shown by the numerous ubuntu users on this bug and its duplicate, whilst new users do expect the windows key to pop-up a start menu many of our existing users would find it irritating. Just saying that users are capable of removing the change isn't an effective argument against their disagreement. The key is already used in compiz for many shortcuts and is also remapped by many users to a variety of tasks, for people who use it in this way making it do something else is sort of a papercut in itself.

The applications menu is by default pretty prominently placed at the top of the screen. There are few distractions from it after a clean install, it has a colourful image next to it and says 'Applications' next to it - I think this is clue enough that this is the 'Start Menu' equivalent. So arguments saying that this would help new users work out what to do given the live cd or a clean install is nonsensical.

Many people have posted on the other bug that the Super_L key is labelled start a lot of the time. I would like to say that as a UK user it does not say 'Start' on many keyboards over here and in fact has a large Windows flag on it.

So the issue boils down to whether the Super_L key is a more effective shortcut key for the menu. Hitting the Super_L key requires the user to move their whole hand down the keyboard to touch type it whereas Alt-F1 simply involves moving the thumb and raising the fourth finger - so in my opinion the existing combo is more convenient - but I'm not a useability expert, either way I don't think the difference is that great. The argument for 'one key is better than two' is not all that convincing and we don't use the F4 key to terminate an application and many common keyboard symbols are implemented as key-combos. Users are very used to this way of working.

A compromise could be a mention of the existing key combo after the initial install or upon a LiveCD boot - another option would be to take advantage of the new notify-osd onscreen messages. Having a tap of the windows key display a one time message on the screen for a short period of time informing the user of the Alt-F1 alternative would not disturb existing users but would effectively inform new users.

This suggestion goes well beyond a papercut, but here goes anyway.

Pass this to the team handling the Migration tool that runs during the install process.

As it stands the migration tool imports users bookmarks, wallpapers, files etc from whatever other OS's it detects.

Why not create a script that runs as part of the migration tool to make minor adjustments to Ubuntu based on the OS that the user is migrating from.

Basically, if Windows is detected, and files are imported, then the windows key should be mapped to the Applications menu. Firefox's address bar should be set to select the entire contents etc. There are many more examples....

The same goes for Mac users (I'm just not familiar with the setup)

This would solve a huge amount of stress for new users and remove an awful lot of "but I can do that in Windows" bug reports.

Anyone any thoughts on this?

Samuel Coleman (sjcoleman) wrote :

Honestly, I think autodetection would be a terrible way to do it. It would be confusing for the user if they switched to a new, cleanly-loaded machine and found the behaviour different, and difficult for a technician used to different keyboard shortcuts. It might be better to do like SuSE did (does?) and prompt the user to select a set of keyboard shortcuts on account creation, and then add an option somewhere so it could be changed or checked later. That way, the user can select what basic set of keyboard shortcuts they want (Windows-style, OS X-style, Gnome-style, or KDE-style) from a clearly-labeled dialog, and there'll be less risk of confusion at a later date.

BTW, Elliott, in North America, most keyboards here are labeled with a Windows flag as well, although some newer keyboards, primarily those on laptops, have a Vista-style flag-in-a-circle emblem.

   --- Samuel

Samuel, you are absolutely right, that would be a much more straight forward method.

What about helping people learn the Gnome shortcuts by adding the text
"(ALT+F1)" to the tool tip of the 'Applications' menu? That would
change it from:
* Browse and run installed applications
to
* Browse and run installed applications (ALT+F1)

Elliot Hughes (elliot-hughes) wrote :

That's a good idea and I'm surprised it hasn't been done already actually.

On Fri, Jul 31, 2009 at 5:20 PM, Duncan Lithgow <email address hidden>wrote:

> What about helping people learn the Gnome shortcuts by adding the text
> "(ALT+F1)" to the tool tip of the 'Applications' menu? That would
> change it from:
> * Browse and run installed applications
> to
> * Browse and run installed applications (ALT+F1)
>
> --
> WIN key <SUPER_L> should be mapped to Applications menu
> https://bugs.launchpad.net/bugs/54024
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in gnome-control-center: Won't Fix
> Status in One Hundred Paper Cuts: New
> Status in “gnome-control-center” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: xkeyboard-config
>
> Please reassign package if it's wrong
>
> The current default is that the WIN key is not mapped to anything, that
> makes it an ideal canditate for doing something helpful _and_ helping those
> migrating from windows (The WIN key in windows open the start menu, used for
> opening applications).
>
> So, let's map it to the Applications menu (currently mapped to <ALT+F1>)
>

the string is in the language files of gnome-panel. This does not seem to be a rosetta/launchpad managed translation and the strings get compiled in to the binary. There seem to be translations for 102 languages.
If you get the source of gnome-panel and do grep -r -A 1 "Browse and run" * you will see them all.

Elliot Hughes (elliot-hughes) wrote :

Here's a git diff for UK and US English, its based on the gnome git of gnome-panel. I'd do some more but I really need to write a script to automate adding the key combination. I'm also not sure how key combinations are reperesented in languages that use a different character set such as cryllic. After guidance about this I will hopefully be able to create a full patch.

Fabio Isgrò (dr.gogeta86) wrote :

The super key it can be usefull for gnome terminal to act as copy paste as alternative to the fingertwisting combo ctrl-shift-x and ctrl-shift-c

Antonio Roberts (hellocatfood) wrote :

I think forcing the keyboard to act like a Windows one is a bad idea. With that said I can see why it could annoy people.

Could there be an option for people to set their keyboard to a "Windows keyboard" i.e. an option to remap the keys to Windows' defaults and resolve any conflicts at the press of a button.

I add my vote to the idea to allow the use of the Super key both as a single key (to open the application menu) AND as modifier (Super+D to minimize all application, Super+R for Run dialog windows, etc.).

Still Antonio Roberts and others are right about users with different need than the Windows behavior; so it will be better to set it as a possible keyboard profile configurable in the control panel (... wasn't already so in older Kubuntu releases with KDE 3.X?).

Umang Varma (umang) wrote :

Earlier, when I wanted to change my shortcuts and started by pressing Super_L (and was going to press E for open home folder), it said Super_L and didn't allow a Super_L + ... I had to change some settings (make Super a meta key I think) to get it to work.

I recently did a fresh install of Karmic (without using my old /home also) and it now allows me to do Super_L + E without any other configuration. So I presume half the problem here has been fixed.

Vish (vish) wrote :

Interestingly , with gnome 3 , the "Win" key does now infact open the applications menu, by default.
Now is it still forbidden in gnome 2... ;)

We might not expect a change upstream with gnome 3 in the horizon.

But , since Lucid is LTS , [considering that gnome 3 will be using the win key too] , Ubuntu 10.04 will be the odd one out for a very long time.
Should we change it in Ubuntu ?

@Sebastien Bacher: Can we re-open the gnome-control-center task?

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged

What do you mean by gnome 3? GNOME 2.29? Has upstream really changed this? I find that hard to believe. We should absolutely not change that behaviour, and particularly not now.

I don't understand the desire for a "Windows Mode" in Ubuntu.

Omer Akram (om26er) wrote :

@Jo-Erlend Schinstad gnome 2.32 will be gnome 3

LightVision (reikimarius) wrote :

I've been using windows for 8 years and linux for about 3 yers and the first and most anoyng thing to do after a linux fresh install is to change winkey to show Applications Menu.
Those who don't like the win logo should erase from the keyboard (as I've done)

Changed in gnome-control-center:
importance: Unknown → Low
summary: - WIN key <SUPER_L> should be mapped to Applications menu
+ WinKey <SUPER_L> should be mapped to Applications menu
description: updated

Thank you for bringing that typo to my attention.

Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

 - Unity has no applications menu.. and there are different shortcuts being assigned in the dash launcher for that.. ;-)
Not a papercut any more, as Unity will be the default in Ubuntu 11.04
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Changed in hundredpapercuts:
status: Triaged → Invalid
Paul Sladen (sladen) wrote :

Vish: we will still be shipping GNOME 2.x panel in Ubuntu 11.04. So having the Super key "just work" is still an issue IMHO, and a comparatively easy one to fix too.

Vish (vish) wrote :

Paul, Yeah, I do realize we will have the classic GNOME 2.x desktop option as well, but i have tried pushing this issue and I have little hopes of being able to push for this change and not face a backlash.
If you feel you can champion this change, pls re-open the bug. [you do have upload rights.. ;-) ]

Owais Lone (loneowais) wrote :

Whoever implements this (IF), please bind the trigger to super key release instead of press. that way other apps (Do/Synapse) can still bind to it unlike Gnome-Shell.

Paul Sladen (sladen) wrote :

Right, people, line up your patches and form an orderly queue. Do the fighting between trigger/release and figure out what the consensus is going to be and then when you have the solution I'll try and force this through; this appears to be 4.5 years old (9 releases!) and about time we fixed it going forward.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.