no gui options to switch title bar buttons back to right side

Bug #535322 reported by enb
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Baltix
New
Undecided
Unassigned
gnome-control-center (Ubuntu)
Invalid
Wishlist
Unassigned

Bug Description

There is no visible option in system>preferances>appearance that will move the close, max and min buttons back to the right. Furthermore, all of the theme preview pictures still show those buttons on the right, and clicking those does not switch the buttons back, so those pictures are incorrect. The buttons should stay on the right, and only be switchable if the user wants them to.

tags: added: kernel-series-unknown
tags: removed: kernel-series-unknown
Revision history for this message
Gabe Gorelick (gabegorelick) wrote :

I believe that they've finally decided to keep the window control buttons on the right for the new themes in Lucid, so that solves your basic problem. But the more general problem of not being able to control the location of the window controls still exists. gnome-appearance-properties does give you the option to change the window border to another given variety, but does not allow you to edit existing window borders, which would be a nice feature.

affects: ubuntu → gnome-control-center (Ubuntu)
Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your bug report, it's not likely to be an option added for lucid but things will be changed to have the settings apply only to the light themes

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

If Ubuntu developers change some important default interface aspect then they must provide an ability to users to restore interface behavior as in previous versions.
If Ubuntu developers doesn't have time to provide an ability to users to restore interface behavior as in previous versions, then they should leave the interface as in previous versions.

Now I'm attaching simple, but user-friendly tool to change window management buttons position (left, right, custom). This tool simply changes the value of "/apps/metacity/general/button_layout" gconf setting (I changed this to "menu:maximize,minimize,spacer,close" - I like space between maximize and close buttons :)

Revision history for this message
Colin D Bennett (colinb) wrote :

@Mantas Kriaučiūnas:
Thank you for the tool! I will probably modify it for my own use and my friends and family's use in Lucid. (I will make the close button always be in the corner.)

Dear Ubuntu: you really should include something like this in the Lucid Lynx release! However, I would be a little happier if you would at least put the Close button in the corner.

The close button is the most important of the three window bar buttons (minimize, maximize, and close).

When the buttons are one the left, I very strongly feel that the Close button should be on the left, closest to the corner. It should not be the third button from the edge, since it is the most important button and being in the corner makes it easier and quicker to click on.

If you disagree that it's the most important button, consider this: You can always resize the window by grabbing the edges to make it big enough or even fill the screen instead of maximizing it, or you can move it out of the way to access other windows instead of minimizing it. Also, you may not minimize or maximize every window you open, but you will eventually have to close each window; although some windows may be closed in other ways, often it is very inconvenient to choose File | Close such as you would have to do for a Nautilus folder window.

Revision history for this message
Gabe Gorelick (gabegorelick) wrote :

It looks like the buttons are going to remain on the left for the time being [1]. Bug #532633 has a lot more information on the topic.

As a side note, let's not be too hasty with Ubuntu for their design decision. As Sebastien stated above, this will be fixed by the time Lucid is released so that other themes besides the light ones will have the old behavior. And if you can't wait, I think bug #532633 may discuss some gconf hacks to revert back to the old behavior.

[1] http://www.omgubuntu.co.uk/2010/03/mark-shuttleworth-explains-why-window.html

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.29.92-0ubuntu3

---------------
gnome-control-center (1:2.29.92-0ubuntu3) lucid; urgency=low

  * debian/patches/52_button_layout_from_theme.patch:
    - Enable themes to provide a prefered button layout option:
      X-GNOME-Metatheme/ButtonLayout. (LP: #535322, #548833)
 -- Didier Roche <email address hidden> Fri, 26 Mar 2010 15:58:44 +0100

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Revision history for this message
enb (elitenoobboy) wrote :

Exactly where do you change the title bar buttons back in the fixed control center?

Revision history for this message
A. Richard Miller (themillers) wrote :

Our thoughts:
1. We find this irksome (inconsistent with most other computers, illogical and demanding of extra attention, particularly on netbooks). We want to encourage converts to GNU/Linux (our clients and more), not discourage them.
2. Keep the Close button at extreme upper right, like the Delete key on a well-designed keyboard.
3. Do not experiment with the DEFAULT layout. Certainly, not in a LTS release.
4. Thanks for all your good work. We want it to succeed!

Revision history for this message
Gabe Gorelick (gabegorelick) wrote :

This bug is not about whether the new window buttons are good or bad. This bug is about how there is no gui option to switch the buttons back to the right side. It is therefore beyond this bug's scope to talk about whether the window button positioning should be kept. Appropriate comments regarding the new window buttons are welcome at bug #532633. Thank you.

Revision history for this message
enb (elitenoobboy) wrote :

I've looked through the gnome control center "appearance" options and can't find any way to change these things back. The way to change these back is either hidden, or not where it should be, ie somewhere in look and feel or appearance theming. It should be located in a logical place where someone can at least find it, therefore this bug still exists for me.

Changed in gnome-control-center (Ubuntu):
status: Fix Released → Incomplete
Revision history for this message
Jacopo Moronato (jmoronat) wrote :

I'm not sure about that: is this option meant to be showed only on upgrades from previous Ubuntu releases ?

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Dmitry Andreychuk (and-dmitry) wrote :

Option "revert button layout" is only showed when gconf key "/apps/metacity/general/button_layout" is unset or it's value differs from the button layouts of both new (selected) and previous themes. So this happens if you have a custom value for this key or on upgrade.

Revision history for this message
Sebastien Bacher (seb128) wrote :

that's not a bug but not a common option and will not be added to the standard configuration dialog, you can install tools from universe to do that

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers