gnome-appearance-properties crashed with SIGSEGV in main()

Bug #516189 reported by tgpraveen
118
This bug affects 23 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Fix Released
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

help

ProblemType: Crash
Architecture: i386
Date: Tue Feb 2 23:58:01 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gnome-appearance-properties
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
NonfreeKernelModules: nvidia
Package: gnome-control-center 1:2.29.6-0ubuntu2
ProcAttrCurrent: unconfined (enforce)
ProcCmdline: gnome-appearance-properties
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.16-generic
SegvAnalysis:
 Segfault happened at: 0x805cdec <main+988>: repz cmpsb %es:(%edi),%ds:(%esi)
 PC (0x0805cdec) ok
 source "%es:(%edi)" (0x080745c8) ok
 destination "%ds:(%esi)" (0x0000007b) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-control-center
Stacktrace:
 #0 0x0805cdec in main ()
 No symbol table info available.
StacktraceTop: main ()
ThreadStacktrace:
 .
 Thread 1 (Thread 2065):
 #0 0x0805cdec in main ()
 No symbol table info available.
Title: gnome-appearance-properties crashed with SIGSEGV in main()
Uname: Linux 2.6.32-12-generic i686
UserGroups: root

Revision history for this message
tgpraveen (tgpraveen89) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop: main (argc=1, argv=0xbfc6deb4) at appearance-main.c:233

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
Revision history for this message
tgpraveen (tgpraveen89) wrote :

I was having a lot of problems with my graphics system.
And i was getting this error.
the problem (or one of the problems) was that compiz was not starting up.
so i added compiz --replace in list of startup applications and now everything works well.
So the bug probably exists, but i cant reproduce anymore.
My system was upgraded from Karmic and i have NVidia card. maybe that was the source of problems.

Revision history for this message
Guy Stacey (gystcy) wrote :

Have been curing at reboot with
metacity --replace.
I don't have nvidia card, mine is:
VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Tried changing theme and visial effects settings to no avail. Fine prior to 9.10 to 10.04 alpha2 upgrade.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

I've just fixed this in bzr

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Fix Committed
Torgeir (torgeir-bryoen)
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.29.91-0ubuntu1

---------------
gnome-control-center (1:2.29.91-0ubuntu1) lucid; urgency=low

  * New upstream version
    - Appearance:
      + Add 'span' as a style for backgrounds
    - Display Properties:
      + Now fits in 640x480 and has a better layout overall
      + Just use "monitors" for wording, not a mixture of "monitor",
        "display", "screen"
      + Make the mouse cursor indicate when you can drag a monitor
  * debian/control:
    - Bump libgnome-desktop-dev build-dep to 2.29.4
    - Drop libxrandr-dev and libxrender-dev build-deps
  * Refreshed patches:
    - 109_screen_resolution_extra.patch
    - 111_screen_resolution_vendor_fallback.patch
    - 99_autoreconf.patch
  * Dropped 92_display_properties_fit_small_screen.patch: this is not
    required with the new capplet layout
  * debian/patches/95_desktop-effects-integration.patch:
    - Don't crash when there is no supported WM available (LP: #516189)
 -- Chris Coulson <email address hidden> Mon, 01 Mar 2010 08:29:48 +0000

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers