proxy settings should be transitive

Bug #390381 reported by Imre Péntek on 2009-06-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

clich through rendszer->beállítások->hálózati proxy (system->settings->proxy) use manual proxy settings and provide your proxy (four this test a not-existing proxy will also make it) use the same proxy for all protocols (optional)
then close this dialog; reboot (its optional I hope) then open a terminal and issue:
echo $http_proxy

you will get an empty result. so this way, the proxy settings doesn't got reincarnated to the http_proxy environmental variable (which would be used by e.g. wget, etc)
---
Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419)
Package: gnome-control-center 1:2.30.1-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=hu_HU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-24.39-generic-pae 2.6.32.15+drm33.5
Tags: lucid
Uname: Linux 2.6.32-24-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Hello Imre Péntek

This issue is not reproducible by me in a fully updated Lucid .
Can you please confirm that ?
Thanks in advance.
:)Fabio

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in gnome-system-tools.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → gnome-system-tools (Ubuntu)
Milan Bouchet-Valat (nalimilan) wrote :

Package is gnome-control-center.

Why do you say "transitive" in the title? To me, proxy settings simply don't work on your system, it's as simple as that.

affects: gnome-system-tools (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
Imre Péntek (pentek-imre) wrote :

By transitive I mean proxy setting doesn't find its way to http_proxy environmental variable. And I can reproduce this bug on an almost up-to-date lucid system. I'll update and check again

Imre Péntek (pentek-imre) wrote :

Same for completely up-to-date system. bug is still present.

Fabio Marconi (fabiomarconi) wrote :

Hello Imre Péntek

I've tried to reproduce the bug, but everythings work ok, so it can depend on your gnome-control-center .

Have you tried to uninstall and reinstall it?

if not, the procedure is not like a simple installation.

You have to logout, change to a tty, be carfull on dropping your network connection though pinging something like google, sudo apt-get remove --purge gnome-control-center, sudo apt-get install gnome-power-center, sudo reboot.

Let us know.

:)Fabio

Imre Péntek (pentek-imre) wrote :

uninstall and reinstall??? hell,it's not Windows! but to answer your question: I'll try a clean install on a virtual machine tomorrow.

Imre Péntek (pentek-imre) wrote :

Hello, on a clean install in my virtualbox it worksforme, however on my phisical machine it doesn't work, even after the reinstall as you wrote it. Maybe there is something with my config files in /home/imi, but anyways if so I do consider this a bug as I haven't edited those configs by hand.

Fabio Marconi (fabiomarconi) wrote :

Hello Imre Péntek

Can you please run in a terminal this command:

apport-collect -p gnome-control-center 390381

Thanks

tags: added: lucid

apport information

tags: added: apport-collected
description: updated
Fabio Marconi (fabiomarconi) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers