Activity log for bug #36812

Date Who What changed Old value New value Message
2006-03-27 06:34:14 Sergey Sinitsa bug added bug
2006-03-28 15:20:14 Olafur Arason None: statusexplanation
2006-12-22 20:15:06 Daniel Holbach control-center: status Unconfirmed Confirmed
2006-12-22 20:15:06 Daniel Holbach control-center: importance Medium Low
2006-12-22 20:15:06 Daniel Holbach control-center: statusexplanation Thanks for the bug report. Somebody of the team could forward this upstream.
2006-12-22 20:15:06 Daniel Holbach control-center: assignee desktop-bugs
2006-12-22 20:15:15 Daniel Holbach bug assigned to control-center (upstream)
2007-04-17 12:30:18 Sebastien Bacher control-center: status Unconfirmed Unknown
2007-04-17 13:13:19 Sebastien Bacher control-center: status Confirmed Rejected
2007-04-17 13:13:19 Sebastien Bacher control-center: statusexplanation Thanks for the bug report. Somebody of the team could forward this upstream. closing the Ubuntu task then
2007-04-18 06:56:12 Bug Watch Updater control-center: status Unknown Rejected
2007-04-18 07:54:38 Daniel Holbach bug assigned to xorg-server (upstream)
2007-04-19 06:55:29 Bug Watch Updater xorg-server: status Unknown In Progress
2010-02-08 00:08:39 Nick Andrik attachment added "switch on release" patch http://launchpadlibrarian.net/38870942/switch_on_release.diff
2010-02-08 00:09:18 Nick Andrik tags patch
2010-07-26 16:46:42 Alexander Pavlov bug added subscriber Alexander Pavlov
2010-08-21 18:56:56 Alexey Kozlov bug added subscriber Alexey Kozlov
2010-08-21 22:29:18 Nick Andrik bug added subscriber Ubuntu-X
2010-09-08 04:49:14 Evgeny Kolesnikov bug added subscriber Evgeny Kolesnikov
2010-09-10 12:58:11 Bug Watch Updater xorg-server: importance Unknown Medium
2010-09-10 12:58:17 Bug Watch Updater bug watch added http://bugs.kde.org/show_bug.cgi?id=59303
2010-09-14 19:09:25 Vadim Dmitriev bug added subscriber Vadim Dmitriev
2010-09-16 03:17:56 Bug Watch Updater gnome-control-center: status Invalid Unknown
2010-09-16 03:17:56 Bug Watch Updater gnome-control-center: importance Unknown Medium
2010-09-16 07:41:53 Nick Andrik bug task added hundredpapercuts
2010-10-12 08:11:58 Konstantinos Togias bug added subscriber Konstantinos Togias
2010-10-21 00:51:31 RussianNeuroMancer nominated for series hundredpapercuts/maverick
2010-10-24 16:32:01 ksn135 nominated for series xorg-server/trunk
2010-10-28 16:55:47 ksn135 bug added subscriber ksn135
2010-11-02 22:34:50 aeol bug added subscriber aeol
2010-11-20 18:34:39 tal bug added subscriber tal
2010-11-22 12:28:51 Oren Held bug added subscriber Oren Held
2010-11-22 12:38:34 Yoni Tsafir bug added subscriber Yoni Tsafir
2010-11-27 20:38:13 Sense Egbert Hofstede bug task added xorg (Ubuntu)
2010-11-27 20:42:37 Sense Egbert Hofstede affects hundredpapercuts null
2010-11-27 20:42:37 Sense Egbert Hofstede null: status New Invalid
2010-11-27 21:32:18 Nick Andrik description I have Ctrl+Shift set to layout switch and press ctrl+shift+N (to open new Terminal or new tab in Opera) -- as a result I have my keyboard layout switched. This happens because Ubuntu (or XOrg?) change layout on key press instead of release and do not match layout hotkeys with application shortcuts. MS Windows do. If layout change hotkeys is pressed with another key this must be treated as application shortcut and layout must not be changed. Combined with shortcut bugs in some Linux applications [Bug 2561] this makes keyboard shortcuts nearly unusable in default bilingual configuration. This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package.
2010-11-27 21:32:49 Nick Andrik description This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package. This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package.
2010-11-27 21:34:12 Nick Andrik description This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package. This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (https://bugs.launchpad.net/ubuntu/+source/control-center/+bug/36812/comments/55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package.
2010-11-27 21:34:30 Nick Andrik description This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (https://bugs.launchpad.net/ubuntu/+source/control-center/+bug/36812/comments/55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package. This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package.
2010-11-27 21:37:07 Nick Andrik description This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch in the upstream xorg, or at minimum to the official ubuntu xorg package. This is a bug about shortcuts mapped to combinations which include each other. For example, if we have Ctrl+Shift (for keyboard layout) and Ctrl+Shift+N (to open a new terminal), then we are practically unable to use the second shortcut; this is what happens: Ctrl press (nothing happens) Shift press (keyboard layout change) N (a simple N appears, since a shortcut has already fired) The expected behavior is to fire shortcuts on the release (not on press) of the special keys (ctrl,shift,alt, etc) which is also how Windows behave. This is a serious problem for bilingual layouts, typically using Alt+Shift or Ctrl+Shift for keyboard layout change. For users being affected by this problem, the easiest solution for now is to add this PPA in your repositories: https://launchpad.net/~oded-geek/+archive/xorg-patches Practical summary of this bug for ubuntu developers (since reading 120 comments is impractical for most): This problem is a really old (since 2004) issue of the xkb part of xorg; the main discussion was made upstream in freedesktop-bugs #865. There has been a patch from Ilya Murav'jov for upstream (#55), and attached here (#61). Upstream xorg has refused to apply the patch, mainly because it "explicitly contradicts the (xkb) spec" (#84, #91). This patch has been reported to work for many people without any problems, and there is also a PPA by Oded Arbel (#95) where he maintains a patched version of the ubuntu xorg. The proper resolution of this bug would be to apply this patch to the upstream xorg, or at minimum to the official ubuntu xorg package.
2010-11-28 12:01:13 bugbot affects xorg (Ubuntu) xserver-xorg-input-evdev (Ubuntu)
2010-11-29 17:53:30 Brian Murray bug added subscriber Ubuntu Review Team
2010-12-01 06:39:42 Bryce Harrington bug added subscriber Ubuntu Sponsors Team
2010-12-08 11:11:06 Sebastien Bacher control-center (Ubuntu): assignee Ubuntu Desktop Bugs (desktop-bugs)
2010-12-10 13:23:24 Ignat Loskutov xserver-xorg-input-evdev (Ubuntu): status New Confirmed
2011-01-06 22:58:35 Bryce Harrington xserver-xorg-input-evdev (Ubuntu): importance Undecided Wishlist
2011-01-06 22:58:35 Bryce Harrington xserver-xorg-input-evdev (Ubuntu): status Confirmed Fix Committed
2011-01-06 23:33:28 Launchpad Janitor branch linked lp:ubuntu/xorg-server
2011-01-07 09:53:18 Timo Aaltonen affects xserver-xorg-input-evdev (Ubuntu) xorg-server (Ubuntu)
2011-01-07 09:54:36 Timo Aaltonen xorg-server (Ubuntu): status Fix Committed Fix Released
2011-01-08 10:21:25 ArcFi bug added subscriber ArcFi
2011-01-08 22:37:34 Benjamin Drung removed subscriber Ubuntu Sponsors Team
2011-01-27 15:57:35 Bug Watch Updater xorg-server: importance Medium Unknown
2011-02-02 12:34:58 Oded Arbel bug added subscriber Chris Halse Rogers
2011-02-09 15:22:29 Bug Watch Updater xorg-server: importance Unknown Medium
2011-03-13 09:41:04 Constantine bug added subscriber Constantine
2011-04-08 22:58:34 Bug Watch Updater xorg-server: importance Medium Critical
2011-04-20 03:56:13 Alexander bug added subscriber Alexander
2011-09-26 06:52:30 Bug Watch Updater xorg-server: importance Critical High
2011-11-11 21:20:57 Curtis Hovey bug task deleted null
2011-12-26 14:21:20 Bug Watch Updater bug watch added https://bugzilla.redhat.com/show_bug.cgi?id=660254
2011-12-26 14:21:20 Bug Watch Updater bug watch added http://bugs.gentoo.org/show_bug.cgi?id=379827
2011-12-26 14:21:20 Bug Watch Updater bug watch added http://bugs.gentoo.org/show_bug.cgi?id=304375
2012-03-09 16:46:28 Alexander removed subscriber Alexander
2013-12-31 07:36:53 Amir Eldor bug added subscriber Amir Eldor
2014-02-03 15:37:25 RussianNeuroMancer removed subscriber RussianNeuroMancer
2014-05-19 17:39:11 Yuriy Yunikov bug added subscriber Yuriy Yunikov
2014-11-02 20:25:52 MV bug added subscriber MV
2015-01-03 00:12:27 Mathew Hodson affects control-center (Ubuntu) gnome-control-center (Ubuntu)
2015-01-03 08:19:25 Yuriy Yunikov removed subscriber Yuriy Yunikov
2016-03-29 15:10:29 Roman Vorobets removed subscriber Roman Vorobets
2016-03-29 20:22:07 Oded Arbel bug watch added https://bugzilla.redhat.com/show_bug.cgi?id=1091631
2017-04-27 13:19:39 kolya bug added subscriber kolya
2017-08-10 08:22:18 Ori Avtalion bug added subscriber Ori Avtalion
2017-10-14 02:03:03 Bug Watch Updater xorg-server: status In Progress Won't Fix
2017-10-14 07:32:14 Bug Watch Updater xorg-server: status Won't Fix Confirmed
2017-11-09 21:09:29 LSK bug added subscriber LSK
2018-04-04 09:53:51 Alexey Barabanov bug added subscriber Alexey Barabanov
2018-04-07 17:55:59 Norbert tags patch artful bionic patch trusty xenial
2018-05-27 13:02:37 Eugene Pakhomov bug added subscriber Eugene Pakhomov
2018-06-08 12:29:00 Bug Watch Updater bug watch added https://bugzilla.gnome.org/show_bug.cgi?id=786257
2018-06-08 12:29:00 Bug Watch Updater bug watch added https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891915
2018-06-08 14:33:41 Eugene Pakhomov removed subscriber Eugene Pakhomov
2018-06-08 14:33:45 Eugene Pakhomov bug added subscriber Eugene Pakhomov
2018-07-31 20:55:08 Norbert bug added subscriber Norbert
2018-12-11 21:41:17 Samuel Lidén Borell removed subscriber Samuel Lidén Borell
2018-12-13 19:53:40 Bug Watch Updater xorg-server: status Confirmed Unknown
2019-03-29 01:43:24 Dan Streetman bug added subscriber Dan Streetman
2019-04-21 19:02:29 Norbert tags artful bionic patch trusty xenial bionic cosmic disco eoan patch trusty xenial
2019-04-28 15:40:56 Oren Held removed subscriber Oren Held
2019-04-30 15:43:04 Alexander Ponyatykh bug added subscriber Alexander Ponyatykh
2019-06-03 04:46:55 Gunnar Hjalmarsson xorg-server (Ubuntu): status Fix Released Confirmed
2019-06-11 09:08:23 Dan Streetman removed subscriber Dan Streetman
2019-06-18 11:51:49 Bug Watch Updater xorg-server: status Unknown Fix Released
2019-06-18 12:32:43 Gunnar Hjalmarsson bug watch added https://gitlab.freedesktop.org/xorg/xserver/issues/258
2019-06-18 12:32:43 Gunnar Hjalmarsson xorg-server: importance High Unknown
2019-06-18 12:32:43 Gunnar Hjalmarsson xorg-server: status Fix Released Unknown
2019-06-18 12:32:43 Gunnar Hjalmarsson xorg-server: remote watch freedesktop.org Bugzilla #865 gitlab.freedesktop.org/xorg/xserver/issues #258
2019-06-18 14:08:53 Bug Watch Updater xorg-server: status Unknown New
2019-07-22 04:22:05 Daniel van Vugt tags bionic cosmic disco eoan patch trusty xenial bionic disco eoan patch trusty xenial