gnome-sound-properties no default mixer track selected

Bug #366630 reported by Nicolò Chieffo on 2009-04-25
2
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

In my laptop, from the Jaunty live cd, when I open gnome-sound-properties the default mixer tracks option is misconfigured:
"Device" is set to "Capture: HDA intel - stac92xx analog (PulseAudio..."
and in the list nothing is selected.

I think that the default option should be "Playback: HDA intel - stac92xx analog (PulseAudio..." with "Master" selected

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: gnome-control-center 1:2.26.0-0ubuntu3
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
Uname: Linux 2.6.30-020630rc3-generic i686

Nicolò Chieffo (yelo3) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you take a screenshot showing the issue? Do you mean that volume control key and the applet don't work out of the box?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

Yes, here's the screenshot (I also added the corresponding gconf keys
so you can see better)

Instead of "Capture" "Playback" should be selected, and also "Master"
should be selected

the volume keys work, but they change the ALSA MASTER mixer, instead
of the PULSEAUDIO MASTER mixer.
In my card these 2 mixers behave completely different: if you like,
see bug https://bugs.launchpad.net/bugs/366603

Sebastien Bacher (seb128) wrote :

using alsa by default is a choice since pulseaudio is not working great for everybody yet

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Invalid
Nicolò Chieffo (yelo3) wrote :

If so, why alsa master is not selected? this is clearly a bug. It's a coincidence that it works as expected

Changed in gnome-control-center (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

oh, your issue is the minor graphical bug that the only line available is not displayed color, ok let's call that a bug

Nicolò Chieffo (yelo3) wrote :

No, my issue is that the default mixer is the pulseaudio _capture_
device, instead of the alsa mixer.

It selects the alsa mixer only because "Master" is not selected.
If for an error you click on "Master" without changing to "alsa" or
"playback" the volume keys won't work.

Sebastien Bacher (seb128) wrote :

ok, to confirm and debug by somebody having a clue about the channel selection in alsa or pulseaudio that's probably due to those rather than the GNOME interface

Nicolò Chieffo (yelo3) wrote :

Ok, but where does gnome find the default values
gnome-sound-properties or gnome-settings-daemon? It can be that it
does not detect the audio options in a correct way

Sebastien Bacher (seb128) wrote :

the code is in gnome-sound-properties but it probably only uses gstreamer or alsa for that

Sebastien Bacher (seb128) wrote :

Could you try if that's still an issue in karmic?

Nicolò Chieffo (yelo3) wrote :

I don't know, there's no more this GUI in karmic

Sebastien Bacher (seb128) wrote :

let's close the bug then since it doesn't apply to current version

Changed in gnome-control-center (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers