Almost all the Actions in the "Keyboard Shortcuts" dialog shows untranslated

Bug #359247 reported by Ricardo Pérez López on 2009-04-10
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
gconf
Unknown
Medium
gnome-control-center
Fix Released
Medium
Guadalinex
High
Juanje Ojeda
Guadalinex Edu
Undecided
Unassigned
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-settings-daemon

[Using Jaunty, fully updated]

Almost all the Actions in the "Keyboard Shortcuts" dialog (System->Preferences->Keyboard Shortcuts) shows untranslated in my Spanish desktop, albeit they're fully translated in the Launchpad template:

  https://translations.launchpad.net/ubuntu/jaunty/+source/gnome-settings-daemon/+pots/gnome-settings-daemon/es/+translate

and the translations are inside the gnome-settings-daemon.mo file. For example, the "Launch calculator" string is translated into Spanish since 2008-02-20:

  https://translations.launchpad.net/ubuntu/jaunty/+source/gnome-settings-daemon/+pots/gnome-settings-daemon/es/23/+translate

and the translation is in the .mo file:

  $ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/gnome-settings-daemon.mo | grep "Lanzar la calculadora"
  Lanzar la calculadora

However, that string, as well as nearly all the Action names, shows untranslated.

I attach an screenshot to illustrate the problem.

Ricardo Pérez López (ricardo) wrote :
description: updated
Ricardo Pérez López (ricardo) wrote :

In the screenshot, there's only one Action name translated: "Iniciar selector de ventanas". This string comes from compiz.mo, and is only displayed when I use compiz instead of metacity.

  $ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/compiz.mo | grep "Iniciar selector de ventanas"
  Iniciar selector de ventanas
  Iniciar selector de ventanas para todas las ventanas

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
affects: gnome-settings-daemon (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: Invalid → Triaged
Changed in gnome-control-center:
status: Unknown → Confirmed
Juanje Ojeda (juanje) wrote :

This bug was detectec also in Guadalinex which is Ubuntu Jaunty with the last jaunty-updates installed. So the bug is still in the Jaunty package version 2.26.0-0ubuntu3. But seems this bug is still in upstream (GNOME 2.27 git branch).

Changed in guadalinex:
assignee: nobody → Juanje Ojeda (juanje)
importance: Undecided → High
milestone: none → final
status: New → Confirmed
tags: added: i18n
tags: added: guadalinex jaunty
Changed in gconf:
status: Unknown → New
Juanje Ojeda (juanje) wrote :

I've just added the project Gconf to the bug because this seems to be a Gconf problem. I've also linked an upstream bug about it.

The problem is not the gnome-settings-daemon doesn't mark for translations the strings, neither the translated strings doesn't show up, the problem is the strings are asked to Gconf and Gconf (now) is giving the untranslated strings.

You can check this by doing this:
$ gconftool --short-docs /apps/gnome_settings_daemon/keybindings/calculator

Even if you force the LANG, you'll get always "Launch calculator", not the translated version. You can try:
$ LANG=es gconftool --short-docs /apps/gnome_settings_daemon/keybindings/calculator
$ LANG=it gconftool --short-docs /apps/gnome_settings_daemon/keybindings/calculator
$ LANG=de gconftool --short-docs /apps/gnome_settings_daemon/keybindings/calculator
...

Also you can see this easuly in the gconf-editor. All the gconf keys' descriptions are untranslated. But in previous versions they were translated. And the translations are still there as Ricardo pointed out before.

So I connected this bug with the upstream gconf bug and I've created a new one ( bug #382274) for the whole Gconf issue (not just the actions stuff).

Sebastien Bacher (seb128) wrote :

the gconf issue is a different one, the capplet issue is that the strings are in a different translation domain than the one used by the capplet

Adi Roiban (adiroiban) wrote :

Is this a Jaunty only problem?

I have tested with Karmic and the strings are translated.

Changed in ubuntu-translations:
status: New → Incomplete
David Planella (dpm) wrote :

I've tested this in Karmic, both in Catalan and Spanish, with the same results:

All shortcut entries appear now translated, except for those under the

* Window management
* Window manager

entries, so it seems it is now fixed on Karmic, although the shortcuts for those entries in the list might come from an application which is not translated or translatable.

As for translations of Gconf keys, they seem to be ok, either on gconf-editor or using the command line (I've tried 'gconftool --short-docs /apps/gnome_settings_daemon/keybindings/calculator' and the message appeared translated)

Martin Pitt (pitti) wrote :

This sounds like a corollary of the gconf schema i18n fixes that we applied late in karmic then. Thanks for testing.

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
David Erosa (erosa) on 2010-05-17
Changed in guadalinexedu:
status: New → Won't Fix
David Planella (dpm) on 2010-08-02
Changed in ubuntu-translations:
status: Incomplete → Fix Released
Changed in gconf:
importance: Unknown → Medium
status: New → Unknown
Changed in gnome-control-center:
importance: Unknown → Medium
Changed in gnome-control-center:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.