Notification window is not translatable

Bug #331818 reported by Gabor Kelemen on 2009-02-19
2
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Sebastien Bacher

Bug Description

Binary package hint: gnome-control-center

I have installed the closed source nvidia driver, but do not use it. Starting the screen resolution panel results an error message, which is not translatable.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, subscribing the patch writter now since it doesn't seem the string is marked as translatable there

Changed in gnome-control-center:
assignee: nobody → superm1
importance: Undecided → Low
status: New → Confirmed
Gabor Kelemen (kelemeng) wrote :

Oh, a quick note: Hungarian LoCo will participate this weekend on the BugJam, and we will teach newbies how to hunt and fix l10n bugs like this. So please do not fix it now, I'd like to use this for educational purposes :).

Does that mean you'll be writing and submitting a patch for it? :)

2009/2/19 Gabor Kelemen <email address hidden>

> Oh, a quick note: Hungarian LoCo will participate this weekend on the
> BugJam, and we will teach newbies how to hunt and fix l10n bugs like
> this. So please do not fix it now, I'd like to use this for educational
> purposes :).
>
> --
> Notification window is not translatable
> https://bugs.launchpad.net/bugs/331818
> You received this bug notification because you are a bug assignee.
>

--
Mario Limonciello
<email address hidden>

Gabor Kelemen (kelemeng) wrote :

Here we go

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.25.90-0ubuntu4

---------------
gnome-control-center (1:2.25.90-0ubuntu4) jaunty; urgency=low

  * Update 111_screen_resolution_vendor_fallback.patch with a
    patch from Gabor Kelemen to make it translatable. (LP: #331818)

 -- Mario Limonciello <email address hidden> Mon, 23 Feb 2009 00:14:57 -0600

Changed in gnome-control-center:
status: Confirmed → Fix Released
Gabor Kelemen (kelemeng) wrote :

Geez guys, what are you doing?

The previous release, 1:2.25.90-0ubuntu4 [1] contains this:
-+ <property name="text">It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?</property>
++ <property name="text" translatable="yes">It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?</property>

which is good, but the new release, 1:2.25.92-0ubuntu1 [2] contains this:

-+ <property name="text" translatable="yes">It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?</property>
++ <property name="text">It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?</property>

The result is obvious:
https://translations.launchpad.net/ubuntu/jaunty/+source/gnome-control-center/+pots/gnome-control-center-2.0/hu/+translate?batch=10&show=all&search=It+appears+that

[1]: http://launchpadlibrarian.net/22995647/gnome-control-center_1%3A2.25.90-0ubuntu3_1%3A2.25.90-0ubuntu4.diff.gz
[2]: http://launchpadlibrarian.net/23415387/gnome-control-center_1%3A2.25.90-0ubuntu4_1%3A2.25.92-0ubuntu1.diff.gz

Changed in gnome-control-center:
status: Fix Released → New
Changed in gnome-control-center:
assignee: superm1 → seb128
Sebastien Bacher (seb128) wrote :

the previous revision was not pushed correctly to bzr and got dropped fixing that now

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.25.92-0ubuntu2

---------------
gnome-control-center (1:2.25.92-0ubuntu2) jaunty; urgency=low

  * Reapply revision which was not correcly pushed to bzr (lp: #331818)

 -- Sebastien Bacher <email address hidden> Fri, 06 Mar 2009 09:55:01 +0100

Changed in gnome-control-center:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers