gnome-mouse-properties does not fit in 1024x600 screen

Bug #324464 reported by Ying-Chun Liu on 2009-02-02
10
Affects Status Importance Assigned to Milestone
gnome-control-center
Expired
Medium
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

Hi,

I've made a patch for gnome-mouse-properties. It will add scrolledbars in some dialogs when the screen height is less than 600.

Please consider including this patch, thanks.

Daniel Holbach (dholbach) wrote :

Can you please forward the patch to GNOME too? https://wiki.ubuntu.com/Bugs/Upstream/GNOME

David Planella (dpm) wrote :

Added link to upstream bug

Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
status: Unknown → Confirmed
Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Sebastien Bacher (seb128) wrote :

changing glade files makes upgrader complicate, would it be possible to do that by code changes rather?

Changed in gnome-control-center:
status: Triaged → Incomplete
Ying-Chun Liu (paulliu) wrote :

Hi Sebastien,

This patch only do code changes.

Changed in gnome-control-center:
status: Incomplete → Triaged
Anmar Oueja (anmar) wrote :

Sebastian/mpt: Guys. Is the scroll bar adequate or you think we should suffle things around like in the about me dialogue? Please let us know.

Sebastien Bacher (seb128) wrote :

the scrollbar will do for jaunty it's late to reshuffle things, I'm busy this week though and will probably not review those changes before next week

Michael Terry (mterry) wrote :

Paul and I discussed a non-scrollbar plan:

1. Split General tab to be horizontally layed out (move Drag & Drop and Double Click sections to right of others).
2. Lay out Accessibility a little differently (2x2 mouse gestures rather than 4x1 and move Dwell Click help text to right)

Ying-Chun Liu (paulliu) wrote :

new glade file

Sebastien Bacher (seb128) wrote :

thank for your work there, the updated version works but displays a double border in the scrollbar displaying case, could you look at fixing those?

Changed in gnome-control-center:
status: Triaged → Incomplete
Sebastien Bacher (seb128) wrote :

I will upload this change since it doesn't break the standard desktop case, would still be nice to fix the bug

Changed in gnome-control-center:
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.25.90-0ubuntu3

---------------
gnome-control-center (1:2.25.90-0ubuntu3) jaunty; urgency=low

  * debian/control.in:
    - recommends iso-codes which is used in the layout selection dialog
      (lp: #289005)
  * debian/patches/90_gnome-mouse-properties_small_screen.patch:
    - change by Ying-Chun Liu to add scrollbar on small screens (lp: #28805)
  * debian/patches/91_gnome-about-me_small_screen.patch:
    - change by Ying-Chun Liu to add scrollbar on small screens (lp: #324464)
  * debian/patches/95_desktop-effects-integration.patch:
    - only call jockey when there was no desktop effects used yet (lp: #285879)
  * debian/patches/96_build_sound_capplet.patch:
    - update by Ying-Chun Liu to add scrollbar on small screens (lp: #28805)
  * debian/patches/109_screen_resolution_extra.patch:
    - change a string to fix a typo (lp: #284630)

 -- Sebastien Bacher <email address hidden> Fri, 20 Feb 2009 16:58:47 +0100

Changed in gnome-control-center:
status: Fix Committed → Fix Released
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
Changed in gnome-control-center:
importance: Unknown → Medium
Changed in gnome-control-center:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.