proxy settings are not applied properly

Bug #296373 reported by Fabus on 2008-11-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Michael Vogt

Bug Description

I've been online for several hours in Uni using a proxy.
I set the proxy up using the Network Proxy control from the preferences menu. Everything works fine.
No that I am back home I cannot use the internet with any program that runs from terminal or uses sudo/gksu (hence running under root).

I used "Apply system-wide..." for 4 times now and even switched the settings and still the following things do not work:
* Synaptic still tries to use the proxy
* The terminal still prints out the proxy with echo $http_proxy (see bugs 48294 and 88380)
* apt-get still tries to use the proxy

What can I do?

Matthieu (gapp-martin) wrote :

Click on "Apply system-wide..." and reboot the whole system - should work then!

That bug is really bothering me! I'm always forgetting to disable the proxy and click on the "Apply system-wide..." Button before I'm going home.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, assigning the bug to mvo who worked on the current proxy code

Changed in gnome-control-center:
assignee: nobody → mvo
importance: Undecided → Low
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The system wide proxy configuration is not very dynanmic. When you reset your proxy (set it to direct connection) and open a new terminal window, does that still show a proxy when you "echo $http_proxy" ?

Changed in gnome-control-center:
status: New → Incomplete
Fabus (fabian-gebert-hh) wrote :

I don't know, it's working fine right now. Have there been any changes to the proxy code?
I will try to reproduce again.

Fabus (fabian-gebert-hh) wrote :

I now found a way to reproduce it: Once you've set up the proxy system-wide and then restarted the system, it does not reset the proxy if you tell him to do so, at least not in a way that makes echo $http_proxy return nothing.
So you do the following:
* set up proxy system wide
* restart
* reset to direct connection
* check proxy, it will still be in $http_proxy (though not in Firefox if set to "use system settings")

frdu0001 (esl-fdumont) wrote :

@Michael Vogt
I apply the system wide proxy configuration (setting it to direct connection) and after closing the dialog I open a new terminal.
echo $http_proxy still saying me the old proxy entry for example http_proxy="192.168.0.1"

As a little "workaround": in terminal you can type --> export http_proxy=""

Sebastien Bacher (seb128) wrote :

is that still an issue in jaunty?

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Nick Sarten (gen-battle) wrote :

Confirming this is still an issue in jaunty.

1. Edited proxy settings.
2. Used "Apply System-Wide" button
3. Synaptic, Add/Remove and Update Manager all still use the previous proxy settings.

Restarting does solve the problem, it just defeats the point of having the ability to apply the settings immediately.

mildertduck (r-j-l-hornby) wrote :

I have just encountered this bug, however frdu0001's workaround worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers