gnome-sound-properties dialog too high

Bug #28805 reported by Jan Claeys on 2006-01-17
36
Affects Status Importance Assigned to Milestone
gnome-control-center
Expired
Medium
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The new gnome-sound-properties dialog in dapper is so large that it doesn't fit on a 1024x768 screen with a panel at the top and one at the bottom...

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=326679

Changed in control-center:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

dapper is UI frozen, dropping the milestone

Changed in control-center:
status: Unknown → Confirmed
Changed in control-center:
importance: Medium → Low
Changed in control-center:
status: Confirmed → Triaged
Changed in gnome-control-center:
status: Confirmed → Invalid
Ying-Chun Liu (paulliu) wrote :

Hi Sebastien,

I've add scrolledbars to gnome-sound-properties when height is not enough.

Since there's no gnome-sound-properties in gnome upstream and it's a patch in debian/patches in Jaunty, I'm attaching the debdiff here.

Thanks.

Sebastien Bacher (seb128) wrote :

not sure that adding scrollbars everywhere is maintainable or the right strategy, we need to discuss those changes in the desktop team since it seems you are wanting to add such hack in lot of softwares

Bill Filler (bfiller) wrote :

I agree that we want to avoid using scrollbars if there is an alternative. Paul, our patch for Hardy modified the layout of the "devices" tab to move the Default Mixer Tracks section to the right side of the dialog so it fit nicely without scrollbars. This was done in the glade file. I believe in this case the layout should be modified to always have the Default Mixer Tracks on the right regardless of resolution as it works well in all resolutions. Same thing for the Sounds tab. The "Alerts and Sound Effects" can easily be moved to be right justified horizonatally. I will attach a screenshot.

Seb, do you agree it will be acceptable to modify the glade file in this case?

Bill Filler (bfiller) wrote :
Sebastien Bacher (seb128) wrote :

cc-ing mpt who is probably better placed for such suggestions

Ying-Chun Liu (paulliu) wrote :

Yes, I was moving things to right side long time ago but later I found it's not really good for some PC resolution only 800x480.

That why my original patches (for other later apps and not attached here) usually guaranteed that the application do fit in 640x480.

Currently we don't have projects that really use 800x480 but since most Microsoft apps do fit in 640x480, we should consider to archive the same thing.
Microsoft Windows and Microsoft-made apps runs good on netbooks without modification because I guess their policy is 640x480.

So if we move "Default Mixer Tracks" to right side, then it may not fit into 800x480, which is bad to EeePC 1st generation.

Matthew Paul Thomas (mpt) wrote :

This is just for devices that don't yet work with PulseAudio, correct? With devices that do work using the new Sound Preferences window. (Wow, until now I hadn't appreciated how incomprehensible the current preferences window is.)

If you keep with the horizontal arrangement, Bill's screenshot shows zero spacing between the top, right, and bottom edges of the right section and the edges of the tab. All of those spacings should be 12 pixels instead. One way of making that window arrangement a bit narrower would be to change "ALSA - Advanced Linux Sound Architecture" (currently the widest item in the menu) to just "ALSA".

An alternative way to make the window shorter would be to keep the vertical arrangement, but reduce redundant labels:
1. Instead of a "Sound Events" heading plus a "Sound playback:" label, have just a "Sound events playback:" label.
2. Instead of a "Music and Movies" heading plus a "Sound playback:" label, have just a "Music and movies playback:" label.
3. Instead of an "Audio Conferencing" heading plus "Sound playback:" and "Sound capture:" labels, have just "Audio conferencing playback:" and "Audio conferencing capture:" labels.
4. For bonus points, use checkboxes instead of multiple selection for the devices in the "Default Mixer Tracks" list. This would let you get rid of the "Use the Shift and Control keys to to select multiple tracks if required" text, freeing up the space that text used.

Sebastien Bacher (seb128) wrote :

the change you suggest makes a double border being displayed in the non scrollbar case which looks less nice on the standard desktop installation, could you try to fix this issue?

Changed in gnome-control-center:
status: Triaged → Incomplete
Ying-Chun Liu (paulliu) wrote :

Add debdiff files for #28805, #324464, #328954

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.25.90-0ubuntu3

---------------
gnome-control-center (1:2.25.90-0ubuntu3) jaunty; urgency=low

  * debian/control.in:
    - recommends iso-codes which is used in the layout selection dialog
      (lp: #289005)
  * debian/patches/90_gnome-mouse-properties_small_screen.patch:
    - change by Ying-Chun Liu to add scrollbar on small screens (lp: #28805)
  * debian/patches/91_gnome-about-me_small_screen.patch:
    - change by Ying-Chun Liu to add scrollbar on small screens (lp: #324464)
  * debian/patches/95_desktop-effects-integration.patch:
    - only call jockey when there was no desktop effects used yet (lp: #285879)
  * debian/patches/96_build_sound_capplet.patch:
    - update by Ying-Chun Liu to add scrollbar on small screens (lp: #28805)
  * debian/patches/109_screen_resolution_extra.patch:
    - change a string to fix a typo (lp: #284630)

 -- Sebastien Bacher <email address hidden> Fri, 20 Feb 2009 16:58:47 +0100

Changed in gnome-control-center:
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :

the debdiff is not trivial, what did you change exactly? I've just uploaded a 2.25.90-0ubuntu3 which contains the previous version of the change and will look at the update next week, maybe you can just update your changes to apply to this version?

Martin Pitt (pitti) wrote :

This looks a bit weird to me. It was rejected upstream with "We already have a better UI in the control-center for GNOME 2.24 and gnome-media for 2.25", and yet we applied the patches to 2.24?

If there's still something to be fixed in 2.25, it needs to be re-raised with upstream.

Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
Changed in gnome-control-center:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.