intrepid: gnome-sound-properties no longer allows enabling/disabling of system beep

Bug #282906 reported by Alec Wright on 2008-10-13
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Invalid
Medium
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

In previous versions of ubuntu, there was an option to enable/disable the system bell in gnome-sound-manager. There's no such option in intrepid.

Edgy (and i think up to hardy): http://www.howtogeek.com/wp-content/uploads/2006/12/WindowsLiveWriter/DisabletheSystemBeeponUbuntuEdgy_6457/systembeep.png

Intrepid replacement attached.

gnome-control-center:
  Installed: 1:2.24.0.1-0ubuntu4
  Candidate: 1:2.24.0.1-0ubuntu4

Alec Wright (alecjw) wrote :
Alec Wright (alecjw) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, that's an upstream bug and should be sent to bugzilla.gnome.org

Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Changed in gnome-control-center:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gnome-control-center:
status: New → Triaged
Changed in gnome-control-center:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

that's not a bug, the option is just displayed in the sounds listing

Changed in gnome-control-center:
status: Triaged → Invalid
Gonzalo Servat (gservat) wrote :

Sebastien, it looks like this isn't working. I have "Play alert sound" unticked which means "Alert sound" is dimmed. Visual Alert on "Flash window" and the beeps still occur. I then tried enabling "Alert Sound" and disabling "Alert sound", beeps still occur. I then tried disabling the entire thing by unchecking "Play alerts and sound effects" and ... keeps beeping!

.. so I went into the gconf-editor and checked that "audible bell" was disabled and it was. I exited gconf-editor and it doesn't beep anymore. Maybe gconf-editor does a rehup of some process which makes the changes take effect?

Gonzalo Servat (gservat) wrote :

I should have proof-read what I wrote before posting. Here it is again:

Sebastien, it looks like this isn't working. I have "Play alert sound" unticked which means "Alert sound" is dimmed. I've got "Visual Alert" on "Flash window" and the beeping still occurs. I then tried enabling "Play Alert Sound" and disabling "Alert sound", beeps still occur. I then tried disabling the entire thing by unchecking "Play alerts and sound effects" and ... keeps beeping!

Finally, I went into the gconf-editor and checked that "audible bell" was disabled and it was. I exited gconf-editor and it doesn't beep anymore. Maybe gconf-editor does a rehup of some process which makes the changes take effect?

Scott Wegner (swegner) wrote :

I can also confirm this. In my Sound Preferences, I have "Play alerts and sound effects" unchecked, as well as "Play alert sound". Subsequently, the rest of the options are grayed out. None of the other system sounds play (as expected). However, I still get the system beep on shutdown.

I realize that there are a number of workarounds (blacklist the driver, or apparently check the setting in gconf), but neither of these are really options for the casual user. There should be a simple setting in the gnome-sound-properties like there was in Hardy. And if somehow things changed from Hardy -> Intrepid, the previous setting should be migrated and honored.

Andy Hird (andy-hird) wrote :

I'll add another me to. I previously had system alerts (beeps) turned off when running Hardy but having upgraded to Intreprid they're back on and I don't have any way of turning them off again. Unticking all sounds in the gnome panel doesn't help, everything but the alerts gets turned off.

mikecaines (mikecaines-gmail) wrote :

In Intrepid, I can turn off the beep that ocurrs in Firefox, Eclipse, etc. by setting the following gconf entry:
/desktop/gnome/peripherals/keyboard/bell_mode
Set this to 'off' instead of 'on'.

This entry seems to be keyboard specific, I wonder if it is related to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/264196

Ferenc Magyar (garferi) wrote :

Why have the Gnome developers modify everything in Gnome what worked perfectly till now???
Gnome very very going to be suck!!! WAKE UP!!!
The previous method was better and worked like a charm, but this is **** together with the new "Volume control slider does not disappear after it has lost focus" "FEATURE"...

Martin Stjernholm (msub) wrote :

FYI the Gnome bug has been resolved as invalid. Seems to be due to that the original issue in this report probably is valid (a tab is gone, but the option has only moved to another tab).

However, the problems further down in this ticket are real. I got it too, and I managed to disable the bell sound by editing /desktop/gnome/peripherals/keyboard/bell_mode in gconf-editor.

Martin Stjernholm (msub) wrote :

Sorry, I made a rather unfortunate spello there: It should read "probably is invalid" on the second line.

w1zard (pacehead) wrote :

I agree - an upgrade to Intrepid has re-enabled the 'bell' or 'beep' when clicking 'Shutdown' or at the login screen. There is no way in the GUI or standarde Gnome settings to reset this (nonr that work, anyway). The only way to disable it again is:

run gconf-editor from terminal and set
/desktop/gnome/peripherals/keyboard/bell_mode
to 'off' rather than 'on'

Not exactly easy to find for your experienced users, impossible for the average user. At the very least this should setting should be migrated during an upgrade, but should really be editable from the Sound properties tab.

Scott Wegner (swegner) wrote :

This bug doesn't seem to be getting much attention, as the initial bug report is different than the problems being expressed in the comments. For those of you experiencing a system beep only on shutdown, there is another bug report open here:

https://bugs.edge.launchpad.net/ubuntu/+source/gnome-session/+bug/290204

w1zard (pacehead) wrote :

Thanks - reposted information into the bug report mentioned by Scott.

Nathan Rogers (nathaniel-r) wrote :

I don't think this will have anything to do with the shutdown beep, however it looks like some may just have the problem of disabling the system bell all together.

It may be important to note that if any of you are using Compiz, you will have to disable the system bell through the "CompizConfig Settings Manager" under the General->General Options->General tab, uncheck "Audible Bell".

Scott Ritchie (scottritchie) wrote :

Here's another bug for another issue being mentioned in the comments:

https://bugs.edge.launchpad.net/ubuntu/+source/gnome-control-center/+bug/301174 -- annoying system beep plays instead of alert sound

Mikel Ward (mikelward) wrote :

According to the upstream bug, there should be an option called "Play system beep sound" under the Sounds tab in GNOME 2.24, but I don't see that on my Ubuntu 8.10 (GNOME 2.24.1) system.

Did Ubuntu make changes to the preferences screen?

Mikel Ward (mikelward) wrote :

Ah, the option is called "Play alert sound".

It doesn't do anything on my computer, but there could be a few reasons for that.

Andrew (andrew-rw-robinson) wrote :

This should not be "invalid", turning the "/desktop/gnome/peripherals/keyboard/bell_mode" off does nothing, nautilus/gnome will still play the "alert sound". Unfortunately, there seems to be no way to turn off the alert sound, only a way to choose one of the annoying alert sounds provided. The only "fix" I currently see is to disable all sounds by selecting "No sounds" as the gnome sound theme, which is not a good work-around.

I came across this as deleting files in nautilus now causes these alert sounds, very annoying as moving something to the trash is not an error.

Discussion on the subject:
http://ubuntuforums.org/showthread.php?p=3669007

Changed in gnome-control-center:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.