gnome-display-properties dont allow me rotate screen rigth and left but xrandr works fine

Bug #280798 reported by eSe on 2008-10-09
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

gnome-display-properties only show me in rotate options normal and upside down but i want works in portrait mode (left rotate or right rotate)
If I go to the terminal and type:
$ xrandr -o 3

All works fine, gnome-display-properties should do this by self.

eSe (snaker) wrote :
James Westby (james-w) wrote :

Hi,

It normally gives four options, so I'm not sure why you only get
two.

Thanks,

James

Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low

With the last updates, I can't open gnome-display. Two updates last and it gave me only those two options.

$$ gnome-display-properties
Xlib: extension "RANDR" missing on display ":0.0".

display-properties-ERROR **: Could not get screen info
aborting...
Aborted

My xorg file:
####################################
####################################
Section "Monitor"
  Identifier "Configured Monitor"
EndSection

Section "Screen"
  Identifier "Default Screen"
  Monitor "Configured Monitor"
  Device "Configured Video Device"
  DefaultDepth 24
EndSection

Section "Module"
  Load "glx"
  Disable "dri2"
EndSection

Section "Device"
  Identifier "Configured Video Device"
  Driver "nvidia"
  Option "NoLogo" "True"
  Option "Rotate" "CCW"
EndSection

###############################
###############################
Screen rotates fine with Option "Rotate" "CCW"

From Xorg.0.log:
(II) NVIDIA(0):The RandR extension is not compatible with the Rotate option
(II) NVIDIA(0): Disabling RandR.

The problem is that I want to rotate the screen everytime I restart.

And everything works great too, including 3d.

Sebastien Bacher (seb128) wrote :

could you give details on the videocard, videodriver and ubuntu version you are using?

Changed in gnome-control-center:
status: New → Incomplete

Nvidia gforce go 7300 memory 256 MB vbios version 256 MB PCI Express 16X in a laptop.

Ubuntu version Intrepid

The problem is the "rotate" option in xorg, but I need it, without it I could not rotate the screen, only the two options(upside down, normal) above mentioned. I had it working in Hardy without "rotate", using a script with at gdm loading times.

The script stopped to work in intrepid.

Andrew Brown (seatrout) wrote :

The same problem here with an nvdia 5200 card. The manual "xrandr" command works fine. But the gnome preference panel only offers me the choice of being right way up and upside down.

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in jaunty?

AppleCrow (acorbeaux) wrote :

It's still an issue in jaunty.
GDP allows only normal and inversed screen rotation.
But GDP warns user about issue between it and nvidia driver, and prompt user to manage display through nvidia control panel.

But NCP doesn't provide a simple way, as GDP, to manage displays.

Bogdan Butnaru (bogdanb) wrote :

I'm not sure if I should, but I'm moving this to Confirmed, as I have the same problem myself. I'm running up-to-date Jaunty.

Just as the original poster mentioned, xrandr works correctly, but the applet only offers “normal” and “upside down” as options.

My card is an nVidia 9600 GT, running the nvidia binary drivers (180). I have enabled rotation in xorg.conf with « Option "RandRRotation" "True" » (not sure if this is true for the original report).

A few more details:
* The display properties applet complains that “It appears that your graphics driver does not support the necessary extensions to use this tool”, and it asks if I want to use the “vendor's tool” (nvidia-settings). The latter works correctly, but is a bit too verbose for everyday use (I rotate my screen often). Also, it's a bit annoying that I get asked the same question every single time.
* For some reason the applet displays “Unknown” as the screen identifier. I imagine that's somehow nVidia's fault, but it's still annoying: I have a single screen, its name is manually entered in xorg.conf, and nvidia-settings is able to show it (also, if I ask it to acquire EDID info, it succeeds, and the screen's name is contained therein).

Let me know if I can provide any more useful information.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
yldouright (yldouright) wrote :

If someone can post a working set of X files including xorg.conf then we may at least have a reference point for those who wish to manually edit their files. A brief description of the hardware where the configuration set is working (ex: nvidia 6150 on board and G100 on pci) would also be helpful.

Bryce Harrington (bryce) wrote :

Could someone test if this is still an issue with Ubuntu natty? I suspect the issue is gone now.

If you don't want to install Ubuntu Precise, it should be sufficient to boot a Live USB session, configure the monitors, and see if it is working properly now. You can get the current Live USB desktop image at http://cdimage.ubuntu.com/daily-live/current/ and create a USB boot drive using usb-creator.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

Ok, this has been working fine for me. Since there's been no response I'll go ahead and assume whatever the issue was it's long since been solved.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints