Ubuntu

Codes shown in Gnome Preferences Keyboard Shortcuts

Reported by Manuel López-Ibáñez on 2005-11-04
20
Affects Status Importance Assigned to Milestone
gnome-control-center
Invalid
Low
gnome-control-center (Ubuntu)
Low
Pascal De Vuyst

Bug Description

Strange codes are shown by default in System > Preferences > Keyboard Shortcuts.
For example,
Launch help browser is 0xbb.

As additionaly information, my system language is English, however, my keyboard
is setup as Spanish.

Created an attachment (id=4873)
0x?? codes shown in Keyboard Shortcuts dialog

Daniel Holbach (dholbach) wrote :

Thanks for your comments. These codes are perfectly normal, they describe the
key event that is reported, when you press a key. I close the bug as NOTABUG -
if you disagree, feel free to REOPEN it again.

Well, they don't seem very usable if one wants to know which is the default key
to do something. Anyway, I use emacs, so who am I to discuss GNOME HIG and
usability with respect to keyshortcuts ;)

Does KDE show also the key codes? I don't think so.

Anyway, I won't reopen this bug since I predict that within a year those codes
will be replaced by key labels that users can understand.

Daniel Holbach (dholbach) wrote :

*** Bug 27289 has been marked as a duplicate of this bug. ***

Martin Olsson (mnemo) wrote :

manu your prediction was wrong, I just booted Gutsy Tribe4 and this bug is still thriving. This bug should be escalated to GNOME bug database.

Martin Olsson (mnemo) wrote :

I took the time to report this bug into GNOME bugzilla now (it's filed as 466058 in their system).

Martin Olsson (mnemo) wrote :

How can I change the status of this bug to something other than "Invalid". I think it's valid and should be reopened.

Wowww, I had given on that one, nice to see some activity !! :o)

Yes, I too can confirm that in 2 years, each and every Ubuntu version, stable or alpha, has never stopped to show weird hex codes. So indeed, seeing the bug status as "invalid", is weird at best. Should be "confirmed" or something iike that...

Mnemo, thanks for filing it upstream in Gnome BTS, though I can't believe it wasn't already filed ?!
I think that Malone has a feature where you can track the upstream bug report (which you just filed), but I don't know how to do it, and I probably don't have the privilege to do it anyway...

Would be nice to fix this bug, would definitely add some "polish" to the user interface, which I thought was one of Ubuntu's main goal...

Here is hoping ! ;-)

On behalf of mnemo. Still valid in Gutsy Tribe4

Changed in control-center:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

Vincent, you know that lot of bugs are opened and the distribution team ressources are limited, the fact the bug has not been worked has nothing to do with the goal of Ubuntu

Changed in control-center:
assignee: seb128 → desktop-bugs
status: New → Triaged

> Vincent, you know that lot of bugs are opened and the distribution team ressources are limited, the fact the bug has not > been worked has nothing to do with the goal of Ubuntu

I was just being a little sarcastic with no bad intentions at all, I apologize...

Martin Olsson (mnemo) wrote :

On the GNOME bug there was an interesting comment:
---------------------------------------------------------------------------------------------------------------------
 Comment #3 from Jens Granseuer (gnome-control-center developer, points: 21)
2007-08-13 17:02 UTC [reply]

This is not a bug in the shortcuts capplet. It does show the key names *if the
keys actually have names*. If they aren't mapped to proper keysyms, there's
nothing we can do about it. Your keymap needs to be fixed (see xmodmap).

Martin Olsson (mnemo) wrote :

I just did a little experiment. First a booted clean from the Gutsy Tribe 4, then before changing anything I took a screenshot of the keyboard shortcuts dialog. It had a large number of "hex codes". Then I switched to swedish keyboard layout and looked again. The exact same keys had hexcodes (no change). I did this experiment because I wanted to know if the hexcode problem was related to specific keyboard layouts/locales.

Changed in control-center:
status: Unknown → Invalid

The problem is that not all keyboards generate the same keycodes for multimedia/internet keys. So it is not possible to map these keys out of the box with a name (called a keysym).

To get keysyms for your keys instead of hex codes there are 2 possibilities:
1) Find out the keycodes with xev and map them to the right keysyms with xmodmap
2) Define a new keyboard model in /usr/share/X11/xkb/symbols/inet which allows you to select the keyboard in the GNOME Keyboard Preferences.

A detailed description on how to do this can be found here: http://gentoo-wiki.com/HOWTO_Use_Multimedia_Keys

Perhaps somebody could set up some project and ask the community to provide their xmodmap files and create keyboard models from this that can be sent to xorg upstream. This would be a good and relatively easy contribution to Ubuntu and GNU/Linux in general.

This is not a bug in GNOME Keyboard Shortcuts.

Changed in control-center:
assignee: desktop-bugs → pascal-devuyst
status: Triaged → Invalid

KDE shows the keys correctly in KControl.

Manu,
This is because kdebase-bin package provides this file:
/etc/X11/Xsession.d/80ubuntu-xmodmap
This file contains keycode to keysym mappings for frequently used multimedia/internet keys as described in my previous comment.

As said before not every keyboard generates the same scancodes for the same multimedia/internet key, these keys were added later to keyboards and every manufacturer could choose different scancodes.
In Ubuntu we could define some buttons like Back and Forward, that have the same scancodes on nearly every keyboard, to work out of the box. But using a xmodmap file like KDE will likely result in some of your multimedia keys still not working or some keys being swapped.

So the question is:
Should we make some keyboard buttons work out of the box? Or should your keyboard model be added to xorg to make all your buttons work when selecting the right keyboard model in GNOME Keyboard Preferences?

Sebastien Bacher (seb128) wrote :

the discussion could be better placed on a mailinglist

Martin Olsson (mnemo) wrote :

What mailing list do you suggest? I'm not currently subscribed to any Ubuntu lists.

Martin Olsson (mnemo) wrote :

fixing status (even though it's not a gnome bug, we still have a problem in ubuntu)

Changed in control-center:
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

you can try the ubuntu-devel-discuss one

Sebastien Bacher (seb128) wrote :

the intrepid version displays the keycode names now

Changed in control-center:
status: Confirmed → Fix Released
Changed in gnome-control-center:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.