Useful dual-head configuration requires manual editing of xorg.conf to set Virtual

Bug #220563 reported by Grant Ingram on 2008-04-22
74
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs
xorg (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xorg

Users upgrading from Dapper Drake to Hardy Heron who have used Xinerama to support dual monitors now have to use a different method (xrandr I think). This isn't mentioned in the release notes and the graphical tool for configuring dual monitors is under "Screen Resolution" in the System -> Preferences Menu. The point being that it is quite hard to find.

Users with multiple desktops appear to have add the following to the xorg.conf file "Screen" section:

SubSection "Display"
  Depth 24
  Virtual 4000 2048
EndSubSection

Then the screen resolution tool works fine for me.

A note in the release notes like the following might help:

"Ubuntu 8.04 changes the way dual monitors are supported. Users should edit the xorg.conf file and then use the System -> Preferences -> Screen Resolution tool to configure dual monitors on their system. "

[More Info]
You should set your Virtual size to the maximum height and width of your combined displays. So if you have two 1600x1200 displays you want to place one beside the other, use Virtual 3200x1200.

Note that setting Virtual to greater than 2048 in either height or width will prevent DRI from loading, which means that Compiz cannot be used (bug #146859). The absolute maximum is 8192x8192. These limits will probably go away in Intrepid after TTM is integrated.

Bryce Harrington (bryce) on 2008-04-30
Changed in xorg:
assignee: nobody → bryceharrington
importance: Undecided → High
milestone: none → ubuntu-8.04.1
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I've documented this at https://wiki.ubuntu.com/X/Config.

A mention in the release notes sounds wise as well, although it's too late for 8.04, but we could put a note into 8.04.1. I wasn't even certain the feature would be available (and functional) in time for the release, so we didn't advertise it in the release notes.

However, I'm betting most people won't look at release notes. An alternate solution would be to check the current Virtual size in the applet when setting dual screen modes; I think this can be done entirely with just libXrandr calls in C. Then, if the selected size would exceed the current maximum Virtual size, it should display a warning dialog to the user mentioning the need to edit xorg.conf to make that setting.

An even better solution would be to include something to edit the xorg.conf for them automagically, however given the wide amount of variations in xorg.conf's out in the wild, I would worry that such a "feature" could end up causing a lot of damage. Plus, the effort would be a waste since for Intrepid the need for specifying Virtual should go away entirely. So I am not going to attempt to do this auto-editing, but if anyone else has a moment of brilliance and comes up with a stunning (and lo-risk) patch, I'd be very interested.

Bryce Harrington (bryce) on 2008-04-30
description: updated
description: updated
Bryce Harrington (bryce) on 2008-04-30
Changed in xorg:
assignee: bryceharrington → nobody
Mark Renouf (mark-renouf) wrote :

I think the first issue to address is providing the user useful feedback.

The first thing I noticed was that both of my screens were detected correctly, but when I set the option to use them independently it seemed to complete giving no indication of a problem. I'd like to see a clear error message returned when I try to disable cloned mode, and have the UI remain in the original state.

Even better, it should be possible to detected the current virtual size and anticipate the problem. For example, if the user reorients the screens so they are vertically stacked, and the Virtual setting is not tall enough, the "cloned" mode option should become disabled, along with a message indicating the reason and some direction on how to resolve it.

At least then, people aren't left wondering...

Sebastien Bacher (seb128) wrote :

confirming, gnome-control-center should give indications about the issue and how to solve it to users

Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Iulian Udrea (iulian) on 2008-07-03
Changed in xorg:
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

the gnome-control-center not being verbose issue has been sent on http://bugzilla.gnome.org/show_bug.cgi?id=545118

Changed in gnome-control-center:
status: Confirmed → Triaged
Changed in gnome-control-center:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.23.90-0ubuntu3

---------------
gnome-control-center (1:2.23.90-0ubuntu3) intrepid; urgency=low

  [Alberto Milone]
  * patches/106_screen-res-extra-support.patch: Add use of
    screen-resolution-extra for automatically configuring Virtual
    setting. (LP: #220563)

 -- Bryce Harrington <email address hidden> Fri, 29 Aug 2008 13:09:13 -0700

Changed in gnome-control-center:
status: Triaged → Fix Released
Bryce Harrington (bryce) wrote :

fixed in g-c-c

Changed in xorg:
milestone: ubuntu-8.04.1 → none
status: Triaged → Invalid
Kieran Fleming (kieran-fleming) wrote :

This doesn't seem fixed in intrepid alpha 5. When trying to apply the settings I get nothing in the GUI and on the terminal I get, "Error: Cannot setup multi-screen configuration with the current Virtual settings".

Muanis (muanis) wrote :

Hi guys, after having a bad day trying to figure out dual head problema i found this entry.

It's really awesome to support resolution change through XRandR, but removing the item from the menu maybe just confused everyone. More than 20 users wich I've talked to, just found the application name and messes with all of their Xorg setup (myself included).

Maybe some notes on first time use of Screen Resolutions would improve the dialog with the users.

Good luck and keep the good work!

Jose Muanis

Alberto Milone (albertomilone) wrote :

FFE request:

The following patches will make the process extremely easy for users so that:
1) the user tries to enable an external monitor (a la xinerama)
2) if screen-resolution-extra is installed:
she is asked the permission to change the virtual resolution and then she's told to log out and log back in.
Otherwise if screen-resolution-extra is not installed:
she is asked to change the virtual resolution manually to what the gtk dialog suggests and to log out and log back in.
Either way her settings are saved in ~/.config/monitos.xml.desired
3) On next login, if everything's ok (i.e. the connected outputs are the same and the framebuffer is enough), the gnome-settings-daemon will load the settings from ~/.config/monitos.xml.desired and the user will have her multiple screens layout automatically applied without problems.

This will require:
1 patch for gnome-desktop (which is used by gnome-settings-daemon)
1 patch for gnome-control-center (which uses gnome-desktop and screen-resolution-extra, the latter being only an option, not a dependency)
an update of screen-resolution-extra so that it only applies the settings without duplicating the calculation of the required framebuffer (now done in gnome-desktop)

See the debdiffs attached below.

Alberto Milone (albertomilone) wrote :

Here's the diffstat.

Alexander Butenko (avb) wrote :

guys, bug is still present. Without installing screen-resolution-extra package no error is displayed.
Maybe lets put screen-resolution-extra as a dependency to ubuntu-desktop?

Steve Langasek (vorlon) wrote :

setting back to 'confirmed', since there's an outstanding FFe...

Changed in gnome-control-center:
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :

ah, FFe request moved to bug #275977 instead.

Changed in gnome-control-center:
status: Confirmed → Fix Released
Changed in gnome-control-center:
status: Confirmed → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.