No way to enroll multiple fingers for identification

Bug #1873298 reported by Marco Trevisan (Treviño) on 2020-04-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Marco Trevisan (Treviño)
Focal
Medium
Marco Trevisan (Treviño)

Bug Description

* Impact

This is the continuation of bug #1865845.

In g-c-c user panel, it is not possible to enroll more than one finger for authentication.

* Test Case

1. enroll fingerprint in gnome-control-center
2. close the dialog
3. click it again to enroll another finger
4. it shows a dialog requiring you to delete your fingerprints

* Impact

As per this, GNOME design has produced some artwork that we want to implement to fix all these issues:
 - https://gitlab.gnome.org/Teams/Design/settings-mockups/-/issues/18

There will be few new strings, although most of the action events are already covered by the fprintd translations.

UI will change quite a lot, but the current documentation [1] should not be affected by the change, being quite generic, but in case it might be updated to be clearer. The change are important improvements and oem request so believe it's right to carry over as a SRU and considered as hardware enablement

The new strings are already translatable on launchpad and the translators mailing list has been notified, hopefully we can get some coverage for the new UI in time for the LTS .1 langpack refresh

[1] https://help.ubuntu.com/19.10/ubuntu-help/session-fingerprint.html

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.4-1ubuntu1

---------------
gnome-control-center (1:3.36.4-1ubuntu1) groovy; urgency=medium

  * New stable version (lp: #1886495)

  [ Hui Wang ]
  * debian/patches/gitlab_ucm_mixer_control_select.patch:
    - consolidate port finding and setting with/without ucm (lp: #1885673)

  [ Marco Trevisan (Treviño) ]
  * Merge with debian unstable, containing new stable upstream version
  * Refresh patches:
    - d/p/0028-user-panel-Add-reference-to-selected-user-and-clear-.patch,
      d/p/0029-user-panel-Don-t-wait-for-fprintd-on-initialization.patch,
      d/p/0030-fingerprint-dialog-Don-t-use-sync-calls-for-deleting.patch,
      d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch,
      d/p/git-sound-profile.patch:
      + Removed, applied upstream
    - d/p/Revert-build-Bump-build-dependency-on-polkit.patch:
      + Removed, was a duplicated file for patch 0021.
  * user-accounts: Use newly designed fingerprint enroll dialog (LP: #1873298)

 -- Sebastien Bacher <email address hidden> Wed, 08 Jul 2020 17:03:08 +0200

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated

Hello Marco, or anyone else affected,

Accepted gnome-control-center into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.36.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal

Tested in gnome-control-center 1:3.36.4-0ubuntu1, using the synaptics sensor in a recent ThinkPad.

Multiple fingerprints can be enrolled, it's still possible to remove the fingerprints properly, identification at unlock/login phase still works properly.

---

❯ apt-cache policy gnome-control-center
gnome-control-center:
  Installato: 1:3.36.4-0ubuntu1
  Candidato: 1:3.36.4-0ubuntu1
  Tabella versione:
 *** 1:3.36.4-0ubuntu1 400
        400 http://archive.ubuntu.com/ubuntu focal-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.36.3-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
     1:3.36.1-1ubuntu5 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
frank (frankwu) wrote :

tested the package,

gui-bug seems to be fixed, i can add fingerprints and delete them. but it looks like they are not registered the right way...i can only login with the first finger i added (tried also reboot and second is still listed in gnome-control-center)....the other one added with the new gui is not recognized...can i check if the fingerprints are added right?

unlock seems to need additional Patch from gnome-shell (gnome-flashback session)

strange is that the dialog is not movable (titlebar-dragging), is this intented?

frank (frankwu) wrote :

Tried with fprintd-list (both listed), fprintd-verify (only first matching) and deleting/new assigning (same result) with my closed source goodix 530c. I guess it's a driver-bug...not gnome-control-center one.

Sorry for the noise

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.4-0ubuntu1

---------------
gnome-control-center (1:3.36.4-0ubuntu1) focal; urgency=medium

  [ Hui Wang ]
  * debian/patches/gitlab_ucm_mixer_control_select.patch:
    - consolidate port finding and setting with/without ucm (lp: #1885673)

  [ Marco Trevisan (Treviño) ]
  * New stable version (lp: #1886495)
  * Refresh patches:
    - d/p/0028-user-panel-Add-reference-to-selected-user-and-clear-.patch,
      d/p/0029-user-panel-Don-t-wait-for-fprintd-on-initialization.patch,
      d/p/0030-fingerprint-dialog-Don-t-use-sync-calls-for-deleting.patch,
      d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch,
      d/p/git-sound-profile.patch:
      + Removed, applied upstream
    - d/p/Revert-build-Bump-build-dependency-on-polkit.patch:
      + Removed, was a duplicated file for patch 0021.
  * user-accounts: Use newly designed fingerprint enroll dialog (LP: #1873298)

 -- Sebastien Bacher <email address hidden> Wed, 08 Jul 2020 17:03:08 +0200

Changed in gnome-control-center (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers