Toggle "Fractional Scaling" does nothing on wayland

Bug #1871864 reported by Grant Kim on 2020-04-09
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Marco Trevisan (Treviño)
Focal
Low
Marco Trevisan (Treviño)

Bug Description

* Impact
In the setting there is option called "Fractional Scaling" but this option only works for X11.

* Test Case
Enable the experimental scaling option in settings and verify that non integer values are listed in the choices

* Regression potential
Check that turning the option on and off works in xorg and wayland

Grant Kim (enpinion) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks, indeed we should either hide the option under wayland or make change the other key. Unsure if the backend would deal correctly with the fractional scaling or if there is more work than just toggle the other key. It might be safe as this point to just not list the control there

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Daniel van Vugt (vanvugt) wrote :

WORKAROUND:

Enable it manually from a Terminal:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer', 'x11-randr-fractional-scaling']"

Daniel van Vugt (vanvugt) wrote :

Since the Wayland fractional scaling implementation is a little more mature and performs better than the X11 one I think it's more important than Low that the GUI can enable it.

Changed in gnome-control-center (Ubuntu):
importance: Low → Medium
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

Also note the uninitialized variable in bug 1874207 can cause the fractional scaling options to go missing randomly.

tags: added: xrandr-scaling
Sebastien Bacher (seb128) wrote :

Sorry but wayland is not our default session and used by less than 1% of our users, it's a low priority item in that regard

Changed in gnome-control-center (Ubuntu):
importance: Medium → Low

Not a problem. I'm happy on X but wanted to make sure I did my bit

On Thu, 30 Apr 2020, 11:46 Sebastien Bacher, <email address hidden> wrote:

> Sorry but wayland is not our default session and used by less than 1% of
> our users, it's a low priority item in that regard
>
> ** Changed in: gnome-control-center (Ubuntu)
> Importance: Medium => Low
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1875751).
> https://bugs.launchpad.net/bugs/1871864
>
> Title:
> Toggle "Fractional Scaling" does nothing on wayland
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1871864/+subscriptions
>

@seb128

What would you think it should be appropriate to do when in wayland?
Hide the panel at all, or just change the setting we use? In such case the warning text wouldn't be correct though...

In fact I suggested in the past to have two strings for the two cases.

Sebastien Bacher (seb128) wrote :

@Marco, for focal we should probably just not display the setting under wayland to avoid having a new string or using an incorrect one

Daniel van Vugt (vanvugt) wrote :

Why not just make it actually toggle Wayland fractional scaling?... 'scale-monitor-framebuffer' instead of 'x11-randr-fractional-scaling'

The warning text that's there is kind of appropriate to Wayland so I don't see that as an issue. Although it really should have included a warning about screen tearing which is Xorg-specific (bug 1846398). It doesn't so it's fine to keep the warning in Wayland too.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in gnome-control-center (Ubuntu Focal):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.3-1ubuntu1

---------------
gnome-control-center (1:3.36.3-1ubuntu1) groovy; urgency=medium

  * New upstream version rebased on Debian (lp: #1884063)

  [ Gunnar Hjalmarsson ]
  * debian/patches/0030-temporarily-revert-alt-char-key.patch:
    - Change po/POTFILES.in too, so dh_translations can create
      gnome-control-center-2.0.pot.
  * d/p/0015-connectivity-add-network-connectivity-checking-toggl.patch:
    - Add "privacy" to Keywords in the .desktop file in line with
      https://gitlab.gnome.org/GNOME/gnome-control-center/-/commit/05f3cb67
      (LP: #1869288)

  [ Marco Trevisan (Treviño) ]
  * d/p/0008-Allow-tweaking-some-settings-for-Ubuntu-Dock.patch:
    - Ensure dock position is respected in RTL (LP: #1876937)
    - Add proper matching the dock monitor ID (LP: #1877108)
  * d/p/0024-display-Allow-fractional-scaling-to-be-enabled.patch:
    - Improve fractional scaling toggling (LP: #1876891, #1876894)
    - Look for proper fractional scaling key in Wayland and X11 (LP: #1871864)
  * d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch:
    - Don't make flowbox children selectable (LP: #1877441)

 -- Sebastien Bacher <email address hidden> Thu, 18 Jun 2020 13:44:56 +0200

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello Grant, or anyone else affected,

Accepted gnome-control-center into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.36.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Grant Kim (enpinion) wrote :

Hello,

I can confirm the problem is now fixed on "gnome-control-center/focal-proposed 1.36.3".

Thank you.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.3-0ubuntu1

---------------
gnome-control-center (1:3.36.3-0ubuntu1) focal; urgency=medium

  * New stable version (lp: #1884063)

  [ Gunnar Hjalmarsson ]
  * debian/patches/0030-temporarily-revert-alt-char-key.patch:
    - Change po/POTFILES.in too, so dh_translations can create
      gnome-control-center-2.0.pot.

  [ Marco Trevisan (Treviño) ]
  * d/p/0008-Allow-tweaking-some-settings-for-Ubuntu-Dock.patch:
    - Ensure dock position is respected in RTL (LP: #1876937)
    - Add proper matching the dock monitor ID (LP: #1877108)
  * d/p/0024-display-Allow-fractional-scaling-to-be-enabled.patch:
    - Improve fractional scaling toggling (LP: #1876891, #1876894)
    - Look for proper fractional scaling key in Wayland and X11 (LP: #1871864)
  * d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch:
    - Don't make flowbox children selectable (LP: #1877441)

 -- Sebastien Bacher <email address hidden> Tue, 23 Jun 2020 17:50:27 +0200

Changed in gnome-control-center (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

After upgrading to version 1:3.36.3-0ubuntu1, nothing has changed ...
https://i.imgur.com/tI2nla4.png
https://i.imgur.com/Z6NykYk.png
https://i.imgur.com/HHwjgm3.png

Everything worked only after rebooting the system - https://i.imgur.com/1eAjLFZ.png

Yeah, you need to login/logout with wayland.

That's another mutter issue, but worth fixing upstream and very low-priority for us.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers