gnome-control-center crashed with SIGSEGV in cc_display_config_set_minimum_size()

Bug #1870735 reported by Laurent Bonnaud on 2020-04-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

I was running gnome-control-center from KDE/plasma and trying all sections.
The crash occurred when I tried to enter the "Display" section.

ProblemType: Crash
DistroRelease: Ubuntu 20.04
Package: gnome-control-center 1:3.36.1-1ubuntu3
Uname: Linux 5.6.2-050602-generic x86_64
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CurrentDesktop: KDE
Date: Sat Apr 4 08:57:48 2020
ExecutablePath: /usr/bin/gnome-control-center
ProcCmdline: gnome-control-center
SegvAnalysis:
 Segfault happened at: 0x563298319f44 <cc_display_config_set_minimum_size+4>: mov (%rdi),%rax
 PC (0x563298319f44) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 cc_display_config_set_minimum_size ()
 ()
 ()
 <emit signal ??? on instance 0x56329a808180 [CcDisplayConfigManagerDBus]> (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at ../../../gobject/gsignal.c:3554
 ()
Title: gnome-control-center crashed with SIGSEGV in cc_display_config_set_minimum_size()
UpgradeStatus: Upgraded to focal on 2020-04-02 (1 days ago)
UserGroups: adm cdrom dip fuse kvm libvirt libvirtd lpadmin plugdev sambashare staff sudo
separator:

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1843699, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.1-1ubuntu5

---------------
gnome-control-center (1:3.36.1-1ubuntu5) focal; urgency=medium

  * debian/patches/git-info-crash-on-nvidia.patch:
    - backport a fix for an info panel segfault on nvidia cards
      (lp: #1870737)
  * debian/patches/git-nongnome-segfault.patch:
    - don't segfault when started outside of GNOME (lp: #1870735)

  [ Marco Trevisan ]
  * d/p/0028-user-panel-Add-reference-to-selected-user-and-clear-.patch,
  * d/p/0029-user-panel-Don-t-wait-for-fprintd-on-initialization.patch,
    d/p/0030-fingerprint-dialog-Don-t-use-sync-calls-for-deleting.patch,
    d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch:
    - Don't wait for fprintd on initialization and don't limit enroll stages
      (lp: #1865845)

  [ Robert Ancell ]
  * debian/patches/0027-window-Stop-using-HdyLeaflet.patch:
    - Disable adaptive layouts, theres some bugs and they're not required on
      desktop (LP: #1871195)
  * debian/patches/0028-applications-Fix-only-connected-snap-interfaces-show.patch:
    - Fix disconnected snap interfaces not showing (LP: #1870600)
  * debian/patches/0029-applications-Use-new-snapd-glib-API-for-labelling-Sn.patch:
  * debian/control:
    - Use shared names for snap interfaces, fixing some interfaces that don't
      have labels.

  [ Gunnar Hjalmarsson ]
  * debian/patches/0030-temporarily-revert-alt-char-key.patch:
    - Revert the "Alternate Characters Key" commit temporarily awaiting
      a proper fix of LP: #1867548.

 -- Sebastien Bacher <email address hidden> Thu, 16 Apr 2020 12:30:37 +0200

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released

Thanks a lot for the fix!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers