permissions pane only shows currently-connected snap interfaces

Bug #1870600 reported by Daniel Llewellyn on 2020-04-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Robert Ancell

Bug Description

The applications applet in Gnome Control Center shows permissions that can be toggled on and off for installed applications and snap packages. When viewing a Snap package, only permissions that are currently enabled (interface is connected in Snap terms). Viewing the same Snap package's permissions in Gnome Software or the Snap Store Snap you can see that there are more permissions that can be enabled which are not currently.

I have uploaded an example of both views to highlight the discrepency in a screenshot at: https://www.dropbox.com/s/zqr35hll94d37yg/photo_2020-04-03_19-49-06.jpg?dl=0

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gnome-control-center 1:3.36.1-1ubuntu2
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Uname: Linux 5.4.0-18-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Apr 3 19:48:07 2020
InstallationDate: Installed on 2020-03-03 (30 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200303)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel Llewellyn (diddledan) wrote :
tags: added: champagne
Martin Wimpress (flexiondotorg) wrote :

Robert, please can you confirm is this is indeed a bug.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Francois Thirioux (fthx) wrote :

Same bug here, g-c-c 1:3.36.1-1ubuntu4. Image attached : control-center + snap-store.
Really annoying if you don't use snap-store or gnome-software.

Francois Thirioux (fthx) wrote :

As you see in above image, additionally there is a sync issue between g-c-c and snap-store about the permissions state.

Ken VanDine (ken-vandine) wrote :

I can confirm that these only show up after connecting the interface.

Robert Ancell (robert-ancell) wrote :
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.1-1ubuntu5

---------------
gnome-control-center (1:3.36.1-1ubuntu5) focal; urgency=medium

  * debian/patches/git-info-crash-on-nvidia.patch:
    - backport a fix for an info panel segfault on nvidia cards
      (lp: #1870737)
  * debian/patches/git-nongnome-segfault.patch:
    - don't segfault when started outside of GNOME (lp: #1870735)

  [ Marco Trevisan ]
  * d/p/0028-user-panel-Add-reference-to-selected-user-and-clear-.patch,
  * d/p/0029-user-panel-Don-t-wait-for-fprintd-on-initialization.patch,
    d/p/0030-fingerprint-dialog-Don-t-use-sync-calls-for-deleting.patch,
    d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch:
    - Don't wait for fprintd on initialization and don't limit enroll stages
      (lp: #1865845)

  [ Robert Ancell ]
  * debian/patches/0027-window-Stop-using-HdyLeaflet.patch:
    - Disable adaptive layouts, theres some bugs and they're not required on
      desktop (LP: #1871195)
  * debian/patches/0028-applications-Fix-only-connected-snap-interfaces-show.patch:
    - Fix disconnected snap interfaces not showing (LP: #1870600)
  * debian/patches/0029-applications-Use-new-snapd-glib-API-for-labelling-Sn.patch:
  * debian/control:
    - Use shared names for snap interfaces, fixing some interfaces that don't
      have labels.

  [ Gunnar Hjalmarsson ]
  * debian/patches/0030-temporarily-revert-alt-char-key.patch:
    - Revert the "Alternate Characters Key" commit temporarily awaiting
      a proper fix of LP: #1867548.

 -- Sebastien Bacher <email address hidden> Thu, 16 Apr 2020 12:30:37 +0200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers