"Privacy" tab in gnome-control-center is not findable

Bug #1869288 reported by Bruno Nocera Zanette on 2020-03-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Gunnar Hjalmarsson

Bug Description

Searching for "Privacy" using gnome-control-center search bar returns the "Search" tab instead of the "Privacy" tab. The same thing happens with Gnome Shell Search.

For all the other tab names of gnome-control-center it works as expected, including Privacy's sub tabs. I've tested using EN and PT-BR languages, and it happens in both.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gnome-control-center 1:3.36.0-0ubuntu3
ProcVersionSignature: Ubuntu 5.4.0-20.24-generic 5.4.27
Uname: Linux 5.4.0-20-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Mar 26 23:42:26 2020
InstallationDate: Installed on 2020-03-08 (18 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200304)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

summary: - Searching for "Privacy" in Gnome Search returns "Search" tab entry in
- gnome-control-center
+ "Privacy" tab in gnome-control-center is not findable
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

If I understand it correctly, this is because "Privacy" is no longer a panel, but just a category where privacy related panels are shown. One possible way to improve it is to add the "privacy" keyword to the .desktop files of the applicable panels. I prepared a debdiff which does that, and the attached image shows the result.

For the case you want to test, I also uploaded a modified version of gnome-control-center to this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/gnome-control-center

Gunnar Hjalmarsson (gunnarhj) wrote :

Attached please find the debdiff.

One problem with this solution is that it breaks existing translations of the affected Keywords strings. Notifying the translators may compensate for that a bit.

Sebastien: Any thoughts on the idea?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: Confirmed → In Progress
tags: added: patch regression-release

Thanks for the quick fix, Gunnar!

I installed the pkg from your ppa and i now i get as result the categories contained in Privacy tab, just as you said.

It's not quite the same behavior as the other tabs and it may confuse a little bit, but i think it's quite easy to get the idea. I believe it's a great improvement of what it was.

Sebastien Bacher (seb128) wrote :

@Gunnar, could you send that change upstream to gitlab or discuss with Robert Ancell?

It feels a bit late to break translations, I'm not confident we will get those redone for most locales in time. One alternative approch could be to append the keywords from the code side to all subpanel from a category, it also have the avantage to require to translate the category only once and mean not breaking existing translations...

Sebastien Bacher (seb128) wrote :

@Gunnar, it's probably worth reporting upstream for discussion.

The code adding the keywords seems to be there
https://gitlab.gnome.org/GNOME/gnome-control-center/-/blob/master/shell/cc-shell-model.c#L241

you could imagine doing a

if panel = 'name' or 'othername'; then

Sebastien Bacher (seb128) wrote :

if panel = 'name' or 'othername' or 'thirpanel'; then
    keywords += _('Privacy')

(pseudo code to give the idea)

That seems hackish though, probably best to just propose your patch adding the keywords upstream for next cycle

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for considering it, Sebastien. I submitted an upstream merge request:

https://gitlab.gnome.org/GNOME/gnome-control-center/-/merge_requests/732

Gunnar Hjalmarsson (gunnarhj) wrote :

The MR was merged into upstream master. So let's finalize it next cycle by adding the "privacy" keyword to 0015-connectivity-add-network-connectivity-checking-toggl.patch too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.3-1ubuntu1

---------------
gnome-control-center (1:3.36.3-1ubuntu1) groovy; urgency=medium

  * New upstream version rebased on Debian (lp: #1884063)

  [ Gunnar Hjalmarsson ]
  * debian/patches/0030-temporarily-revert-alt-char-key.patch:
    - Change po/POTFILES.in too, so dh_translations can create
      gnome-control-center-2.0.pot.
  * d/p/0015-connectivity-add-network-connectivity-checking-toggl.patch:
    - Add "privacy" to Keywords in the .desktop file in line with
      https://gitlab.gnome.org/GNOME/gnome-control-center/-/commit/05f3cb67
      (LP: #1869288)

  [ Marco Trevisan (Treviño) ]
  * d/p/0008-Allow-tweaking-some-settings-for-Ubuntu-Dock.patch:
    - Ensure dock position is respected in RTL (LP: #1876937)
    - Add proper matching the dock monitor ID (LP: #1877108)
  * d/p/0024-display-Allow-fractional-scaling-to-be-enabled.patch:
    - Improve fractional scaling toggling (LP: #1876891, #1876894)
    - Look for proper fractional scaling key in Wayland and X11 (LP: #1871864)
  * d/p/0031-fingerprint-dialog-Don-t-limit-the-number-of-maximum.patch:
    - Don't make flowbox children selectable (LP: #1877441)

 -- Sebastien Bacher <email address hidden> Thu, 18 Jun 2020 13:44:56 +0200

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers