[FFe] Add method to enable fractional scaling

Bug #1868019 reported by Robert Ancell on 2020-03-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Robert Ancell
Focal
Medium
Robert Ancell

Bug Description

[Impact]
Fractional scaling is currently requires enabling an experimental feature in Mutter to use it. We would like this feature to be easily enabled by users. A lot of modern hardware supports high DPI displays and these are often not usable without some form of fractional scaling.

[Test Case]
1. Open Settings
2. Select Displays panels

Expected result:
Scale can be set to fractional values (e.g. 125%). There is a UI control to enable fractional scaling (disabled by default).

Observed result:
Scale can only be set to multiples of 100% unless the feature was enabled. No UI control is shown for Fractional scaling.

[Regressional Potential]
New UI code risks introducing new bugs. Users enabling fractional scaling may trigger new bugs.

Robert Ancell (robert-ancell) wrote :

Screenshot showing current implementation. Awaiting text from design for labels. The text should appropriately warn the consequences of enabling fractional scaling.

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-control-center (Ubuntu Focal):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

Requesting a UI freeze exception for this with the rationale being in the bug description. The wording on the UI might change before this is released, but no other changes are required.

Changed in gnome-control-center (Ubuntu Focal):
status: Triaged → New
description: updated
summary: - Add method to enable fractional scaling
+ [FFe] Add method to enable fractional scaling
Robert Ancell (robert-ancell) wrote :

Messages sent to the documentation and translation mailing lists, currently awaiting moderation.

Doug Smythies (dsmythies) wrote :

Ya, those e-mails to the lists were too big, due to big html and with an embedded png file. So they bounced even after being approved in moderation. I sent an edited e-mail to the lists.

Gunnar Hjalmarsson (gunnarhj) wrote :

The applicable docs page looks like this:

https://help.gnome.org/users/gnome-help/stable/look-resolution.html

So it would lag with respect to this change, but the UI difference is small and self-explanatory, so I think this is ok from a docs POV.

It looks like this will add one or two new translatable strings. If so, please notify the translators as soon as they are available at LP for translation.

Łukasz Zemczak (sil2100) wrote :

Seems a bit late, since this is something I'd love for users to be able to experiment with on the Beta images (which it might be too late already). Have the packages built successfully somewhere already? Could you provide some links to a PPA or logs? I assume you have tested this thoroughly too - was this dogfooded by other users as well?
Also, this will just require a new g-c-c, no changes to mutter needed, correct?

Seeing a +1 from Gunnar, I think we might consider approving this.

Sebastien Bacher (seb128) wrote :

> Have the packages built successfully somewhere already? Could you provide some links to a PPA or logs?

I built it locally but we didn't have it in a ppa. I uploaded now but the builders have long queue due to the ongoing archive rebuild
https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/ppa/+build/19091117

> I assume you have tested this thoroughly too - was this dogfooded by other users as well?

Robert wrote the patch/tested it and I've given it a round of testing as well now

> Also, this will just require a new g-c-c, no changes to mutter needed, correct?

Correct. The patch is really minor, you can see it there
https://launchpadlibrarian.net/471901518/gnome-control-center_1%3A3.36.1-1ubuntu1_1%3A3.36.1-1ubuntu2~build1.diff.gz

The is no backend change, the feature is available as a gsetting key for some cycle which has been documented/shared on websites, discourse, etc. The change there is just to add a switch in the settings to change the gsettings key value, avoid having to find the document/use the command line to do the job

Łukasz Zemczak (sil2100) wrote :

As mentioned on IRC, ok, this is what I wanted to know - mostly if the fractional scaling feature has been tested on Ubuntu by more users already. If you say it has been built locally, it's good. Let's proceed - approving this FFe. Who knows? Maybe we'll be able to land it for Beta after all?

Changed in gnome-control-center (Ubuntu Focal):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.1-1ubuntu2

---------------
gnome-control-center (1:3.36.1-1ubuntu2) focal; urgency=medium

  [ Robert Ancell ]
  * debian/patches/ubuntu-scaling-option.patch:
    - display: Allow fractional scaling to be enabled (lp: #1868019)

 -- Sebastien Bacher <email address hidden> Tue, 31 Mar 2020 11:31:20 +0200

Changed in gnome-control-center (Ubuntu Focal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers