gnome-control-center crashed with SIGSEGV in gtk_flow_box_select_child()

Bug #1866246 reported by Rodolfo Tischler on 2020-03-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Robert Ancell

Bug Description

Un poco lento en cuanto a la desktop, pero mucho más estable en las descargas de actualizaciones, un error que saltó de la nada.

ProblemType: Crash
DistroRelease: Ubuntu 20.04
Package: gnome-control-center 1:3.35.92-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu18
Architecture: amd64
CurrentDesktop: Budgie:GNOME
Date: Thu Mar 5 17:23:06 2020
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2020-03-05 (0 days ago)
InstallationMedia: Ubuntu-Budgie 20.04 LTS "Focal Fossa" - Alpha amd64 (20200305)
ProcCmdline: gnome-control-center info-overview
ProcEnviron:
 LANGUAGE=es_PY:es
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_PY.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f0aa83b155e <gtk_flow_box_select_child+78>: cmp %rsi,(%rax)
 PC (0x7f0aa83b155e) ok
 source "%rsi" ok
 destination "(%rax)" (0x00000041) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 gtk_flow_box_select_child () from /lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? ()
 g_cclosure_marshal_VOID__STRINGv () from /lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in gtk_flow_box_select_child()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
separator:

Rodolfo Tischler (fitopy) wrote :

StacktraceTop:
 gtk_flow_box_select_child (box=0x558052bca8d0, child=0x558051ee9790) at ../../../../gtk/gtkflowbox.c:4844
 on_interface_settings_changed (self=0x5580527f7b40) at ../panels/ubuntu/cc-ubuntu-panel.c:215
 g_cclosure_marshal_VOID__STRINGv () from /tmp/apport_sandbox_0jy5vb1p/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.6305.0
 _g_closure_invoke_va () from /tmp/apport_sandbox_0jy5vb1p/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.6305.0
 g_signal_emit_valist () from /tmp/apport_sandbox_0jy5vb1p/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.6305.0

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Incomplete
information type: Private → Public
Sebastien Bacher (seb128) wrote :

Looks like it's happening in the new ubuntu panel when changing style
It's also reported on the error tracker
Robert, could you have a look?

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Medium → High
status: Incomplete → Confirmed
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

Turned out to be an uninitialized variable that the compiler wasn't warning about.

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Robert Ancell (robert-ancell) wrote :

Triggered by changing the theme externally to g-c-c (e.g. using dconf-editor) to a non-Yaru theme.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.36.0-0ubuntu2

---------------
gnome-control-center (1:3.36.0-0ubuntu2) focal; urgency=medium

  * debian/patches/0008-Allow-tweaking-some-settings-for-Ubuntu-Dock.patch:
    - Only show appearance panel in Ubuntu session (LP: #1866618)

gnome-control-center (1:3.36.0-0ubuntu1) focal; urgency=medium

  * New upstream release
  * debian/patches/0008-Allow-tweaking-some-settings-for-Ubuntu-Dock.patch:
    - Fix crash when theme changed to unknown value (LP: #1866246)

 -- Robert Ancell <email address hidden> Tue, 10 Mar 2020 12:47:02 +1300

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers