GNOME control center UI does not update dconf setting for magnifier mouse tracking m ode

Bug #1831144 reported by Lee Clark on 2019-05-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Unknown
gnome-control-center (Ubuntu)
Low
Unassigned
Disco
Low
Gunnar Hjalmarsson

Bug Description

[Impact]

If you attempt to change the mouse cursor tracking mode in the gnome control centre UI for the gnome magnifier the radio buttons have no effect. If yous use dconf-editor to manual change the option at: org.gnome.desktop.a11y.magnifier.mouse-tracking the setting will have an effect.

[Test Case]

To reproduce
* Open gnome control centre and select universal access.
* Click on Zoom.
* Toggle between "Keep the mouse cursor centred" and the other two options (proportional and push).
* If you enable Zoom and change these settings they have no effect.
* Open dconf-editor.
* Navigate to:

    org/gnome/desktop/a11y/magnifier/

* Select the mouse tracking entry and change the setting to different values while the Zoom is enabled. The setting will change the way the mouse tracking behaves.

Then install gnome-control-center{,-data,-faces} from disco-proposed and find that the UI now successfully changes the dconf values and the mouse tracking behavior.

[Regression Potential]

The code changes are specific to the Zoom Options window, where some of the options are currently broken. Low regression risk.

Lee Clark (lclark125) wrote :
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

This seems to be an upstream issue; maybe it's related to this commit:

https://gitlab.gnome.org/GNOME/gnome-control-center/commit/6cd94618

The issue is not present in Ubuntu 18.04, at least.

@Lee: Any chance you can file an upstream issue about it?

https://gitlab.gnome.org/GNOME/gnome-control-center/issues

If you do, please post the URL to it here for tracking purposes.

Lee Clark (lclark125) wrote :

Turns out I already reported this on the GNOME gitlab a while back but have had no reply. I've updated it with the new information I've learned. Here is the link: https://gitlab.gnome.org/GNOME/gnome-shell/issues/865

I've looked at the commit but it's not immediately obvious to me why it isn't working or if it is even related to this commit. But I'll look it it more over the weekend.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks! But you filed it as a gnome-shell issue, while my belief is that it is a gnome-control-center one. Hence there is a risk that it doesn't get attention from the right people.

I'm really not sure that the commit I linked to is the culprit. But the panels/universal-access/zoom-options.{c,ui} files are probably involved somehow, and that commit contains the most extensive changes of those files after 3.28 (when it worked).

Lee Clark (lclark125) wrote :

OK, opened a new bug upstream under the correct project this time. https://gitlab.gnome.org/GNOME/gnome-control-center/issues/555

Lee Clark (lclark125) wrote :

I've had a stab at working out what the problem is. I have an idea which I have posted to the upstream bug report. But I've no way to test this out.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks! Hopefully someone familiar with the code is able to use that hint to spot and fix it.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Gunnar Hjalmarsson (gunnarhj) wrote :

Hi again,

I think you were right about what causes the bug. As you may have seen, I wrote a patch and filed an upstream merge request:

https://gitlab.gnome.org/GNOME/gnome-control-center/merge_requests/486

I also uploaded gnome-control-center with the patch applied to this PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/gnome-control-center

It would be great if you could install g-c-c from there and check it out, to confirm that I didn't miss anything.

Gunnar Hjalmarsson (gunnarhj) wrote :

Well, things change.. g-c-c in the PPA is now built with Robert Ancell's patch instead. Still good if you install and test.

Changed in gnome-control-center:
status: Unknown → New
Lee Clark (lclark125) wrote :

Yep, I will test as soon as I get home tonight.

Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
description: updated
Changed in gnome-control-center (Ubuntu Disco):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Low
status: New → In Progress
tags: added: regression-release
tags: added: cosmic
Lee Clark (lclark125) wrote :

I've tested the updated package in the PPA and all the settings now work as expected. Thank you.

Gunnar Hjalmarsson (gunnarhj) wrote :

Fix has been committed to upstream master, and I have submitted a merge proposal for disco.

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-control-center:
status: New → Fix Released

Hello Lee, or anyone else affected,

Accepted gnome-control-center into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.32.2-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Gunnar Hjalmarsson (gunnarhj) wrote :

Verified the test case using gnome-control-center{,-data,-faces} 1:3.32.2-0ubuntu1.1 from disco-proposed.

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.32.2-0ubuntu1.1

---------------
gnome-control-center (1:3.32.2-0ubuntu1.1) disco; urgency=medium

  * d/p/fix-broken-zoom-options.patch:
    - Update dconf settings properly from the zoom options GUI
      (LP: #1831144).

 -- Gunnar Hjalmarsson <email address hidden> Wed, 26 Jun 2019 13:33:00 +0200

Changed in gnome-control-center (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.